1. hamsteak62's Avatar
    I'm new to the forum and hope you guys can help me with a problem with my i727 skyrocket. Over the weekend I was away and connected to a hotel's wi-fi. When it connected I found out it wouldn't update my AP News or the Accuweather widgets that came on the phone from AT&T. Nor can I go out on the web browser with it. Any site I try to go to with the browser comes up as "web page not available."
    Figured it was just a problem with their wi-fi system, since if I turned off the wi-fi and turned on my data package, everything would work fine.
    Got home, connected to my wi-fi and found out I still have this problem. Phone doesn't have any problem if I go to my data package. The best I can figure out is that a setting in my phone was changed somehow and needs to be returned to what it was. Checked all my wi-fi settings.... they all seem fine....same as on my wife's phone (she has the same phone as me)....her's works fine, no problem.... I cleared out the internet explore cache and cleared the history and the cookies out, turned the phone off, turned it back on and still the same problem.
    The phone's wi-fi had been working fine before I tried connecting it to the hotel's wi-fi connection.
    Any help you can give me would be appreicated!!!
    04-09-2012 02:44 PM
  2. Creek's Avatar
    Did you try the smartphone equilivant of the 3 finger salute on a PC. Try a battery pull.
    hamsteak62 likes this.
    04-09-2012 06:00 PM
  3. hamsteak62's Avatar
    Thanks for the suggestion. Tried the battery pull.... no luck...fired the phone back up and it's still the same. If I use the browser, it comes up "web page not available."
    Weird thing is, I can go to Ebay through the Ebay app and I don't have a problem. I can go to my gmail through the app on the phone, no problem. But if I click on anything that brings up a web page, the browser won't display it. In the email, it'll display the email contents, but if I click on a link... it won't go to it.
    Thanks for the battery suggestion though...
    04-09-2012 06:56 PM
  4. hamsteak62's Avatar
    Tried to download a different browser, thinking maybe it's a browser setting stopping me from connecting....downloaded it (dolphin), started it up and it wouldn't connect either. Must be a setting on the phone somewhere that is stopping me from connecting....I just can't find it....went through all the wireless settings, not finding anything to stop me from connecting.... real mystery...must be something I'm overlooking...
    When I go to refresh the AP News widget, I get a "server unavailable" across the app screen. When I do the accuweather refresh, it comes up as "connection failed."
    Any suggestions would be appreciated....
    04-09-2012 10:49 PM
  5. anon(153966)'s Avatar
    I suggest going to your WIFI settings and selecting your HOME WIFI, and choosing forget. Once done, search for it again, and re-select it, then enter said password for it, etc.

    Then test the browser, and let us know the outcome.
    04-10-2012 06:52 AM
  6. hamsteak62's Avatar
    Thank you for the suggestion. I tried it and still no luck. I did notice one thing when I would go and clean out the privacy settings in the browser. I clear the cache, no problem.... cleared the cookies, no problem. But when I go to clear the history, I click on it, hit the ok button to clear it and in about 4 seconds I get a screen with Sorry! on it and the message, The application Web (process com.android.browser) has stopped unexpectedly. Please try again. Then the button under this reads "Force close."
    Every time I try to clear the history, I get this message. Any ideas, anyone?
    04-10-2012 09:52 AM
  7. anon(153966)'s Avatar
    I know this is a pain, but, reset the device to factory default, and then load your apps again, etc...

    Better still, do you have MyBackup? If yes, backup first, then restore. After the restore test the WIFI etc., if all okay, then do a restore of the MyBackup.
    hamsteak62 likes this.
    04-10-2012 11:10 AM
  8. rocker22dallas's Avatar
    mybackup doesnt save app data. if you are rooted, use titanium backup.

    try the forget method but doing it for all networks, make sure you don't have a static IP set, check your dns settings, make sure there is no VPN set.

    i wish i could give a step by step but i have ICS installed on my sgs2

    edit: make sure DHCP is enabled. this is used to pull an ip address from the wireless access point
    04-10-2012 11:24 AM
  9. hamsteak62's Avatar
    Hi Guys,

    Just wanted to thank you both for the suggestions. I really don't want to do a factory reset on the phone if I don't have to. That's my last resort, I'm saving it for.

    Also checked the settings like rocker22dallas suggested. Every thing was good there.

    I'm doing a little more research from work on the problem and will try something I came across when I get home tonight. If it works, I'll let you know what I did, so anyone else with this problem can fix it.

    Keeping my fingers crossed...hope it works!!
    04-10-2012 07:39 PM
  10. rocker22dallas's Avatar
    Try setting a static ip. Home integrated routers usually have a default address of If so, try the following settings:
    IP address:
    Subnet mask:
    Default gateway :
    Dns: and

    This will rule out an issue with dhcp

    Download terminal emulator (can do from computer at play.google.com)
    Connect to wifi using either dhcp or static addressing
    Open terminal emulator and ping and www.google.com

    If both are successful, everything below the transport layer works, and there is an issue above the transport layer. (using osi model)

    You said you have cleared cookies and browser data? Try going into settings> application > all tab> Internet and clear all data and cache from there.

    If this doesn't fix it, that rules out application layer.

    So that leaves presentation and session.

    If earlier you couldn't ping, there is an issue with the actual connection.

    It is hard to error check the network when I don't have access to it.

    Sources: currently enrolled in cisco networking academy, have my a+ cert, and am working on my ccna, have completed cisco discovery and it essentials, and am currently in cisco exploration.

    Sent from my Galaxy S II epic 4g touch. 4.0.3 FC05 ICS
    04-10-2012 10:13 PM
  11. hamsteak62's Avatar
    Hi rocker22dallas,

    I had gone into the applications yesterday and cleared out the data from there...I was hoping that would fix my connection problem. I had to wait until I got home from work to connect to my home wifi to see if it worked. No luck....

    It fixed my force close error when I would try to clear out the browser history, but I still can't get the browser to connect to the internet. My apps can connect to the internet, but the internet browser, the AP news widget and the Accuweather widget won't connect. You'd think either everything would work, or nothing would work. It's really weird having this problem.

    Then when you turn on the data package, everything works fine....

    Looks like I might be busy this weekend putting the phone back to factory default settings.....
    My last resort, unless someone can come up with something I might of missed....

    Thanks for the help!
    04-11-2012 10:26 AM
  12. rocker22dallas's Avatar
    try downloading wamp (windows program) on your computer. this is a local web server.

    once installed, type the ip address of the computer you are trying wamp on into your phone (while on wifi) by going to start>run>type cmd>enter>type ipconfig (assuming it is on the same local network)

    type that ip address into your internet browser to see if you can access the wamp default webpage (you will have to click on it in the tray and click put online otherwise you will gget an apache error)

    this will mean that you have access through the wifi via the web browser and help determine the issue.

    sorry its a lot of running around and trying different things, but troubleshooting is the first step to fixing the problem
    04-11-2012 10:59 AM
  13. lithprintr's Avatar
    Settings/Wireless and network/Mobile networks/Access Point Names/ Reset to default. Worth a try?
    hamsteak62 likes this.
    04-11-2012 11:37 AM
  14. hamsteak62's Avatar
    sorry, had to remove this as I thought my message above didn't post.
    04-11-2012 12:29 PM
  15. hamsteak62's Avatar
    Hi Lithprintr,

    I tried your suggestion, but no luck.

    Rocker22dallas, thanks for the suggestions.... I'll have to try it when I get a minute. I'm overwhelmed at the moment with things on the home front.

    Now I have a new problem to go with my origional one. I was looking at my phone today and found out that my icons for three of my apps have disappeared. I have a shadow of a droid head with a little sd card emblem at the lower right. If you click on this, a message comes up that this application isn't installed on my phone.

    This is true to a certain extent, I moved the app to the sd card but it should still be there. So I go to setting>applications>on sd card... pick that app...comes up to the screen where I can either move it to the phone, clear the data or uninstall it.

    If I pick move to phone and tap on it, I get Failed to move application: application not found. Then you have to choose Ok. Now, it's not found, but if I choose uninstall, it actually uninstalls it and tells me that it successfully uninstalled it. Now, how can you uninstall something when in two other spots it's telling you that it doesn't exist?

    This is getting weirder and weirder.... looks like a factory reset unless some one can figure this one out... must be something corrupted somewhere....

    Thanks everyone for your help so far with my problem.
    04-12-2012 06:18 PM
  16. hamsteak62's Avatar
    Ended up resetting phone and have most of the apps put back in.
    Seems to be working now....

    Thanks everyone for the help....
    04-13-2012 04:28 PM
  17. rocker22dallas's Avatar
    Glad to hear it's working. I've had the app disappearing with a little sd symbol over it a few times, fixed by downloading and installing from market and opening, and it pulled all my saved save data from the broken installation

    Sent from my Galaxy S II epic 4g touch. 4.0.3 FC05 ICS
    hamsteak62 likes this.
    04-13-2012 07:07 PM
  18. robor007's Avatar
    I've had the same issue with WiFi and connectivity. What sucks is it's intermittent in both the WiFi spot and time. Sometimes it works fine. Other times I can't even get google.com to load. I've tried reboots and battery pulls (which shouldn't be necessary) and the issue always comes back. My fix is to turn off wireless and use 4G/LTE. Hopefully, AT&T will fix this crap soon.
    04-17-2012 12:09 PM
  19. jspuky's Avatar
    pls @ Hamsteak62 how did you resolve the problem with your phone, i am having similar problem pls anyone who has also experienced this can inbox me on jspuky@yahoo.com or write me here. I shall be most glad.
    12-03-2012 08:41 PM
  20. ViB BaN's Avatar
    i got the same problem, i changed ip to static from dhcp and then back to dhcp and it worked fine. i dont know what was the problem but it fixed it for me
    10-21-2015 07:23 AM