1. jbautista83's Avatar
    I charge my phone via usb cable directly onto my computer sometimes, and every now and then I get a "USB device not recognized" error message. It is hit and miss, and I'm not exactly sure why. Does anyone have the same thing happen to them?
    05-26-2012 10:24 AM
  2. jdale2000's Avatar
    I have the same problem - i even installed new Samsung usb driver - and on wont work on at least 3 computers

    Any help? Thanks

    My son has a s2 and went on my computers with no problem - - ie something with the phone
    05-28-2012 11:50 AM
  3. jdale2000's Avatar
    So I guess us 2 are the only ones having this problem... I just tried a XP with latest Samsung driver installed and it doesnt reconize the usb. I guess I will have to go to ATT and have them take a look at it!
    05-30-2012 08:19 AM
  4. raed_alassi's Avatar
    i have the same problem >>> i think the problem in usb output in galaxy SII .. may any help??
    06-27-2012 07:10 AM
  5. robert n's Avatar
    Try this...it worked for me...Except I started getting this all of the sudden and Every single time I would connect to my PC.

    I read this solution on the internet but did not think it would work...but I took 2 minutes and tried it and it worked! give it a try..you only have to lose 2 minutes...

    1. hold your phone and look at the micro USB connector on the bottom edge of your Skyrocket

    2. you will see a "tongue" inside the USB port.

    3. put something "non metalic" (I used a flat wooden toothpick). Gently, lift up the "tongue"..
    I used a twirling motion on my toothpick to raise the tongue up a little bit. Don't Go PRYING it up...just be gentle because you don't want to break your toothpick inside the phone or break the Tongue.

    I did this and now I do not get the "USB device is not recognized". Give it a try and post here if it worked for you. Spread the word if it does.

    Good Luck!
    06-28-2012 08:49 AM
  6. Xyclos's Avatar
    @robert n

    that worked. thank you.
    01-19-2013 07:09 PM
  7. bigmazey's Avatar
    hey worked wonders thanks for this fix.
    04-22-2014 04:00 PM