02-22-2017 11:31 AM
136 ... 23456
  1. itseranga's Avatar
    +1.. You helped me lot.
    01-15-2014 02:35 AM
  2. Prafull Chaturvedi's Avatar
    Hi, It really worked. Thanks.
    01-15-2014 05:33 AM
  3. Prafull Chaturvedi's Avatar
    Take care while using toothpick. In my case it did break and I had to remove the broken part with help of pin but of course after switcing off the phone and remove the battery. Please be careful. Good luck.
    01-15-2014 05:36 AM
  4. Gene Souza's Avatar
    Amazing...it worked. Tried the toothpick, but did not want to pry to hard...did not work. Then tried plastic pick to clean connections...did not work. Then used my wife's cutical tool to pry up..and it works.
    Silly Samsung.
    01-20-2014 07:01 PM
  5. FR Sheffield's Avatar
    Reading the solution to fiddle with the connector using the toothpick, I just changed the cable and it worked. I had a cable plugged in to a USB port all the time for charging and for remote storage access (photos) but all the sudden it stopped letting me connect to my phone's storage but the phone still showed as "charging". Changing the cable lets me do both again. Putting the old cable back on and I get the USB device not recognized message again but the phone starts to charge.
    01-24-2014 12:28 PM
  6. bryanlinas's Avatar
    Thanks man..that did it
    01-24-2014 11:34 PM
  7. Mario DCruz's Avatar
    This is because your device is connecting to the laptop as a "media device". This is changed easily by (after connecting your USB cable to the PC and the phone) pulling down the notification bar from the top of the screen (the black bar at topmost with small icons on it for new users). The first entry should see is called "Ongoing"and it tells you how the device is connected to the PC (either as a camera or a media device-you can activate (by touching) either the camera optionif you want to access your files or the media option if you want to play music or videos on your computer directly.
    Lastly, depending on how you use your camera in between USB connection times you would have to do this again if your device is not recognised the next time you plug it in (because sometimes when it's on a wireless network the device automatically switches back to media device)
    please post back if this helps
    02-01-2014 09:51 PM
  8. chinitopex chinitopex's Avatar
    hi guys i have troybbles my phone samsung SII not recognize the pc
    and not turn on please help me?? SII is dead
    someone can tell me if the method can use in SII ??

    02-07-2014 01:55 PM
  9. deafcheer's Avatar
    This should be a video tutorial! I have trouble understand this instruction.

    Few hours ago, it was working but now it won't work.
    02-09-2014 09:45 PM
  10. kronos77's Avatar
    Awesome it worked like a charm, I spent almost an hour trying to re-install the driver and boot my laptop numerous times. Never thought the solution would be so simple and non-technical Thanks s ton!
    02-10-2014 05:00 PM
  11. Renaldo du Pisani's Avatar
    Hi Guys

    Same problem, USB device not recognised by Windows. Lifting up the tongue did not work for me, but this did: Plug the phone in, restart the phone, windows recognises it. No problems.
    02-27-2014 05:15 AM
  12. adejmoore's Avatar
    Oh my days this worked. So not expecting it to. Thanks a million.
    03-04-2014 11:53 AM
  13. Andre Terblanche's Avatar
    THanks for that Advice on USB device not recognized!!

    took me 1 minute...
    03-21-2014 12:18 AM
  14. Chung Hong Tam's Avatar
    Thank You for that method ! It worked you are a genius
    03-22-2014 08:23 AM
  15. kote sichinava's Avatar
    Its take 10 seconds and all is works Thinks :*
    03-24-2014 02:17 PM
  16. rohanjoe's Avatar
    Craziest Idea.. pushing the USB tongue of the Phone ... but it Worked ... Thanks..
    03-25-2014 05:53 AM
  17. myonecent's Avatar
    For people who like me couldn't solve this problem.

    I tried to bend this tongue with no better success afterwards, but I switched my connection cable to another one then it worked !

    It appears that the other one - non official micro usb - was poorly featured, switching back to the original Samsung cable solved the issue for me.
    04-23-2014 07:27 AM
  18. Miguelito Chugani's Avatar
    Thanks Bro! It does work!
    05-03-2014 07:24 AM
  19. Akira Alday's Avatar
    thank men your my savior :P
    05-09-2014 10:39 PM
  20. Lauren Enright's Avatar
    I tried this with absolutely no expectations and it actually worked! you've saved a lot of stress thanks mate.
    05-15-2014 12:34 AM
  21. Szasz Hunor's Avatar
    It worked 100 % ! I only signed up so I can thank you ! You saved me of a lot of trouble ! Thank you again !
    05-23-2014 12:36 PM
  22. Bruno Garcia2's Avatar
    05-26-2014 11:11 AM
  23. Laurence Milton-Goodhead's Avatar
    wow, it worked, my samsung gs2 is now fully functional again, thanks a million
    05-28-2014 11:00 AM
  24. essc7274's Avatar
    Hello All.

    Please Help.

    I have a Samsung Galaxy 3 mini. I tried to root it, unfortunately used the wrong ROM and it went into Bootloop.
    Then I tried installing again, but that did not work either

    My phone can get into download mode, but my computer does not recognize it. It comes up as "other devices"

    When I right click on properties (in device manager) there is no device name.
    When I try to install the drivers, My PC says drivers are installed and up to date.

    How can I restore my phone, when my PC won't recognize it.
    05-28-2014 03:15 PM
  25. Vicky Muscat's Avatar
    what can i do as my samsung s2 is not recognize??
    06-25-2014 01:33 PM
136 ... 23456