06-18-2016 08:44 PM
217 ... 34567 ...
tools
  1. Rachel Leigh Collins's Avatar
    What should I use for my galaxy s3 settings I also have straight talk and use a at&t compatible sim. Im not able to send pics or use internet without wifi
    10-09-2013 09:37 PM
  2. Adiel Colon's Avatar
    I have the SAME phone (Samsung Galaxy S2 Skyrocket with an AT&T SIM from StraightTalk) and am having the EXACT SAME issue. I have tried about 100 different setting and NOTHING seems to work other than sending and receiving texts and being able to get on the internet. I am not able to send/receive picture messages.
    lamsonbw and tammy62766 like this.
    10-12-2013 10:48 AM
  3. Vee Ayee's Avatar
    yest another galaxy 2 skyrocket user who cannot send recieve pictures via mms
    lamsonbw and tammy62766 like this.
    10-14-2013 04:37 AM
  4. UNVNSABAN's Avatar
    I just ported over a Pantech Flex P8010 to Straight Talk by using a Straight Talk At&t sim. Getting 4g LTE speeds for $45 a month is sweet so far. At first only web, telephone, and texts worked. I could send MMS but could not receive them..and then this morning when I got some time I was trying some settings out and mixing and matching and I came up with the following APN settings that worked for me..I couldn't find anything any where pertaining to this phone and any APN settings. So I hope if anyone is having trouble with MMS & bringing a Flex to Straight talk this will help out!

    Name: straight talk
    APN: tfdata
    Port: 80
    MMSC: http://mms-tf.net
    MMS Proxy: mms3.tracfone.com
    MMS port: 80
    Authentication type: PAP
    APN Type: default,supl,mms
    APN protocol: IPv4
    APN roaming protocol: IPv4

    Other settings not listed are left blank. Also if at first it doesn't work, let it soak in for a few minutes after you select this setting and then restart the phone. Again hope this helps!
    10-17-2013 03:50 PM
  5. spanky007's Avatar
    I am so frustrated at this point....I have read so many of these posts saying this apn works ...I have tried so many, called straight talk, talked with a guy who run me around for almost 2 hours doing the same things over and over then told me I have to update so I updated my skyrocket to jellybean (its now reads 4.1.2 under which version). I was all excited thinking this would solve my apn problem....nope I tried a new bunch of apn settings, old ones, new ones, the one straight talk gives, the ones I read here and else where and nothing lets me download a photo. I can send them ok but when I receive them and try to download message says sorry downloadin has stopped.....Please anybody, somebody help!!!
    10-17-2013 08:19 PM
  6. royal2blue's Avatar
    Ps PAP doesnt matter but gl
    10-17-2013 11:19 PM
  7. royal2blue's Avatar
    This worked for my at&t S3Name: straight talk
    APN: att.mvno
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Proxy: mms3.tracfone.com
    MMS port: 80
    Mcc: 310
    MNC: 410
    Authentication type: none
    APN Type: default,supl,mms
    APN protocol: IPv4

    Tip: no spaces in "default,supl,mms"
    Good luck. Not sure bout tmobile :-)
    gunnshot likes this.
    10-17-2013 11:23 PM
  8. labrishaford's Avatar
    I have a straight talk phone already, but I am getting the att samsung galaxy 2 I wanted to ask will I have to get another sims card or can I continue to use my same one, and just change the APN ???
    10-18-2013 11:52 AM
  9. UNVNSABAN's Avatar
    straight talk requires you use their straight talk(tracfone) at&t sim card.
    10-18-2013 12:43 PM
  10. UNVNSABAN's Avatar
    Ps PAP doesnt matter but gl
    using both the Authentication Type: PAP and the APN TYPE: default,supl,mms made the world of difference on my Pantech Flex..If I change any one of the two, MMS quits working.
    10-18-2013 12:48 PM
  11. blkveloster's Avatar
    This worked for my at&t S3Name: straight talk
    APN: att.mvno
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Proxy: mms3.tracfone.com
    MMS port: 80
    Mcc: 310
    MNC: 410
    Authentication type: none
    APN Type: default,supl,mms
    APN protocol: IPv4

    Tip: no spaces in "default,supl,mms"
    Good luck. Not sure bout tmobile :-)
    This worked for me (internet and mms) on my Galaxy s2 skyrocket (running gingerbread) with Straight Talk (att) except:
    Apm Type: internet+mms+supl
    There was no choice for APN protocal

    I wonder what happens if I upgrade from gingerbread!?!?!
    10-24-2013 08:56 PM
  12. blkveloster's Avatar
    This worked for my at&t S3Name: straight talk
    APN: att.mvno
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Proxy: mms3.tracfone.com
    MMS port: 80
    Mcc: 310
    MNC: 410
    Authentication type: none
    APN Type: default,supl,mms
    APN protocol: IPv4

    Tip: no spaces in "default,supl,mms"
    Good luck. Not sure bout tmobile :-)
    This worked for me (internet and mms) on my Galaxy s2 skyrocket (running gingerbread) with Straight Talk (att) except:
    APN Type: internet+mms+supl
    There was no choice for APN protocal

    I wonder what happens if I upgrade from gingerbread!?!?!
    10-24-2013 08:59 PM
  13. grenefroggie's Avatar
    If you don't have the option to set it, I wouldn't worry too much about it. The protocol it is requiring, to my knowledge, is an internet protocol (IPv4). If you have even data, then there is no need to specify it.
    10-26-2013 03:49 PM
  14. Connie Hall2's Avatar
    I have this phone Samsung Galaxy s2 skyrocket through ST AT&T and I also have Go SMS pro downloaded to receive pics.

    - - - Updated - - -

    I have this phone Samsung Galaxy s2 skyrocket through ST AT&T and I also have Go SMS pro downloaded to receive pics.
    10-26-2013 10:27 PM
  15. blkveloster's Avatar
    now this setting no longer works!
    James Gearhart likes this.
    10-27-2013 07:43 AM
  16. BobbyT454's Avatar
    A week ago I started using an ATT GS2 on straight talk and everything was fine but now I can't receive MMS. Has anyone had this happen? have the APN settings changed? Do I have to change anything when my service auto-refills?
    10-28-2013 01:39 PM
  17. Dutch29's Avatar
    I just took a trip to Las Vegas in September. As soon as I landed at the airport I had no Internet or MMS service.
    These WERE the settings that WERE working great for me (in Louisville, Kentucky) Before I landed in Las Vegas.

    Name: straight talk
    APN: att.mvno
    Proxy: not set
    Port: not set
    User name: not set
    Password : not set
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms3.tracfone.com (CHANGED TO 66.11.209.33 when I got to Las Vegas)
    MMS port: 80
    MCC:310
    MNC: 410
    Authentication type: none
    APN type: Internet+ mms
    Bearer: Unspecified


    As you see, I have noted that I had to change the MMSC proxy to 66.209.11.33. After I did that everything worked beautifully. I did not change the settings back when I got back to Kentucky. Hope this helps someone.
    10-28-2013 02:51 PM
  18. Dutch29's Avatar
    I just took a trip to Las Vegas in September. As soon as I landed at the airport I had no Internet or MMS service.
    These WERE the settings that WERE working great for me (in Louisville, Kentucky) Before I landed in Las Vegas.

    Name: straight talk
    APN: att.mvno
    Proxy: not set
    Port: not set
    User name: not set
    Password : not set
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms3.tracfone.com (CHANGED TO 66.11.209.33 when I got to Las Vegas)
    MMS port: 80
    MCC:310
    MNC: 410
    Authentication type: none
    APN type: Internet+ mms
    Bearer: Unspecified


    As you see, I have noted that I had to change the MMSC proxy to 66.209.11.33. After I did that everything worked beautifully. I did not change the settings back when I got back to Kentucky. Hope this helps someone.

    At&t Galaxy S2 Skyrocket.
    10-28-2013 02:51 PM
  19. BobbyT454's Avatar
    Thank for trying but unfortunately I can't get MMS or data using the above settings. Maybe it's because I'm in Philadelphia. I called straight talk and they were absolutely no help and basically told me "that happens all the time and you're screwed".
    Any other suggestions?
    10-28-2013 03:26 PM
  20. Dutch29's Avatar
    Sorry, that's all I have for you right now. I would just keep looking on the Internet. I'm sure you'll find a setting that will work for your phone.
    10-28-2013 03:42 PM
  21. BobbyT454's Avatar
    I somehow am now able to receive MMS but still cannot send. All i did was toggle between my APN's. I'll try the above settings. Will i go through this every month?
    10-28-2013 06:21 PM
  22. BobbyT454's Avatar
    i.e. will this happen every time my service refills?
    10-28-2013 06:44 PM
  23. Dutch29's Avatar
    No. Once you get the settings figured out, service refills will have no affect on it.
    10-28-2013 07:33 PM
  24. BobbyT454's Avatar
    No. Once you get the settings figured out, service refills will have no affect on it.
    Thanks. That's definitely good to know. It's odd that it worked perfectly and then completely lost MMS. I messed with the MMS proxy a bit more tonight and got to the point where I am regularly receiving MMS but only can send when I change the MMS proxy, save, change the MMS proxy back, and save again, and that only works sometimes. Any thoughts on why that would happen?
    Thank you for all the help.
    10-28-2013 10:35 PM
  25. GloriousGlory's Avatar
    I still can't download MMS messages. I can send them only.

    Before I got my LTE sim card which used att.mvno, I could send and receive MMS. I called Straight Talk and they blamed the phone I'm using which is the Note 3..
    10-29-2013 07:58 AM
217 ... 34567 ...

Similar Threads

  1. Replies: 49
    Last Post: 05-10-2014, 01:38 PM
  2. Samsung Galaxy SII Skyrocket for AT&T
    By nicholasdejohn in forum Marketplace Archive
    Replies: 1
    Last Post: 05-23-2012, 09:40 PM
  3. (guide) reference HOW TO SET UP ADB AND FASTBOOT FOR UBUNTU
    By asadullah in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 12-20-2011, 05:40 PM
  4. A noobs review of the Samsung Galaxy SII Skyrocket and Android
    By DFWPhotoguy in forum Samsung Galaxy S II Skyrocket
    Replies: 12
    Last Post: 11-25-2011, 03:56 PM
  5. cancel home internet and opt for hotspot instead?
    By kelton in forum Droid Bionic
    Replies: 7
    Last Post: 09-07-2011, 08:13 PM
LINK TO POST COPIED TO CLIPBOARD