1. David420's Avatar
    Okay, so here's the deal i bought the phone from a friend, it was AT&T Every time i try to make a phone call on it it instantly says no signal, i'm still playing with the APN settings and trying to get it to work but half the time when the phone boots up it doesn't run the media scans and locks up, and the other half the time it doesn't even register there's a sim-card inserted.

    Edit: sim card is now working 100% of the time post root, phone randomly is shutting off while in use, while charging goes from 36% (after about 30 minutes of charging) reboots, then is at 17%. seems to lock up(as previously stated) i pull the battery, put it back in and it's at 27% battery.. is there some kind of connection here? xD
    09-25-2013 04:08 PM
  2. Kevin OQuinn's Avatar
    Okay, so here's the deal i bought the phone from a friend, it was AT&T Every time i try to make a phone call on it it instantly says no signal, i'm still playing with the APN settings and trying to get it to work but half the time when the phone boots up it doesn't run the media scans and locks up, and the other half the time it doesn't even register there's a sim-card inserted.

    Edit: sim card is now working 100% of the time post root, phone randomly is shutting off while in use, while charging goes from 36% (after about 30 minutes of charging) reboots, then is at 17%. seems to lock up(as previously stated) i pull the battery, put it back in and it's at 27% battery.. is there some kind of connection here? xD
    Did you get it unlocked through AT&T?
    09-26-2013 01:55 PM
  3. David420's Avatar
    Did you get it unlocked through AT&T?
    No, phone is unlocked via root, also noticed that the phone only seems to reboot it's self when the battery is being used.
    ordered a replacement battery, should be here tomorrow or Saturday, Though the phone maintaining signal is another story..
    the coverage in my area is good, the internet only seems to want to work on it only after enabling/disabling flight mode, if the new battery doesn't
    fix my problems i'm going to demand a refund lol.

    I should also probably say that i tried a factory reset, but to no avail.
    09-26-2013 02:51 PM
  4. Kevin OQuinn's Avatar
    No, phone is unlocked via root, also noticed that the phone only seems to reboot it's self when the battery is being used.
    ordered a replacement battery, should be here tomorrow or Saturday, Though the phone maintaining signal is another story..
    the coverage in my area is good, the internet only seems to want to work on it only after enabling/disabling flight mode, if the new battery doesn't
    fix my problems i'm going to demand a refund lol.
    It might need to be carrier unlocked is the point I was trying to make. Bootloader unlock/root aren't the same thing. It's a code that you get from the carrier to allow it to work uninhibited on other compatible networks.
    09-26-2013 02:57 PM
  5. David420's Avatar
    and what of the other problems?

    I have an old LGThrive that works flawlessly on straight talk (also at&t) without even rooting it.

    is there a way around having to go through the carrier? i have a pretty strong feeling they'd charge me.
    09-26-2013 03:02 PM
  6. Kevin OQuinn's Avatar
    and what of the other problems?

    I have an old LGThrive that works flawlessly on straight talk (also at&t) without even rooting it.

    is there a way around having to go through the carrier? i have a pretty strong feeling they'd charge me.
    As for the other problems I couldn't say. Did you originally purchase the phone from AT&T, fulfilled your contract, then moved to Straight Talk? Or did you get it from someone else? Worst case scenario is that you call AT&T and they do want to charge you (unlikely, I've heard good things about getting unlock codes from AT&T) just hang up the phone. I imagine they'll want the IMEI of the phone, and if it's clean you'll probably get the code. That being said, that might not have anything to do with your data inexplicably going in and out.
    09-26-2013 03:41 PM
  7. David420's Avatar
    might just say the heck with it and buy a straight talk S2 and get a refund from my friend. lol this thing is more trouble than it's worth.
    09-26-2013 03:43 PM
  8. Kevin OQuinn's Avatar
    might just say f%$# it and buy a straight talk S2 and get a refund from my friend. lol this thing is more trouble than it's worth.
    Well that's also an option.
    09-26-2013 04:08 PM
  9. David420's Avatar
    Well that's also an option.
    speaking of options, i actually just flashed Cyanogenmod 10.1.3 and it fixed the crashing, started looking around on the net and found some resolutions to problems that are for the GS2 (standard) which are usually either hardware, or some kind of system corruption, Well as far as the random signal loss. Alot of people suggest flashing firmware upgrades to the radio.

    Update: i tried flashing a radio driver, no such luck, wifi actually seems to be the source of the crashing now. (start wifi> open web page> almost instant crash.)
    09-27-2013 07:28 PM
  10. Kevin OQuinn's Avatar
    speaking of options, i actually just flashed Cyanogenmod 10.1.3 and it fixed the crashing, started looking around on the net and found some resolutions to problems that are for the GS2 (standard) which are usually either hardware, or some kind of system corruption, Well as far as the random signal loss. Alot of people suggest flashing firmware upgrades to the radio.

    Update: i tried flashing a radio driver, no such luck, wifi actually seems to be the source of the crashing now. (start wifi> open web page> almost instant crash.)
    I don't do too much flashing of radios, but maybe there are different ones that will affect the wifi performance.
    09-28-2013 08:52 AM
  11. David420's Avatar
    I don't do too much flashing of radios, but maybe there are different ones that will affect the wifi performance.
    could it be hardware related? isn't the GSM/Wifi/loudspeaker all one piece inside the phone? i'm determined to get this thing working by any means, my friend is a.. well... won't give me a refund
    09-28-2013 10:49 AM
  12. Kevin OQuinn's Avatar
    could it be hardware related? isn't the GSM/Wifi/loudspeaker all one piece inside the phone? i'm determined to get this thing working by any means, my friend is a.. well... won't give me a refund
    I guess it could be. As far as the internal layout I have no idea.

    Sent from my Nexus 4 using Tapatalk 4
    09-28-2013 03:28 PM
  13. David420's Avatar
    Phone's been water damaged, and the GSM antenna is fried according to a "samsung representative".. probably either going to get it refurbed or try and sell it off to someone else that wants a headache.
    09-29-2013 01:32 AM

Similar Threads

  1. Flashing battery when phone is off and on charge
    By Zari Jacobs in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 11-29-2013, 07:06 AM
  2. returned my phone after a week..
    By philly in forum LG G2
    Replies: 46
    Last Post: 09-30-2013, 01:18 PM
  3. Came from iPhone having text issues
    By TANGOxOMEGA in forum General Help and How To
    Replies: 5
    Last Post: 09-28-2013, 10:15 PM
  4. Don't Run With a Plasma Sword on Google Play
    By XperimentalZ in forum Android Games
    Replies: 1
    Last Post: 09-26-2013, 11:03 PM
  5. Replies: 2
    Last Post: 09-25-2013, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD