1. Rizaria's Avatar
    Finally gave up the ol iPhone 3G and "upgraded" to an SGSII. I paid a lot of money and figured it'd work, but there are two extremely niggling problems that I cannot fix.

    1. No one calling me can hear me unless I use speakerphone. I did successfully fix that once with some settings accessed by typing in a number and changing a few things, but that reset when I reset my phone...I've yet to be able to fix this.

    2. When listening to music on my massive Sennheiser headphones I can't hear much at all. On the iPhone if I'd even approached full volume, I woulda blown my head off, on the SGSII, even on full, Metallica sounds like a soothing lullaby.

    Are there any fixes for these issues? Or are these things that perhaps are fixed simply from having a different firmware? An almost 800 dollar phone, it'd be nice if it did two basic functions without flopping.

    All help is appreciated.

    Oh and forgot to mention, I know the mic works thanks to speaker phone making me heard and I know headphones/sound output can be louder because the app Volume+ or whatever boosts it fine. I just don't want to use a seperate app each time, I want a more permanant fix.
    08-06-2011 01:22 AM
  2. D-Caf's Avatar
    I haven't had any of the problems you mentioned so unfortunately not much of an idea on how to fix it. Are you running a stock ROM? Have you tried different headphones? The galaxy S II has to microphones one at the top and one at the bottom, it may be that the top one is working (which I believe is used during speaker phone in addition to the one at the bottom) and the bottom one doesn't (which is the only one used during normal talk mode). You might test by talking on speaker mode with someone and try covering one after the other to narrow it down.
    08-06-2011 12:41 PM
  3. Rizaria's Avatar
    I haven't had any of the problems you mentioned so unfortunately not much of an idea on how to fix it. Are you running a stock ROM? Have you tried different headphones? The galaxy S II has to microphones one at the top and one at the bottom, it may be that the top one is working (which I believe is used during speaker phone in addition to the one at the bottom) and the bottom one doesn't (which is the only one used during normal talk mode). You might test by talking on speaker mode with someone and try covering one after the other to narrow it down.
    I was using the stock ROM, but I have since flashed a newer one and rooted. Ironically I don't believe I tested this before that, so I can't say for sure if had the issue earlier or not.

    You make a good point for testing by the way, might give that a shot. My only thoughts on that really though are the fact I DID fix that at one point by fiddling with settings. So as far as I know, both mics work fine, there's just some error in the settings. Shame it lost my fix when it restarted. I need to find a new fix and save it for future purposes..
    08-06-2011 07:16 PM
  4. Rizaria's Avatar
    Okay, Poweramp works fine, and I also see types of headphones are to blame. Like the earphones that came with the phone are fine. They have 3 notches on the plug as opposed to 2. I'd say that's a fair indication. Anyway, can consider my MUSIC problem solved.

    Also I've been told my warranty was indeed automatic, so if I truly cannot fix the mic problem again, apparently I can send it away to get fixed. Although I guess I'll have to reset and all, hide root and all that. Don't even know how, nor do I want to be phone-less, so help will still be very appreciated.
    08-07-2011 08:41 PM
  5. D-Caf's Avatar
    Okay, Poweramp works fine, and I also see types of headphones are to blame. Like the earphones that came with the phone are fine. They have 3 notches on the plug as opposed to 2. I'd say that's a fair indication. Anyway, can consider my MUSIC problem solved.
    On the headphones thing, standard 2 notch headphones (standard stereo) should work fine on your Galaxy S II, I've used a pair of Sony with mine on occasion fine. The three notch only difference is that it adds the mic channel as well for voice calls. That's not to say that the SGSII's plug isn't more picky and that your one pair of headphones just won't make proper contact with the port, but you should be able to use other 2 notch headphones as well. That's why I suggested trying another pair of headphones, sometimes the connectors are picky.


    Also I've been told my warranty was indeed automatic, so if I truly cannot fix the mic problem again, apparently I can send it away to get fixed. Although I guess I'll have to reset and all, hide root and all that. Don't even know how, nor do I want to be phone-less, so help will still be very appreciated.
    I'd still do the test between the two built in mic's just to see if it's the one at the bottom. As for a software solution, unfortunately I just haven't heard of anything. Sorry.
    08-08-2011 08:40 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD