1. wilkolakpl's Avatar
    After 2.3.5 update my Bluetooth stopped working, when I try to switch the Bluetooth on it stays in half switched on and after a while it turns off without ever completing the process. I noticed it after 2 days since updating the software, when I tryed to send something via Bluetooth.
    11-21-2011 02:48 AM
  2. wilkolakpl's Avatar
    I even tried to make it working with hard reset, but without luck. I dont know what to do.
    11-21-2011 11:40 AM
  3. voghan's Avatar
    Same issue.. It worked on 2.3.4 leak but disconnects for me after I started using 2.3.5 leak. I had the same issue on Cyanogen so I'm assuming this is a Google issue.
    11-21-2011 03:15 PM
  4. madhatter2426's Avatar
    Not had any bluetooth problems on my UK Vodafone 2.3.5 firmware. In fact just used it both in the car and for file transfer from my Mac. Have you tried a security wipe and format internal storage.
    11-24-2011 07:36 AM
  5. wilkolakpl's Avatar
    Yes I've tried. It didn't work.
    11-25-2011 09:09 AM
  6. gazmo_vlc's Avatar
    It happened to me just the same as you, I solved it by reinstalling the version of android. I have the 2.3.4 and reinstall it with the complete rom my country (because my phone is free) and odin
    Search the XDA developers forum I can not spend the link ...
    I hope to serve you friend! Pardon my English is goolge translator xD
    12-04-2011 11:38 AM
  7. Loki_ca's Avatar
    Operating HTC Desire 3D now with Android 2.3.5 now and same issue.
    Use Sync in my Ford and phone ALWAYS connected before. Now I have to remove device and re-pair each time with the car, and I can make outgoing calls but when I get an incoming one, it gets caught by the locked screen (used to bypass it before) and once I enter password, I get force closed and phone flips to Airplane mode, then returns to normal - however no longer connected despite the fact that my car and phone both show active connections.

    02-02-2012 06:34 PM
  8. talks-too-much's Avatar
    Same here. After 2.3.5, my Bluetooth has been flakey - basically I get one shot to connect a headset. After one connection, if I disconnect, I can't connect any device (including the original one) unless I reboot. Cycling the bluetooth doesn't help, cycling the device doesn't help, being discoverable doesn't help. Also, I don't get a keyboard in several of my apps. Is there a way to downgrade to the prior version?
    02-09-2012 08:35 AM