1. giancarlo93's Avatar
    I just updated my galaxy s2 to firmware 2.3.4

    Everything works minus the browser and youtube.
    I downloaded firefox and it browses like normal.

    Whats wrong?
    What should I look for?

    thanks in advanced.
    11-21-2011 09:04 PM
  2. giancarlo93's Avatar
    Ok no worries
    I took off the sim card, put another one and it worked.

    11-21-2011 09:11 PM
  3. gsainath4u's Avatar
    I guess this is a problem with the network settings of the previous SIM card.
    The APN has to be added either through a push message from the operator or manually.

    Put back the earlier SIM and wait for the operator to push the settings, or if you know them you can manually update them @ Settings -> Wireless and Network -> Mobile Networks -> Access Point Names

    Hope this helps.
    11-22-2011 02:39 AM
  4. giancarlo93's Avatar
    Thanks for your help.
    That's what I did.
    I pull out my cable & wireless sim card, then inserted a movistar sim card and the again the cable & wireless one and now it works perfectly.
    11-22-2011 11:07 AM
  5. jakson0100's Avatar
    I use dolphin HD It has tabs like firefox and seems to be fairly stable. Firefox also has a mobile browser, but I have never tried it
    03-21-2012 04:00 AM