1. Ayman10's Avatar
    I have a few incidences when callers report to me that they hear their sound back (echo)

    Any solution?
    11-22-2011 07:18 AM
  2. ChuckeeDroid's Avatar
    I've heard this on low quality Bluetooth devices and occasionally when you have a bad connection.
    I don't think it's the phone's fault.

    Sent from my GT-P7510
    11-22-2011 07:41 PM
  3. reg67's Avatar
    Quick question ..... are u using any sort of case?

    Sent from my GT-P7510 using Tapatalk
    11-23-2011 10:04 AM
  4. Ayman10's Avatar
    Yes I do use a case
    11-29-2011 09:52 AM
  5. reg67's Avatar
    Yeah thats your prob mate, the case is interfering with your call. Same thing happens to me

    Sent from my GT-P7510 using Tapatalk
    12-01-2011 06:28 PM
  6. Ayman10's Avatar
    So, does that mean I have to get rid of my cas?
    12-03-2011 01:19 PM
  7. TQB's Avatar
    You can also try to turn off "noise reduction". This solved my problem when I make voice calls, but I had to do it everytime I wanted to make call, so in the meantime I have sent back my phone for repair.
    12-04-2011 10:43 AM
  8. Ayman10's Avatar

    How can u do this?
    12-05-2011 08:18 AM
  9. TQB's Avatar

    You can only turn off noise reduction once the person you are calling has picked up the phone (or when you have picked up the phone when receiving a call). Once this is done you have to press the menu key and there should be an option "noise reduction off" that should appear. I have attached a screenshot that shows the option.

    I have read on several forums that not every samsung has this option. I've got an unlocked version myself, so no bloatware or modifications from a carrier (just samsung bloatware ).
    12-05-2011 01:59 PM