1. wahlb22's Avatar
    I rooted my gs2 earlier this week and put cyanogenmod 7.1.0 on it. For the past few days it has worked flawlessly. Today however I ntocied I was unable to download mms messages. Thinking it was just a wrong apn setting I checked on that first. I am absolutely positive my settings are correct. So after a reboot I saw I no longer had data connectivity. Again the apns are correct. I can make calls and text but no data. Finally I just decided to wipe the phone. When I restore a backup from before cyanogenmod I have data. If I flash cyanogenmod again I lose data. Nothing. Has changed as far as apps I have. I didn't even restore my apps after I ran into this problem. I've tried hard resets, battery pulls, reflashing kernal/rom, various apn backup apps, fixing permissions, basically anything I could find. Still no data on cyanogenmod. I'm just lost since it was working fine only a matter of hours ago. Does anyone have any suggestions?
    12-29-2011 02:13 AM
  2. capcanuck's Avatar
    Go to your access point names in your mobile network settings, press your menu button and select "restore default".. that should do it.

    Sent from my SGH-T989 using Tapatalk
    12-29-2011 01:15 PM
  3. wahlb22's Avatar
    Thanks for the tip. I had already tried that though. All it did was erase the settings then I was unable to add a new apn.
    12-29-2011 02:03 PM
  4. capcanuck's Avatar
    If your on T-Mobile change your apn to T-Mobile, then type in internet2.voicestream.com, it stops throttling!! Shhh, don't tell anyone.. haha

    Sent from my SGH-T989 using Tapatalk
    12-29-2011 02:49 PM
  5. wahlb22's Avatar
    Sorry I'm not on T-Mobile. I'm on viaero. I know for a fact that my apn is correct.
    12-29-2011 03:09 PM