1. skulldroid67's Avatar
    I un boxed my GS II yesterday and to start the battery was completely dead right out of the box. After a full charge (with the device off) I messed around with some initial settings for about an hour, downloaded the latest firmware version; GB 2.3.6 and then went to bed.

    Woke up this morning and it was zapped again, would not even boot up...no juice! Another full charge up, been sitting idle most of the day and already down to 40%. Looks like the Android OS is really taxing the device; 93%. This is not cool!


    Any others having similar problems? I've only had this device for one day now, traded up from my Captivate. Any advice before I call it in to AT&T?
    01-25-2012 03:36 PM
  2. Meiji's Avatar
    It might be an issue with the update, some phones are not fully compatible with the 2.3.6 rom (you should've tried the original rom for some days to be sure this was the problem though). If so, you might need to go back to 2.3.5 or 2.3.4 (which imo is better). Don't know what version you're phone had originally.

    Also could be the battery, if so, a new battery should do the trick (warranty should pay for this one).

    First you can try a Factory Reset, if it keeps having troubles you can tweet or call your phone's carrier and tell them the update's not working properly and want to go back to one of those versions I told you, then they'll give you instructions. If this doesn't solve the problem you might need to go to tech support.
    01-27-2012 11:16 AM
  3. skulldroid67's Avatar
    Thanks I've actually been able to get it under control by tweaking some of the settings. It's doing much better right now.
    01-27-2012 05:34 PM
  4. Meiji's Avatar
    Oh those common settings, I should've considered them too.. yeah they are battery eaters at the beginning. Enjoy your phone!
    skulldroid67 likes this.
    01-27-2012 05:48 PM
LINK TO POST COPIED TO CLIPBOARD