1. descartes's Avatar
    I just loaded ICS on my Samsung Galaxy S2 and it's a disaster!

    First, I can't get the phone to synchronise with Microsoft Exchange (Outlook) via wireless activesync. I never had a problem with Gingerbread.

    Next, the Contacts icon has been removed from the Phone section which means that you have to go to a menu page to access Contacts.

    And there are so many other frustrating issues being reported in blogs across the web. I never thought that I would change from Android but this ICS stuff-up is testing my faith!

    Before I jump off a bridge, does anyone have any recommendations on how to get MS Exchange activesync working with ICS?
    05-15-2012 02:29 AM
  2. MooPenguin32's Avatar
    What type of issue are you having exactly? I have a Galaxy Nexus that I bought from Google running ICS 4.0.4. I setup an Exchange email over Wi-Fi (I don't get cell signal where I am right now) and it worked without a hitch. I chose just to sync the email and not calendar and contacts as I'm just setting this up to see if it worked and I'm ultimately going to remove it.
    05-15-2012 09:14 AM
  3. descartes's Avatar
    Thanks for your reply.
    MS Exchange mail account settings on Andriod provide for me to sync email, contacts, calendar and tasks. None of these sync either way (phone to server or server to phone) even if I try to sync just one of them as you have done. I am not getting any error messages when setting up or when trying to sync. The phone seems to go through the motions of syncing, although very quickly, but doesn't actually sync.
    I have checked that all the account settings are the same as previously (when I used Gingerbread) and have had my IT provider check the MS Exchange server but it still won't synchronise.
    I removed the account from my phone and reinstalled it without any result even though the phone seems to accept the account settings without any problems. I have restarted the phone but there is no change.
    I previously had no problems with Gingerbread other than the fact that Tasks would sync at GMT rather than local time.
    I have checked that all the account settings are the same as previously and have had my IT provider check the MS Exchange server but it still won't synchronise.
    I removed the account from my phone and reinstalled it without any result even though the phone seems to accept the account settings without any problems. I have restarted the phone but there is no change. My only other option may be to reset the phone but that introduces other issues.
    If I can't resolve this I'll either have to look at using Triosync or buy a Windows 7 phone.
    Any help would be welcome.
    05-15-2012 06:30 PM
  4. MooPenguin32's Avatar
    After you setup your Exchange account on the phone, does any email show up or does it just appear like an empty inbox?

    Did you flash your SGS2 with an ICS rom?
    05-15-2012 06:57 PM
  5. descartes's Avatar
    Out of the blue and totally unexpectedly after six days of trying, re-trying, re-setting, etc Activesync started to work. However, my Galaxy S2 is a total wreck since upgrading to ICS. It is so bad and I have spent so much time trying to resolve the problems that I am going to scrap it and buy a non-Samsung, non-Android phone.
    Since installing ICS I have reset the phone twice to try to get functions operating.
    It refuses to sync my two Telstra Bigpond email accounts. These accounts are visible via the email app but not visible via Settings/Accounts and do not receive mail.
    Next, I have no bluetooth functionality. I have a paired my vehicle Parrot device but the bluetooth connection does not work. Now I am unable to Unpair the device.
    Now the battery is running flat in a few hours without any usage (with bluetooth and wifi turned off).
    Finally, Outlook Tasks entered with a reminder at local time sync to Exchange at GMT and vice versa.
    I appreciate you advice about flashing the ROM but this is a phone that sells to a very wide market,most of which would have no idea how to upgrade the phone. Samsung's product should be better than this. Their new tablet is getting a caning and now this disaster, as evidenced by the blogs all over the internet. I doubt that this wold happen with Apple.
    I paid about A$800 for this phone only 9 months ago and now it is useless and there is no support from Samsung for problems their ICS release has caused!.
    Sorry I'm letting off steam but I really feel 'burnt' by Samsung on this.
    05-17-2012 08:47 AM
  6. MooPenguin32's Avatar
    I completely understand your frustration. I would feel the same exact way as you.

    I actually wasn't advising you to flash a ROM, I was asking if you had gotten ICS on your phone by flashing a ROM. Since you mentioned Telstra, I'm guessing this was an official upgrade.

    Unfortunately, you do not seem to be the only person having issues. I came across this comment thread by just Googling "telstra samsung galaxy s2."

    It sounds like the best thing you can do is either get another phone or downgrade to Gingerbread. I'm not Android savvy enough to assist with downgrading, but if you really want to keep your phone and are up to it, people on the forums could certainly help. You could also Google it as I'm sure there are quite a few guides out there.

    Whatever you choose to do, I wish you the best of luck. Hopefully Samsung will release an fix, but it is ridiculous that they released such a buggy update. Especially considering they were the first smartphone manufacturer to release an official ICS phone in the form of the Galaxy Nexus.
    05-17-2012 11:12 AM
  7. descartes's Avatar
    OK, now some feedback that might help others with ICS on SGS2.

    My activesync problem is sorted. I took the phone to my company's IT support provider and it took them an hour to fix the sync problem. That little exercise cost me $180 - thanks Samsung!

    There seemed to be two issues. One is that my three email accounts (but not my Google account - the fourth) all had to be set up using the Microsoft Exchange Activesync option on the phone. This had not been the case in the past with the Bigpond accounts. The second issue seemed to relate to the fact that Telstra now translates its Bigpond webmail to Windows Live for access and this means that the incoming and outgoing email account settings have changed from there traditional settings. So when you access Bigpond webmail you enter the Bigpond webpage and are immediately translated to a Windows Live Hotmail page with a Bigond tab. When entering Bigpond I have to use my Bigpond password but if I enter via Windows Live I have to use the Windows Live password.

    However, one of my Bigpond email accounts was set up after Telsrta translated the accounts to Windows Live and the same password id used for both accesses. Unfortunately, there is no functionality to change that Windows Live password or to aggregate both my Bigpond accounts into the one Windows Live Hotmail access. Even the tech staff in the Telstra Shop I visited couldn't figure out how these passwords operated so what chance does the public have?

    My next issue resolved was the failure of my vehicle Bluetooth to operate after upgrading to ICS and my inability to remove a paired device. This was eventually resolved by turning off the phone, removing the battery and re-pairing the device.

    Finally, I thought that my ICS upgrade issues were resolved but that is far from the case. I now have disastrous battery life and constant data transmission. The data transmission icons are constantly flashing. even when all active applications are turned off. To try to find out what was happening I loaded the Traffic Monitor app but that does not show that significant amounts of data are being sent from the phone. Nevertheless, I'll keep monitoring this.

    My biggest concern now is that I don't really have a "mobile" device any more. Apart from short breaks I have to keep the phone plugged in for recharge most of the time. I can turn off all active applications(including wifi and GPS) and not use the phone and I will be lucky if I get four hours of battery life. The when I do recharge from a wall socket it takes a couple of hours for the battery to fully recharge. After 30 mins with no use the battery will have dropped to 70%.

    Does anyone have an answer for this pathetic battery life issue please?
    05-18-2012 08:00 PM
  8. shamskhalil's Avatar
    try reducing the brightness of your screen. the screen drains the battery faster. you can also activate power saving mode, which automatically reduce the brightness.

    Sent from my GT-I9100 using Tapatalk
    05-19-2012 01:38 PM
  9. Omegajester's Avatar
    Download juice defender.

    I'm getting 22-24 hours on my phone. ICS 4.0.3 XWLPD.

    I'm also not experiencing a single problem of the things you said. Thanks for the feedback though, it oughta help those less fortunate.

    If you're thinking about selling your phone, I'll gladly take it off your hands... :-)

    Sent from my GT-I9100 using Tapatalk 2
    05-19-2012 08:21 PM
  10. gollycious's Avatar
    I'm using Galaxy Nexus with Jelly Bean, and Microsoft active sync was working normally, recently my company upgrade their exchange server to Microsoft 365 and this active sync doesn't work any more. every i try to open my office email the attached screen is appear for hours and my email is not appear.
    08-28-2012 05:54 AM