1. Remon Georgy's Avatar
    Hi There,

    I have a weird issue with my samsung i9100's display. A couple of weeks ago, the screen started to go black randomly, usually after getting it out of my pocket. Display could go back to normal after opening battery cover, removing the buttery and booting the mobile. But most of the time it would work on it's own!

    At first a suspected a software issue (e.g BSOD) because I was installing a nighty Cyanogenmod rom.
    I wiped everything and installed a stable CM mod, the issue was still happening. Re-installed the stock rom but that didn';t help either.
    I noted couple of things:
    1- The occurrence of that issue was becoming more frequent. Started from once per day to always black.
    2- While the screen is black, the soft keys are lit!
    3- While the screen is black, touch works fine. E.g. with some luck I could unlock the phone, answer callsetc.

    Now the phone has gone completely black. Only one trick could bring back the display for couple of hours.
    1- Remove the screws and unclip the back panel.
    2- Remove the display connector from the main board.
    3- Connect the display back.
    4- Turn on the phone, Voila! display is back. but only for couple of hours .

    Samsung guys here are quite lazy, they want to replace the screen without even investigating the issue for couple of minutes.

    Have anyone experienced a similar issue before? Any clues?

    Thanks,
    Remon
    03-20-2013 07:45 AM
  2. Remon Georgy's Avatar
    bump! any clues?
    03-21-2013 07:44 AM

Similar Threads

  1. Phone glass broken (Display and touch works fine)
    By Tritoz in forum General Help and How To
    Replies: 1
    Last Post: 01-31-2013, 05:42 PM
  2. Rooted, Many Root Apps work, Titanium Backup doesn't??
    By DikaiaKnight in forum Incredible Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 02-07-2011, 05:39 PM
  3. Battery working while the phone is turned off?
    By sanibel in forum HTC myTouch 4G
    Replies: 21
    Last Post: 01-20-2011, 01:38 PM
  4. Camera app does not work while on call!!!
    By hotis300boy in forum Sprint Epic 4G
    Replies: 13
    Last Post: 09-22-2010, 05:03 PM
  5. Replies: 0
    Last Post: 07-22-2010, 03:29 PM
LINK TO POST COPIED TO CLIPBOARD