03-15-2017 06:21 PM
133 ... 23456
  1. Rascal Art's Avatar
    Hi, For those having problem accessing *#9900# and it throws up invalid error, you probably run on custom rom.

    You will need to look for this directory /data/log and delete all the files. For my case, it freed up 1 gig of memory!

    You can do it via terminal in your apps (I'm running on Cyanongen):
    1. su
    2. cd /data/log
    3. rm *.log
    Can you please give some more detail on how to use this fix? I am on Cyanfox Nightlies and cannot access the SSID codes option to fix the problem.
    04-09-2014 07:20 AM
  2. martinmurray345's Avatar
    I'm really happy it works for you, but I'm getting very angry reading all these reports of how wonderful this method is, because when I try it, the SysDump menu DOESN'T HAVE any item "delete dumpstate/logcat".

    My phone says it has 180Mb of memory, and only 12Mb free. But it still won't accept a text message! Which is what, 1Kb or so? What is wrong with this system?

    Martin Murray
    04-11-2014 03:53 PM
  3. kliki77's Avatar
    hello guys I got samsung galaxy s2 and I download cracked Fifa 14 and when I run the game show like this "download filed beacuse you may not have puorchased this app"
    sorry for my bad english
    04-19-2014 02:30 PM
  4. Katzhuu's Avatar

    Thank you!

    I hope you'll get one cent for each kb that has been released with this trick.
    04-23-2014 01:08 PM
  5. Latir's Avatar
    Dear Stu40 thank you so much to helping people! it was very usefuly to me and it works!!!
    05-14-2014 11:57 AM
  6. raywright1's Avatar
    taking the time and effort thank Stu as well.

    for me, it only freed up 300mb but it was enough to get back to being productive (email would not even sync).

    for me, the USSD code also threw an error, but moments later, the menu came up and i was able to delete the log file(s).
    05-15-2014 02:51 PM
  7. Readervictoria's Avatar
    I have an S2, T989. When I try to #9900#, the message I get is "Unable to Process Request" I've looked through the other solutions and can't find anything that applies to my phone. (I'm running Android 4.0.3 if that makes a difference.) When I simply search through my files, there is no "log" in the "Data" folder. Any suggestions are welcome!
    05-18-2014 01:40 AM
  8. Ankit Khanna1's Avatar
    hey i have moto e. i want to clear log cat file. i had tried *#9900# but i get wrong mmi code . pls help

    - - - Updated - - -

    hey i have moto e. i want to clear log cat file. i had tried *#9900# but i get wrong mmi code .
    06-04-2014 11:08 AM
  9. LeProsey's Avatar
    Hi all,

    I had the storage issue and used the dialling method to free some space. This did free enough to update apps etc but I still wasn't happy with all that free space on the USB part.I decided to have a play without doing any "rooting" or hacks.
    I discovered that I could manually move folders, such as Photographs, Videos and also some apps.
    To do this you have to click on the "apps" icon from your home screen and look for the "my files" icon.
    In MY FILES -
    select ALL FILES
    and you will see two folders - "extSdCard" and "sdcard0"
    In the SDCARD folder you will find the sub folder for "usbStorage"

    You can then browse through any folder you like. If you are happy that you want to move that folder, you simply select it and using the Top Menu either DELETE or MOVE - COPY - RENAME - DETAILS.
    Select MOVE if you want to keep it and the go to the SDCARD folder and select the USBSTORAGE. You should have the option to "move here" at the top of the screen. Click MOVE HERE and job done. It takes a few minutes but it will be well worth the time.
    I have managed to get an extra 1.5GB into my USB Storage from my other folders.

    Take your time and your effort will be rewarded.
    06-09-2014 05:39 AM
  10. BetterReports's Avatar
    If it does not work then you might have missed the first character in the *#9900# string - the * character - add that then it will work
    06-17-2014 08:50 AM
  11. BetterReports's Avatar
    It works well when you can type properly
    06-17-2014 08:53 AM
  12. Chris Rhee's Avatar
    I had almost the exact same amount of memory used up and tried *#9900# but it didn't clean anything up.
    How exactly do I access all the files that are on the device memory?
    I tried doing it through "my files" and going to sdcard0, but there was no USB folder...
    I got some space back by moving some apps to the SD card (I have 12GB internal and 32GB external), but it's still showing 1.5 GB. Arrrrgggghhhh!!!
    06-28-2014 06:06 AM
  13. swanonac's Avatar
    I'ust used that tip dial *#9900# Option 2. I can now update apps!
    And Android / S2 still good, EVERY computing thing has bugs.
    07-01-2014 05:32 AM
  14. itzMohans's Avatar
    Factory reset is not necessary. You just need to do the following.

    Just dial *#9900# on the phone and select option 2 “Delete dumpstate/logcat” in the prompted menu.

    This will restore heaps of storage space by deleting all the log files in the device memory. It’s not necessary to root your phone either.

    From Shuvabrata....
    07-14-2014 04:17 AM
  15. Srikanth Parthasarathy's Avatar
    A hearty Thanks Stu40! You made my day. Had this issue, and you came like the saviour!
    07-16-2014 07:11 AM
  16. vasanthns's Avatar
    God,, thanks man!! dont beleive it freed 1.5 GB on Device memory :-))))))))))
    08-04-2014 01:36 AM
  17. David Panqueva's Avatar
    Oh man thx a lot! it really works!
    08-04-2014 12:29 PM
  18. zebulonka's Avatar
    You are a just simply genius.
    08-04-2014 04:08 PM
  19. nz_walton's Avatar
    Thank you mate. You are the MAN!

    I had to add a * at the front as I was getting a invalid MMI number.


    For all those having the problem of invalid MMI. If you prefix the codes with an asterisk * first, then the it will work. Example: *#9900# and it displays your IMEI. If you leave off the prefix * then it does not recognize the code and will give you that "invalid MMI code" message
    It worked after I added the *

    Thanks again STU for the money saving post.
    09-04-2014 05:53 AM
  20. TypeOverride's Avatar
    I see that the insufficient memory issue is a big problem.

    Use a system cleaner app to find the leak.

    Has 4.4 KitKat already fixed this problem with the memory issue / Log-Files ?

    Its the biggest problem with Android Smartphones i guess.
    09-05-2014 07:09 PM
  21. Misterincredible's Avatar
    Thank you Stu40 for your post! You are magnificent. You've just made my life a lot easier. Sincere thanks again!
    09-08-2014 10:26 AM
  22. Ravi Singla's Avatar
    Thanks dude...It worked like a charm!!

    Any other tips like this, do enlighten please!!
    09-09-2014 12:15 AM
  23. Colin Johnson2's Avatar
    Thanks Stu...this is a great tip that the average Joe on the street would have no idea about. Thanks for sharing. Top man.
    09-22-2014 09:23 PM
  24. peterkau's Avatar
    I have a Samsung Galaxy S2 and when I tried to download applications from Playstore it showed a message "App will be installed soon" but that never happened. I think it was because there wasn't enough main storage. Device Manager/Storage showed Device Memory as Total Space 1.97GB Available 190MB and USB Storage as 11.50GB and available and available 10.69GB. So there's plenty of storage overall but it wasn't being used/managed effectively by the phone.

    After much searching on this and other forums without any luck I think I've finally found the solution myself. If you go to the main Settings menu and then Device and click on Storage there is a Format USB Storage option. I did this even though it warns it will erase any files held in that storage area as I was less concerned about that than the fact the storage didn't seem to be being referenced at all by the S2 device. Anyway, once done all applications are now downloading fine from Playstore and are being stored in the USB Storage area.

    I suspect that the problem with accessing the USB Storage may have arisen after I upgraded the Android version on the S2 from Ice Cream Sandwich to Jelly Bean v 4.1.2 and that the reformatting of the USB Storage area has now recreated the right linkages with 4.1.2 - can't be sure but this may be the reason. Anyway, it's fixed now.
    09-24-2014 05:21 AM
  25. arevik's Avatar
    Hi guys, I am not sure anyone is reading this line anymore but still I hope so.
    First of all thank you a lot! I found that secret menu and tried the trick, but it didn't work for me... am I the only one and if there is anything I can do about it without rooting the gadget?

    I got Samsung Galaxy S2 GT-I9100G with Android 2.3.6 on board...

    10-27-2014 04:46 AM
133 ... 23456

Similar Threads

  1. Official Samsung Galaxy S2 Jelly Bean Update Available Now Via Unofficial Means
    By NYGator in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 114
    Last Post: 06-19-2013, 05:54 AM
  2. galaxy s2 cannot download updates or new apps
    By TCCD in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 5
    Last Post: 06-18-2013, 10:12 PM
  3. Galaxy S2 Epic (Sprint) Keeps booting from apps
    By shadowzkillerz in forum Samsung Galaxy S II
    Replies: 0
    Last Post: 12-05-2011, 02:41 PM
  4. new galaxy s2 how to update market
    By hanly2 in forum Market Help
    Replies: 0
    Last Post: 11-30-2011, 05:33 PM
  5. Replies: 896
    Last Post: 11-15-2011, 08:29 AM