1. Downward Spiraling's Avatar
    Hi Everyone,
    Newbie to the frums.

    So, here goes: I tried restoring the Factory settings on my S2 cuz I got a new phone.
    Now the phone is stuck on the Samsung Logo, I tried the Power+volume up+home and did the delete/restore Factory settings and did the reboot
    and it seemed to work, I got into the original set-up but 5 minutes go by and the phone restarts and goes back to the Samsung logo. Donno what to do.
    Thanks in advance for your help!
    01-01-2014 11:50 PM
  2. UJ95x's Avatar
    Welcome to Android Central
    Try flashing the stock firmware via Odin. You can get them from here: Firmwares | SamMobile
    01-02-2014 12:07 AM
  3. Downward Spiraling's Avatar
    Thanks for your quick reply. I'm a little technically challenged so is this something I could do myself ?
    I went to the site but I'm afraid I'll brick my phone.
    Thanks again
    01-02-2014 12:22 AM
  4. UJ95x's Avatar
    Yeah, it's really easy (Could just be that I have used it many times)
    It's very unlikely you brick the phone with official firmware, unless you use one that isn't for your specific model
    Here's a video on how to do it
    Downward Spiraling likes this.
    01-02-2014 12:32 AM
  5. Downward Spiraling's Avatar
    Thanks again. I'll give it a shot.
    I'll let you know how it turns out.
    01-02-2014 12:42 AM

Similar Threads

  1. How to remove/uninstall samsung by-default application
    By shreyshah05 in forum T-Mobile Samsung Galaxy S4
    Replies: 8
    Last Post: 08-19-2015, 08:08 AM
  2. Note 3 Tips and Tricks ....
    By vja4Him in forum T-Mobile Samsung Galaxy Note 3
    Replies: 2
    Last Post: 01-16-2014, 07:49 PM
  3. Kindle App on AT&T Note 2 phone not working
    By ccagte6 in forum AT&T Galaxy Note 2
    Replies: 6
    Last Post: 01-06-2014, 03:54 PM
  4. Android update stops before end on Nexus 7 tablet ?
    By LaQira in forum General Help and How To
    Replies: 1
    Last Post: 01-03-2014, 12:20 AM
  5. Replies: 4
    Last Post: 01-02-2014, 08:36 PM
LINK TO POST COPIED TO CLIPBOARD