1. Katzhuu's Avatar
    Hi,

    I've got a phone that froze in use and after reboot it just stays in startup screen:
    Galaxy S II plus - stuck on Samsung logo-20140915_092638.jpg

    If I take the battery out and replace it after a few minutes and then try to restart it just get's stuck in the same screen.

    If I take battery out, replace it and stick the charging cord in then it get's stuck in following screen:

    Galaxy S II plus - stuck on Samsung logo-20140915_092549.jpg

    I have tried to load a new firmware with Kies (was unable to load firmware) and also I've done a factory reset (Vol up+Menu+Power). Nothing helps.

    Any ideas?
    09-15-2014 07:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you tried a new battery?
    09-16-2014 01:38 AM
  3. Katzhuu's Avatar
    Welcome to Android Central! Have you tried a new battery?
    Not a new one, but one that works in other phone (Galaxy S II). Didn't change anything.
    09-16-2014 01:53 AM
  4. B. Diddy's Avatar
    Are you able to boot into Recovery and wipe the cache partition? http://forums.androidcentral.com/sam...2-s3-tab2.html

    Also, if you have an SD card inserted, remove it. A corrupt card can cause various problems.
    09-16-2014 02:01 AM
  5. Katzhuu's Avatar
    Are you able to boot into Recovery and wipe the cache partition?...
    Ok, I tried this now, but after choosing Wipe Cache Partition, the Green Android image flashed with an 'Error'-message and the phone booted and is still stuck on that Samsung logo.

    ...
    Also, if you have an SD card inserted, remove it. A corrupt card can cause various problems.
    Removing the SD-card was the first thing I did. I also removed the SIM-card, because I need to use it on my spare phone. Can removing the SIM-card cause some problems? Is SIM-card required for wiping the cache partition?
    09-16-2014 04:28 AM
  6. B. Diddy's Avatar
    Darn it. We see that occasionally (errors when trying to wipe the cache partition), and I'm not sure what the cause is. Are you rooted or unrooted? Running the stock ROM?

    I'm not aware of the SIM being needed. I suppose you could try reinserting it, but I don't think it'll change anything.

    You could try flashing the stock ROM back onto the phone using Odin. You need to make sure you have the ROM designed for your exact phone--don't use a file that is one number or letter off. http://forums.androidcentral.com/amb...-via-odin.html
    Golfdriver97 and Katzhuu like this.
    09-16-2014 10:15 AM
  7. Katzhuu's Avatar
    Flashing the stock rom with Odin did it. Thanks! Everything works now again. And my wife is happy again
    B. Diddy likes this.
    09-16-2014 02:10 PM

Similar Threads

  1. Not registered on Network? URGENT
    By JollyJed in forum Samsung Galaxy S4
    Replies: 15
    Last Post: 08-18-2015, 08:47 AM
  2. Android TV, anyone played game on it?
    By Wastelands in forum Google Nexus Player
    Replies: 1
    Last Post: 10-07-2014, 11:11 PM
  3. Replies: 7
    Last Post: 09-17-2014, 10:24 PM
  4. Replies: 1
    Last Post: 09-15-2014, 11:17 AM
  5. samsung galaxy s4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-15-2014, 09:40 AM
LINK TO POST COPIED TO CLIPBOARD