1. HotIce05's Avatar
    Everytime I try to install the Kies onto my computer, I get an error saying that file MSSetupaddin.dll is missing. I've tried everything from downloading it again to restarting, but nothing has worked. Can someone please help?
    05-13-2011 09:59 AM
  2. ragnarokx's Avatar
    Use Google to find a copy of that missing .dll file, download it, put it in your Windows "system" folder and try Kies again.

    Sent by a little green robot
    05-13-2011 11:54 AM
  3. stevehsteveh's Avatar
    Make sure that you are using the latest version of Kies:
    Kies_2.0.0.11044_11_3.exe
    If not, get this and it may help.
    05-14-2011 11:20 AM
  4. Shonzz's Avatar
    I went though hell and back to figure out how to get my international, unlocked Galaxy S II, GT-I9100, to connect to Kies. This is only for the PC and Android 2.3....I tried all of the crazy suggestions found on the many forums, including deleting files, removing my external SD card, adding lines to the registry, nothing worked...I just happened onto this and thought I'd share it...


    Turn off USB debugging from Applications/Development (if you're using it for anything)
    Go into Wireless-Networks/USB Settings, USB Utilities and click Connect Storage to PC….it will say connect to USB
    Connect and mount phone’s memory, both internal and external
    Once it shows up on the computer, dismount the phone from your computer's tray by clicking the Disconnect Android, but leave the phone connected via USB
    Go into Notifications by dragging down your home page on the phone and It will then show “ USB Connected MTP-Initialization”
    Now open Kies
    If you get the an error, disconnect and then reconnect the phone via USB, without any mounting and the notification area will show it connecting and it will work that time.

    Hit me if this isn't clear enough for you.

    I have successfully updated my phone to 2.3.5
    10-10-2011 02:41 PM
LINK TO POST COPIED TO CLIPBOARD