1. maven1975's Avatar
    I am running my SG2 Vanilla and have had nothing but trouble on AT&T with thee phone app. I just converted over from an iPhone and would appreciate any input on this issue as I have not been in the Android world long enough to understand what the issue is.

    Huge thanks in advance!
    05-30-2011 03:00 PM
  2. geekaren's Avatar
    I'm also using SGS2 on AT&T but haven't experienced problems using the phone app.

    You may want to consider doing a factory reset -- will delete all of your data but should resolve the phone app problem. (Settings > Privacy > Factory Data Reset)

    Be careful about re-adding new apps after the reset, to ensure you're not installing a market app that creates a conflict for the phone app.
    05-30-2011 03:52 PM
  3. maven1975's Avatar
    I'm also using SGS2 on AT&T but haven't experienced problems using the phone app.

    You may want to consider doing a factory reset -- will delete all of your data but should resolve the phone app problem. (Settings > Privacy > Factory Data Reset)

    Be careful about re-adding new apps after the reset, to ensure you're not installing a market app that creates a conflict for the phone app.
    Thanks for the reply. i have not added any applications besides Facebook and a few games from the hub. I have done a factory restore and still have the issue.

    Does AT&T need to provision the phone?
    05-30-2011 05:17 PM
  4. geekaren's Avatar
    hmmm.....

    I don't think the phone would need to be provisioned by AT&T. All I did to use my SGS2 was to move my AT&T sim from my Infuse over to the SGS2.

    A few options:
    A) You could ask AT&T to replace your sim card. (I don't think it will help, but can't hurt! :-)
    B) You could upgrade your SGS2 firmware to XWKE7. Here's an xda-developers.com thread providing links to updated SGS2 firmware and link to software you'd use to flash it (Odin):
    xda-developers - View Single Post - [ROM + Guide]Official i9100 KDD/KE1/KE2/KE7 download for Odin Flash and Root Guide.

    You can find your firmware version in Settings > About.

    I successfully flashed my SGS2 firmware to XWKE7 (it arrived with XWKE2). If you decide to go that route, probably best to post any questions to that thread (I'm no expert, I just followed the directions to a T)
    05-30-2011 08:03 PM
  5. maven1975's Avatar
    Well, I called AT&T and they took the iphone plan off and updated the information. The phone still had issues and I was able to track down the problem to two specific contacts.

    I merged the contacts together and bam, I was able to call them. It looks like the social hub caused issues with these contacts.

    However, after AT&T did their magic, the phone would not ring. It would go straight to a message stating that the ATT subscriber you are trying to reach is unavailable! Got back on the phone with att and they tried a bunch of different stuff. I tracked down the issue to when they reset the phone, the device changed the phone setting to ignore all calls!

    So finally, the ATT rep was able to contact me on the device. Yea! But before disconnection, she wanted to point out that unlimited data for this device is being offered for $10 per month. She asked if I wanted this and I said hell ya!

    I guess the hassle was worth the time. Anyone want to advise me to the unlimited data for $10. Obviously im not going to go crazy, and have kept under 2GB's, but is there anything I could do to raise suspicion or a flag to me having this?
    05-30-2011 09:30 PM
  6. maven1975's Avatar
    Thought I had the issue licked.

    But the problem persists today. This time the phone app crashes, and the network dies. (No signal or Data)

    Wow, I thought for sure Android would have these issues worked out by now.

    This thing will be marked for sale in the next 24 hours if I cant figure it out.

    What a shame.
    05-31-2011 04:16 PM
  7. chestvrg's Avatar
    Thought I had the issue licked.

    But the problem persists today. This time the phone app crashes, and the network dies. (No signal or Data)

    Wow, I thought for sure Android would have these issues worked out by now.

    This thing will be marked for sale in the next 24 hours if I cant figure it out.

    What a shame.
    Why don't you contact Samsung or the site where you bought it from and see if you can get a replacement? I'm sure it is still under warrantee and most companies like expansysUSA wil send you a replacement unit with a RMA (Return Merchandise Authorization) label and maybe it's just a defective unit.

    -- Sent from my Palm Pre using Forums
    06-03-2011 03:40 AM
  8. mfriedman79's Avatar
    I would definitely follow up with Samsung or the store you bought it from. I am using this on AT&T as well and have not had any issues with the phone app crashing at all. I do see the occasional data stall, but my guess is that has been fixed in a newer firmware or will be soon as its likely a Samsung issue.
    06-03-2011 11:23 AM
  9. maven1975's Avatar
    The problem is software. Once I decided not to use Samsung's social hub, all of the problems went away.
    06-05-2011 08:05 PM
LINK TO POST COPIED TO CLIPBOARD