1. mfriedman79's Avatar
    Anyone had any luck getting HBO Go to work on the GS2? I get the HBO splash screen and audio but no video. Just curious if I am missing something or if this appears to be a device wide issue.
    05-31-2011 05:45 PM
  2. geekaren's Avatar
    Anyone had any luck getting HBO Go to work on the GS2? I get the HBO splash screen and audio but no video. Just curious if I am missing something or if this appears to be a device wide issue.
    I'm seeing the same behavior as you (no video after the spash intro, but audio works fine)
    05-31-2011 06:03 PM
  3. stevehsteveh's Avatar
    Make it 3, same here.
    06-01-2011 09:19 AM
  4. mfriedman79's Avatar
    starting to look like a device incompatibility issue then. Damn hope they fix it soon.
    06-01-2011 01:39 PM
  5. topinate's Avatar
    free HBO GO v1.0.2 download | MobileCruze

    I installed HBO Go and it works from here. I am using MR2.
    06-23-2011 07:54 PM
  6. stevehsteveh's Avatar
    free HBO GO v1.0.2 download | MobileCruze

    I installed HBO Go and it works from here. I am using MR2.
    Current version is 1.03. Still doesnt work on SGS2. Are you saying this download from Mobile Cruze works on the SGS2?
    06-24-2011 07:56 AM
  7. niannello's Avatar
    So there was an update to HBO GO, v1.20937. Still the same problem as before, sound but no video even on wifi. anyone got it working yet?
    10-13-2011 06:21 PM
  8. JChapa13's Avatar
    There was an update a few days ago. HBO Go works now.
    10-26-2011 03:54 PM
LINK TO POST COPIED TO CLIPBOARD