1. Rocklandsboy's Avatar
    I have a really weird problem and I wonder if someone can help.

    I'm using the Hi-Fi Cast app to access the music (FLAC format) on my Galaxy S10 and NAS (Synology 218+).

    Everything works perfectly when I'm on wi-fi. But as soon as I come off the wi-fi (e.g. I switch it off or leave the house), Hi-Fi Cast is VERY sluggish to access the music on my phone. It can take 30-60 seconds to access a track and I often get a "timeout" message.

    I've re-installed the app and cleared data. Everything then works fine, until I then go back on the wi-fi, play music from the NAS (or, indeed, my Galaxy S10), then go off the wi-fi and play something from my phone again - then it goes back to taking ages to start.

    I've tried moving my music between the phone and SIM but same result.

    It seems to work fine on my Galaxy tablet.

    I'm guessing there is something on the phone causing some kind of conflict but I can't think what it is. I've tweaked all sorts of settings. Sometimes it work again, briefly, but ultimately it goes back to being sluggish.

    Other music apps - Samsung Music, Google Play, etc. work fine. But I really like Hi-Fi Cast and its interface, and I know it *can* work.

    Can anyone help?!

    John
    09-20-2020 02:48 PM
  2. mustang7757's Avatar
    Hi, welcome to AC!

    Try take that app out battery optimization, make sure your phone isn't in adaptive or medium power save mode also and check device car doesn't have it as sleeping app on its list .
    09-20-2020 03:12 PM
  3. Rocklandsboy's Avatar
    Hi, welcome to AC!

    Try take that app out battery optimization, make sure your phone isn't in adaptive or medium power save mode also and check device car doesn't have it as sleeping app on its list .
    Hi! It passes all those tests - the app is not in battery optimisation mode, the phone itself is in "optimised" power mode and its not a sleeping app.
    09-20-2020 05:54 PM
  4. Rukbat's Avatar
    When you lose the WiFi signal, disable Hi-Fi Cast then run it again. (An app like Tasker [not free] can automate that for losing WiFi and regaining WiFi.) The app is probably still looking for the WiFi signal, and it takes time for it to switch to local files.
    09-20-2020 06:02 PM
  5. mustang7757's Avatar
    Hi! It passes all those tests - the app is not in battery optimisation mode, the phone itself is in "optimised" power mode and its not a sleeping app.
    Ok , and adaptive not toggled on win battery mode? This only happens on lock screen not while the phone open correct?
    09-20-2020 06:37 PM
  6. Rocklandsboy's Avatar
    Ok , and adaptive not toggled on win battery mode? This only happens on lock screen not while the phone open correct?
    Adaptivr is not toggled on.

    This happens all the time - I'm not sure why you mention lock screen...?

    It feels like this is wi-fi related. It works perfectly while cobnected to the wi-fi. It only haplens when thr wi-fi is switched off. It's like it's searching for a network, realises there isn't one present, then finally starts to play. Where is should play immediately.
    09-20-2020 08:30 PM
  7. mustang7757's Avatar
    Adaptivr is not toggled on.

    This happens all the time - I'm not sure why you mention lock screen...?

    It feels like this is wi-fi related. It works perfectly while cobnected to the wi-fi. It only haplens when thr wi-fi is switched off. It's like it's searching for a network, realises there isn't one present, then finally starts to play. Where is should play immediately.
    I mentioned lock screen see if when screen time out maybe wifi goes to sleep .

    Under advanced in wifi settings is it the toggle on to save wifi power ? Also check wifi control history any apps controlling it ?
    09-20-2020 08:35 PM
  8. Rocklandsboy's Avatar
    I mentioned lock screen see if when screen time out maybe wifi goes to sleep .

    Under advanced in wifi settings is it the toggle on to save wifi power ? Also check wifi control history any apps controlling it ?
    Wi-fi power savinf mode is toggled OFF.

    The only entry under wi-fi control history is "Turn on wi-fi automatically"
    09-20-2020 08:40 PM
  9. mustang7757's Avatar
    Wi-fi power savinf mode is toggled OFF.

    The only entry under wi-fi control history is "Turn on wi-fi automatically"
    Ok go settings >apps >3 dots upper right corner tap>select special access> go down to wifi control and tap > turn those off and recheck if problem still happens
    09-20-2020 08:57 PM
  10. Rocklandsboy's Avatar
    Ok go settings >apps >3 dots upper right corner tap>select special access> go down to wifi control and tap > turn those off and recheck if problem still happens
    Are you saying turn ALL those off? Won't that cause me different problems?

    I just tried resetting wi-fi /network settings. Still the same!
    09-21-2020 02:25 AM
  11. mustang7757's Avatar
    Are you saying turn ALL those off? Won't that cause me different problems?

    I just tried resetting wi-fi /network settings. Still the same!
    Those there are able control your wifi , I turn them off , if u like after the test turn them on , I personally don't want any app to decide control when my Wi-Fi goes on or off .
    09-21-2020 08:52 AM

Similar Threads

  1. S20+ Freezing when using Camera
    By LukeTayy in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 11
    Last Post: 09-22-2020, 09:33 AM
  2. Replies: 8
    Last Post: 09-21-2020, 12:41 AM
  3. Where to watch from anywhere
    By encelle111 in forum Suggestion Box
    Replies: 19
    Last Post: 09-20-2020, 07:45 PM
  4. How to Remove my S10e from Google Devices and Samsung Find my Device?
    By 0mrspock0 in forum Samsung Galaxy S10 & S10+
    Replies: 14
    Last Post: 09-20-2020, 06:41 PM
  5. Android Device Manager
    By Nelson221 in forum Google Pixel 4 & Pixel 4 XL
    Replies: 2
    Last Post: 09-20-2020, 01:12 PM
LINK TO POST COPIED TO CLIPBOARD