10-20-2019 11:40 PM
68 123
tools
  1. pandit81's Avatar
    There is this setting in Gmail App:
    Settings > [your email address] > Notifications. Select "All" option
    In my case "High priority only" was selected and I was not getting any notifications.
    But now every notification started coming as soon as mail in my inbox
    05-27-2019 08:58 PM
  2. Scutley's Avatar
    I had this problem after I got the may update this morning. It has happen before but all I had to do was restart my phone. This was not the case this morning however. So I did some searching on the Google machine, and found something. I did what it said on this forum and it started to work and notify me again.

    I just received an E-mail and it notified me. So I hope it continues.

    https://us.community.samsung.com/t5/.../619506#M21333

    Dumasz
    Dumasz
    Constellation
    Re: No longer receiving GMail notifications
    3 weeks ago

    I was having the same issue with my S10 with gmail not sending notifications. I found if you go to settings > search for "special access" > optimize battery usage > turn of the gmail app, I started getting notifications again even while on medium power saving mode. I'm not sure if you've tried this yet but it seems to be working again normally for me? Hope this helps.
    05-28-2019 12:06 PM
  3. Scutley's Avatar
    I had this problem after I got the may update this morning. It has happen before but all I had to do was restart my phone. This was not the case this morning however. So I did some searching on the Google machine, and found something. I did what it said on this forum and it started to work and notify me again.

    I just received an E-mail and it notified me. So I hope it continues.

    https://us.community.samsung.com/t5/.../619506#M21333
    I also did this with my AP News alerts because they weren't giving my notifications anymore either. That seems to be working now as well. It must've been something when the put out the May update.
    05-28-2019 12:28 PM
  4. saaammm's Avatar
    Hey, please everyone who have the same issue CALL samsung now and file a report, and please leave on gmail support forum ticket/complain.

    "I just bought new S10e factory unlocked 2 weeks ago. Activated it 5 days ago. Overall everything seems ok, except Gmail notification!

    I'm getting email notification with 5, 10, 20... minutes or hours delays, or never.

    1. I searched youtube, forums, and articles, contacted samsung tech support to solve the issue

    2. The issue is well known for 3 years already, since 2017 people claim the issue on different models!

    3. I did and follow all ~10 possible fixes: including: sim card reinsert, restarted phone, soft reset, hard reset (factory restore), reinstalled gmail, enable all SYNC everywhere, enable all notifications in gmail setting (to constantly get notification for all emails), enable all notification in phone settings specifically and in general for gmail, removed gmail from battery optimization, tried Samsung email app, cleared all cache, etc.

    4. It seems the issue so far only with gmail, other apps I think I'm getting constant notifications."
    05-30-2019 12:11 PM
  5. zimaster681's Avatar
    I think i did just that and it fixed the proble i think. I get my notifications 4/5 times
    https://forums.androidcentral.com/sh...=1#post6512788
    06-04-2019 10:32 AM
  6. zimaster681's Avatar
    In Gmail there's a setting under NOTIFICATIONS -> INBOX NOTIFICATIONS -> NOTIFY FOR EVERY MESSAGE. Mine was unchecked. I just checked and it seemed to work.
    I think i did that and it works 4/5 times
    06-04-2019 10:36 AM
  7. zimaster681's Avatar
    There is this setting in Gmail App:
    Settings > [your email address] > Notifications. Select "All" option
    In my case "High priority only" was selected and I was not getting any notifications.
    But now every notification started coming as soon as mail in my inbox
    I tried it and i thinks it works for the most part. Thanks.
    06-04-2019 10:37 AM
  8. Topher788's Avatar
    Just created an account for this, here is the real fix.

    Settings >apps >3 dots top right >Special access >Allow app while data saver on >Toggle Gmail to ON.
    felloffthetruck likes this.
    06-06-2019 12:59 PM
  9. felloffthetruck's Avatar
    Just created an account for this, here is the real fix.

    Settings >apps >3 dots top right >Special access >Allow app while data saver on >Toggle Gmail to ON.
    Very interesting.
    06-06-2019 06:44 PM
  10. Adam Frix's Avatar
    I'm glad people are having discussions about this problem finally, delayed notifications on various apps are a huge problem on Android, nobody can fix it.
    This. 110% this.

    My answer is, turn off all the power saving stuff. I got the phone with the big battery, so I'll use it.
    06-06-2019 07:02 PM
  11. Topher788's Avatar
    And it's still not working... Well it did for about an hour anyway.
    06-06-2019 08:16 PM
  12. mustang7757's Avatar
    You guys with delayed notifications can try turning off adaptive battery .
    06-06-2019 09:01 PM
  13. NIZMOZ44's Avatar
    You guys with delayed notifications can try turning off adaptive battery .
    Mines been doing this as well. I just turned adaptive battery off to see if I get emails immediately now.
    mustang7757 likes this.
    06-08-2019 11:44 AM
  14. mustang7757's Avatar
    Mines been doing this as well. I just turned adaptive battery off to see if I get emails immediately now.
    Hopefully it helps , let me know .
    06-08-2019 11:48 AM
  15. NIZMOZ44's Avatar
    Hopefully it helps , let me know .
    No go. Just sent an email from my other account and its not going off right away.
    06-08-2019 11:52 AM
  16. mustang7757's Avatar
    No go. Just sent an email from my other account and its not going off right away.
    Ok then got be something more to this , do you have any other battery saving mode then optimized on or adaptivepiwer saving mode ? Because that will switch to medium at some point to further cut battery loss.
    06-08-2019 11:54 AM
  17. NIZMOZ44's Avatar
    Ok then got be something more to this , do you have any other battery saving mode then optimized on or adaptivepiwer saving mode ? Because that will switch to medium at some point to further cut battery loss.
    Not that I am aware of.

    Why are my Gmail notifications no longer working on Galaxy S10?-screenshot_20190608-105615_device-care.jpg
    06-08-2019 11:57 AM
  18. NIZMOZ44's Avatar
    Adaptive is off, its set to Optimized for Power mode. Not sure what else to do. Could it be that not used apps setting? As soon as I unlocked the phone, gmail chimed.
    06-08-2019 11:58 AM
  19. mustang7757's Avatar
    Optimized settings I would uncheck that just to try .
    Not that I am aware of.

    Click image for larger version. 

Name:	Screenshot_20190608-105615_Device care.jpg 
Views:	14 
Size:	148.5 KB 
ID:	304122
    06-08-2019 11:58 AM
  20. NIZMOZ44's Avatar
    Just changed it to high performance mode to see what it does.
    06-08-2019 11:59 AM
  21. mustang7757's Avatar
    Also make sure I have it toggled on so you can see adaptive battery not on , this is in the notifications panel long press the power modeWhy are my Gmail notifications no longer working on Galaxy S10?-screenshot_20190608-115858_device-20care.jpeg
    06-08-2019 12:00 PM
  22. mustang7757's Avatar
    Just changed it to high performance mode to see what it does.
    Ok
    06-08-2019 12:00 PM
  23. NIZMOZ44's Avatar
    Yeah, adaptive battery was off in that section and it was set to optimized. Now on HP mode, its still not working. I see my email has gotten several and the phone hasn't done anything yet.
    06-08-2019 12:03 PM
  24. NIZMOZ44's Avatar
    06-08-2019 12:06 PM
  25. mustang7757's Avatar
    Yeah, adaptive battery was off in that section and it was set to optimized. Now on HP mode, its still not working. I see my email has gotten several and the phone hasn't done anything yet.
    The other thing I can suggest make sure in gmail itself in settings it set to sync and push , if checks out ok there last resort will be long press the gmail icon >info>clear data ,cache and force stop and possibly uninstall the update in the top corner 3 dots
    06-08-2019 12:08 PM
68 123

Similar Threads

  1. What happened to my android studio?
    By Android Central Question in forum Software Development and Hacking
    Replies: 3
    Last Post: 03-19-2019, 10:48 PM
  2. S10+ Wifi and Device Idling high battery drain
    By Android Central Question in forum Samsung Galaxy S10 & S10+
    Replies: 2
    Last Post: 03-19-2019, 04:17 PM
  3. Why did colors of tiles get changed?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-19-2019, 01:29 PM
  4. What's this icon in my notification tray?
    By Lecrae116 in forum Samsung Galaxy S10 & S10+
    Replies: 4
    Last Post: 03-19-2019, 01:14 PM
  5. What are the most popular developer options to toggle?
    By mrpackerguy in forum Google Pixel 3 & Pixel 3 XL
    Replies: 2
    Last Post: 03-19-2019, 01:01 PM
LINK TO POST COPIED TO CLIPBOARD