10-20-2019 10:40 PM
68 123
tools
  1. NIZMOZ44's Avatar
    The other thing I can suggest make sure in gmail itself in settings it set to sync and push , if checks out ok there last resort will be long press the gmail icon >info>clear data ,cache and force stop and possibly uninstall the update in the top corner 3 dots
    Just tried this, no go on either. It just checks when it feels like it.
    06-08-2019 11:14 AM
  2. mustang7757's Avatar
    Just tried this, no go on either. It just checks when it feels like it.
    Very strange
    06-08-2019 11:29 AM
  3. mustang7757's Avatar
    Just tried this, no go on either. It just checks when it feels like it.
    Do you have status bar to show all notifications alsoWhy are my Gmail notifications no longer working on Galaxy S10?-screenshot_20190608-123442_settings.jpeg
    06-08-2019 11:35 AM
  4. mustang7757's Avatar
    I just tested this looks like that's a issue , need to show all notifications in status bar
    06-08-2019 11:45 AM
  5. NIZMOZ44's Avatar
    I just tested this looks like that's a issue , need to show all notifications in status bar
    Mine was set to all notifications too.
    06-08-2019 11:51 AM
  6. mustang7757's Avatar
    Mine was set to all notifications too.
    Yeah that's weird , I put show only recent it didn't show a test notification , then I put it back to all notifications it shows up . Very strange.
    06-08-2019 12:12 PM
  7. felloffthetruck's Avatar
    I'm using Aqua Mail Pro and my Gmail notifications work perfect.
    06-08-2019 03:49 PM
  8. Adam Frix's Avatar
    Adaptive is off, its set to Optimized for Power mode.
    It's not the adaptive, it's the optimization. Turn off optimization.
    06-08-2019 04:25 PM
  9. NIZMOZ44's Avatar
    It's not the adaptive, it's the optimization. Turn off optimization.
    Not sure what you are talking about. You can't turn it off. It has 4 modes, high performance, optimized, and then battery saving ones below that. And I've already tried HP and still had the issue.
    06-08-2019 06:42 PM
  10. Adam Frix's Avatar
    "high performance" means "not optimized", while "optimized" means "optimized".
    06-08-2019 11:39 PM
  11. CWinkler's Avatar
    I don't remember if this was addressed before or not, and short on time to read through all previous posts right now ... but there's a Gmail account setting that can be checked or not for "notify for every message" ... it's in Inbox notifications under Gmail settings for a specific account (not General settings).
    06-10-2019 05:07 AM
  12. VLauricella's Avatar
    Very strange
    Hey guys...I was having the same issue and realized something very simple was behind it (in my case at least). I tried everything else mentioned in this thread, but the issue was that background data was somehow switched off for Gmail.

    Settings > Apps > Gmail > Mobile Data > Allow background data usage

    I'm not sure how it got switched off for me, maybe accidentally in my pocket, but as soon as I toggled this setting, my emails popped up as notifications and I tested and verified new emails showing up as notifications instantly like they used to.
    mustang7757 likes this.
    06-11-2019 10:31 PM
  13. mustang7757's Avatar
    Hey guys...I was having the same issue and realized something very simple was behind it (in my case at least). I tried everything else mentioned in this thread, but the issue was that background data was somehow switched off for Gmail.

    Settings > Apps > Gmail > Mobile Data > Allow background data usage

    I'm not sure how it got switched off for me, maybe accidentally in my pocket, but as soon as I toggled this setting, my emails popped up as notifications and I tested and verified new emails showing up as notifications instantly like they used to.
    I'm glad yours is working, hopefully can help others also.
    06-11-2019 10:43 PM
  14. NIZMOZ44's Avatar
    Hey guys...I was having the same issue and realized something very simple was behind it (in my case at least). I tried everything else mentioned in this thread, but the issue was that background data was somehow switched off for Gmail.

    Settings > Apps > Gmail > Mobile Data > Allow background data usage

    I'm not sure how it got switched off for me, maybe accidentally in my pocket, but as soon as I toggled this setting, my emails popped up as notifications and I tested and verified new emails showing up as notifications instantly like they used to.
    Mines on.

    06-12-2019 05:14 AM
  15. snakeyes1000's Avatar
    I had this problem after I got the may update this morning. It has happen before but all I had to do was restart my phone. This was not the case this morning however. So I did some searching on the Google machine, and found something. I did what it said on this forum and it started to work and notify me again.

    I just received an E-mail and it notified me. So I hope it continues.

    https://us.community.samsung.com/t5/.../619506#M21333
    It worked! **** OPTIMIZATION!!!

    Thank you so much. Why all the sudden it caused notifications to stop is very annoying.
    07-01-2019 12:32 PM
  16. bulldoza99's Avatar
    Here is the fix that worked for me!

    I have had the same issue for over 3 months - S10 with latest updates.
    The fix i found was uninstall the updates on gmail - reinstall them and reset up the gmail app with your account.
    Fixed it immediately - obviously tried the notifications settings, data saver, power saver and the rest. This was the only thing that fixed it.
    07-25-2019 09:11 PM
  17. anon(5519702)'s Avatar
    So, I might have sorta fixed this issue on my phone. I turned on the "Notification Reminder" then selected "Selected apps" and shut off all the apps except for Gmail. I am now getting the notifications and not just at the 10 minute intervals, but as soon as I get a new email. I have no clue if this just fixed itself somehow or if this made a difference. You might try that and see what happens. With that being said...I'm not thrilled if this is the only solution.
    I've just read through this whole thread and checked the settings on my S10+. All were already as per the suggested configurations, except for the suggestion quoted here. Once I set the Notification Reminders, the Gmail notifications started popping up.

    What was weird for me, is that I have two accounts on my phone, one would send notifications, the other wouldn't. It was my main account that was not notifying.

    Thanks cfellswu.
    08-20-2019 11:15 AM
  18. AndroidSamsungGuy's Avatar
    This issue is finally solved for me, after 2 months, several factory resets, going through every fix listed here, regularly clearing partition cache, etc, etc.

    For me, it was linked to Google One backups somehow, I was maxed on storage and paying for a larger storage plan to handle images seemed to fix this. I'd be interested to here if anyone else experiences this fix
    Laura Knotek likes this.
    10-20-2019 10:40 PM
68 123

Similar Threads

  1. What happened to my android studio?
    By Android Central Question in forum Software Development and Hacking
    Replies: 3
    Last Post: 03-19-2019, 09:48 PM
  2. S10+ Wifi and Device Idling high battery drain
    By Android Central Question in forum Samsung Galaxy S10 & S10+
    Replies: 2
    Last Post: 03-19-2019, 03:17 PM
  3. Why did colors of tiles get changed?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-19-2019, 12:29 PM
  4. What's this icon in my notification tray?
    By Lecrae116 in forum Samsung Galaxy S10 & S10+
    Replies: 4
    Last Post: 03-19-2019, 12:14 PM
  5. What are the most popular developer options to toggle?
    By mrpackerguy in forum Google Pixel 3 & Pixel 3 XL
    Replies: 2
    Last Post: 03-19-2019, 12:01 PM
LINK TO POST COPIED TO CLIPBOARD