1. hnguyen's Avatar
    Anyone have issues seeing Chromecast devices to cast to in your apps? I have a pixel 3, iPhone 7, and Note9 and it works fine.

    After a reboot it seems to work fine but after about a day I would get the same issue and have to reboot again.

    I've read on forums about it being caused by battery optimization stuff, so I disabled it for the Google Home app, but it didn't fix it. Anyone got any advice?
    05-01-2019 11:34 PM
  2. WizeGuyDezignz's Avatar
    What is the exact issue that you're having?
    05-02-2019 12:13 AM
  3. hnguyen's Avatar
    What is the exact issue that you're having?
    If I open up youtube, netflix, or the Google home app (discovery) tab it will not show any chromecast devices, sometimes it does but if I click on the icon nothing happens. I'll force close the app to try again and the same thing happens (Sometimes no casting devices shows, or one of them pops up, but can't cast). All my other devices, ipads, iphones, note9, pixel3, they all work fine and i can see all 4 castable devices on my network and can easily cast to it.

    If i reboot my S10 all the casting devices will show up on my phone and i can easily cast to it. But the following day it'll all disappear, and I have to reboot the phone again. Realworld example, on Sunday I wanted to stream GOT with my HBONow app on my TV with a chromecast. When i opened the HBONow app i clicked on the cast button and saw one of my casting devices so I clicked on it and nothing happen (waited for 30 seconds). I closed out the app and tried again, but this time no casting device. I let the app stay open for a few minutes in case it popped up, but it didn't. I reboot the phone, and everything worked fine. So now I just use my note9 to do all my casting to my TV.
    05-02-2019 11:41 AM
  4. WizeGuyDezignz's Avatar
    If I open up youtube, netflix, or the Google home app (discovery) tab it will not show any chromecast devices, sometimes it does but if I click on the icon nothing happens. I'll force close the app to try again and the same thing happens (Sometimes no casting devices shows, or one of them pops up, but can't cast). All my other devices, ipads, iphones, note9, pixel3, they all work fine and i can see all 4 castable devices on my network and can easily cast to it.

    If i reboot my S10 all the casting devices will show up on my phone and i can easily cast to it. But the following day it'll all disappear, and I have to reboot the phone again. Realworld example, on Sunday I wanted to stream GOT with my HBONow app on my TV with a chromecast. When i opened the HBONow app i clicked on the cast button and saw one of my casting devices so I clicked on it and nothing happen (waited for 30 seconds). I closed out the app and tried again, but this time no casting device. I let the app stay open for a few minutes in case it popped up, but it didn't. I reboot the phone, and everything worked fine. So now I just use my note9 to do all my casting to my TV.
    Interesting. I'm gonna keep an eye on it and see if the same thing happens to me.
    05-02-2019 12:56 PM
  5. Rukbat's Avatar
    Pull down the notification bar - twice. If you don't see a "cast" icon (if all the icon slots are filled, scroll to the left), tap the pencil (edit), find the cast icon and move it up to where you can get to it. Use that to cast.
    05-03-2019 03:30 PM
  6. wookiee2cu's Avatar
    Is it only happening with HBO GO? If so I'd clear the cache by going to setting>apps>HBO GO>Storage and Clear cache and Clear data then restart the device. If it is happening with other apps the only other thing I can think of to try is wiping the cache partition. Check out this video adn jump to 1:40 where he starts going through the steps https://www.youtube.com/watch?time_c...&v=-tIFdbmawBI .
    05-03-2019 03:45 PM
  7. MarlburroW's Avatar
    If I open up youtube, netflix, or the Google home app (discovery) tab it will not show any chromecast devices, sometimes it does but if I click on the icon nothing happens. I'll force close the app to try again and the same thing happens (Sometimes no casting devices shows, or one of them pops up, but can't cast). All my other devices, ipads, iphones, note9, pixel3, they all work fine and i can see all 4 castable devices on my network and can easily cast to it.

    If i reboot my S10 all the casting devices will show up on my phone and i can easily cast to it. But the following day it'll all disappear, and I have to reboot the phone again. Realworld example, on Sunday I wanted to stream GOT with my HBONow app on my TV with a chromecast. When i opened the HBONow app i clicked on the cast button and saw one of my casting devices so I clicked on it and nothing happen (waited for 30 seconds). I closed out the app and tried again, but this time no casting device. I let the app stay open for a few minutes in case it popped up, but it didn't. I reboot the phone, and everything worked fine. So now I just use my note9 to do all my casting to my TV.
    I've exactly the same issue ! Works fine after reboot on any app, and the next day the cast icon is missing and I've to reboot again. (other device always works fine, this is only on my S10). Did you find a solution to this issue ?
    05-11-2019 02:53 PM
  8. hnguyen's Avatar
    I've exactly the same issue ! Works fine after reboot on any app, and the next day the cast icon is missing and I've to reboot again. (other device always works fine, this is only on my S10). Did you find a solution to this issue ?
    Unfortunately no. I have to use other devices to cast or I have to reboot. But if I find something I'll be sure to post back.
    05-12-2019 03:58 PM

Similar Threads

  1. Some users with pixel 3 issues still...
    By eric002 in forum Google Pixel 3 & Pixel 3 XL
    Replies: 16
    Last Post: 05-04-2019, 07:49 PM
  2. Group txt message issues
    By tomstark in forum Samsung Galaxy S10 & S10+
    Replies: 9
    Last Post: 05-03-2019, 04:55 PM
  3. Different AccuWeather Widget issue
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-03-2019, 03:56 PM
  4. Syncing issue
    By Rumblee1 in forum OnePlus 6 & 6T
    Replies: 2
    Last Post: 04-30-2019, 10:11 AM
  5. Live Wallpaper Issue After Theme
    By air2desk in forum Samsung Galaxy Note 9
    Replies: 0
    Last Post: 04-29-2019, 08:54 PM
LINK TO POST COPIED TO CLIPBOARD