1. frederickdawg's Avatar
    My problem with my new Samsung Galaxy S10+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message.

    Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

    I'd seriously consider another messaging app, however with my branded T Mobile device RCS only works using stock Samsung messaging between other T Mobile users.
    05-14-2019 08:23 PM
  2. mustang7757's Avatar
    My problem with my new Samsung Galaxy S10+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message.

    Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

    I'd seriously consider another messaging app, however with my branded T Mobile device RCS only works using stock Samsung messaging between other T Mobile users.
    Go to settings>lock screen>tap notifications>tap view style and choose iconsScreen wake up Samsung messaging-screenshot_20190514-215109_settings.jpeg
    05-14-2019 09:52 PM
  3. frederickdawg's Avatar
    Go to settings>lock screen>tap notifications>tap view style and choose iconsClick image for larger version. 

Name:	Screenshot_20190514-215109_Settings.jpeg 
Views:	40 
Size:	16.3 KB 
ID:	303277
    That's what I already had. It seems to be an issue with the screen waking up for just this particular app. Which is ironically a Samsung app.Screen wake up Samsung messaging-screenshot_20190514-221521_settings.jpg
    05-14-2019 10:17 PM
  4. mustang7757's Avatar
    That's what I already had. It seems to be an issue with the screen waking up for just this particular app. Which is ironically a Samsung app.Click image for larger version. 

Name:	Screenshot_20190514-221521_Settings.jpg 
Views:	42 
Size:	49.8 KB 
ID:	303278
    Hmmm...so it will wake up to lock screen ?
    05-14-2019 10:48 PM
  5. frederickdawg's Avatar
    Hmmm...so it will wake up to lock screen ?
    The screen lights up basically. I've tried multiple configurations and the screen still lights up when receiving a text message via Samsung messages. I did some more Google research, apparently it's been like this even for s9 users.
    05-14-2019 11:07 PM
  6. mustang7757's Avatar
    The screen lights up basically. I've tried multiple configurations and the screen still lights up when receiving a text message via Samsung messages. I did some more Google research, apparently it's been like this even for s9 users.
    It is weird, I text from my other phone and it bypasses AOD to lock screen
    05-15-2019 12:30 AM
  7. frederickdawg's Avatar
    The only band aid workaround I've figured so far to prevent the screen waking up when receiving text messages is the attached. However, this also stops any vibration notification and icon showing on the lock screen for said Samsung messaging app. Attached is my setup.

    Screen wake up Samsung messaging-screenshot_20190515-105520_settings.jpgScreen wake up Samsung messaging-screenshot_20190515-105751_settings.jpg
    05-15-2019 11:42 AM
  8. mustang7757's Avatar
    The only band aid workaround I've figured so far to prevent the screen waking up when receiving text messages is the attached. However, this also stops any vibration notification and icon showing on the lock screen for said Samsung messaging app. Attached is my setup.

    Click image for larger version. 

Name:	Screenshot_20190515-105520_Settings.jpg 
Views:	38 
Size:	35.5 KB 
ID:	303285Click image for larger version. 

Name:	Screenshot_20190515-105751_Settings.jpg 
Views:	39 
Size:	29.6 KB 
ID:	303286
    So you set it to silent and minimize?
    05-15-2019 08:04 PM
  9. frederickdawg's Avatar
    So you set it to silent and minimize?
    Yes for new messages.
    05-15-2019 08:19 PM
  10. frederickdawg's Avatar
    So you set it to silent and minimize?
    Tried this now. Get sound, but still no visual notification on AOD .still good as it doesnt wake up the screen.Screen wake up Samsung messaging-screenshot_20190516-145754_settings.jpgScreen wake up Samsung messaging-screenshot_20190516-145805_settings.jpg
    05-16-2019 02:59 PM
  11. lexee's Avatar
    You need root access so you can edit the config file of the stock Messages app manually. On my Nougat Android, this file is called /data/data/com.samsung.android.messaging/shared_prefs/com.samsung.android.messaging_preferences.xml. Pretty sure it's still there in the later Android versions.

    There are two lines in that file:

    <boolean name="pref_key_backlight" value="true" />
    <boolean name="pref_key_backlight_sim2" value="true" />

    Just change "true" to "false", save, reboot -- and there will be no more annoying screen wake from the stock Messages app.

    My problem with my new Samsung Galaxy S10+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message.

    Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

    I'd seriously consider another messaging app, however with my branded T Mobile device RCS only works using stock Samsung messaging between other T Mobile users.
    06-11-2019 10:54 AM
  12. frederickdawg's Avatar
    You need root access so you can edit the config file of the stock Messages app manually. On my Nougat Android, this file is called /data/data/com.samsung.android.messaging/shared_prefs/com.samsung.android.messaging_preferences.xml. Pretty sure it's still there in the later Android versions.

    There are two lines in that file:

    <boolean name="pref_key_backlight" value="true" />
    <boolean name="pref_key_backlight_sim2" value="true" />

    Just change "true" to "false", save, reboot -- and there will be no more annoying screen wake from the stock Messages app.
    Thanks for the information, that's one hell of a workaround
    06-11-2019 10:56 AM
  13. Crystal Diehl's Avatar
    You need root access so you can edit the config file of the stock Messages app manually. On my Nougat Android, this file is called /data/data/com.samsung.android.messaging/shared_prefs/com.samsung.android.messaging_preferences.xml. Pretty sure it's still there in the later Android versions.

    There are two lines in that file:

    <boolean name="pref_key_backlight" value="true" />
    <boolean name="pref_key_backlight_sim2" value="true" />

    Just change "true" to "false", save, reboot -- and there will be no more annoying screen wake from the stock Messages app.
    How do I get there to change this? With my job I can not have my screen keeps lighting up when I receive a new text.
    03-01-2020 05:21 PM
  14. VidJunky's Avatar
    Wow... I didn't read everything but I saw the mention of Root. Here is a video that will allow you to get RCS on any Android, without root, and using the Google Messaging app. Not sure if the Google app will by-pass the screen wake thing for you but it's easy, it works and you don't need root.



    Best wishes
    03-04-2020 05:25 AM
  15. rimz808's Avatar
    I am actually trying to do the reverse. I want to see my text message pop up with preview and wake up my lock screen. Instead of me having to constantly touch the screen to quickly see who texted me.

    Right now, when a text comes in, it shows the icon on the AOD and I have to double tap the screen to then see the message in the lockscreen. I would like to not have to double tap to wake up the screen.

    Is it possible?
    12-02-2020 04:22 PM

Similar Threads

  1. Verizon Message+ help
    By lparsons21 in forum Android Apps
    Replies: 1
    Last Post: 05-15-2019, 01:20 PM
  2. why is there green tint on my screen
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-14-2019, 03:40 PM
  3. text message no longer going to email on Samsung S9+
    By Android Central Question in forum Samsung Galaxy S9 & S9+
    Replies: 1
    Last Post: 05-14-2019, 02:24 PM
  4. text message no longer going to email on Samsung S9+
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-14-2019, 01:46 PM
  5. WTS: Two Samsung Galaxy S9 Verizon Unlocked
    By cbs1507 in forum The Marketplace - Buy, Sell & Trade
    Replies: 0
    Last Post: 05-14-2019, 01:32 PM
LINK TO POST COPIED TO CLIPBOARD