1. Vatish Sharma's Avatar
    I am using Heimdall v1.4.2. I have compiled it from the source code.

    I have run the `heimdall detect` and `heimdall print-pit --verbose`.

    My device is successfully detected by the Heimdall but the second command failed. I am using Samsung S10 5G device(Qualcomm). Following are the logs:

    ```
    heimdall print-pit --verbose
    Heimdall v1.4.2

    Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

    This software is provided free of charge. Copying and redistribution is
    encouraged.

    If you appreciate this software and you would like to support future
    development please consider donating:

    Initialising connection...
    Detecting device...
    Manufacturer: "Samsung"
    Product: "SM8150"

    length: 18
    device class: 2
    S/N: 0
    VID:PID: 04E8:685D
    bcdDevice: 021B
    iMan:iProd:iSer: 1:2:0
    nb confs: 1

    interface[0].altsetting[0]: num endpoints = 1
    Class.SubClass.Protocol: 02.02.01
    endpoint[0].address: 82
    max packet size: 0010
    polling interval: 09

    interface[1].altsetting[0]: num endpoints = 2
    Class.SubClass.Protocol: 0A.00.00
    endpoint[0].address: 01
    max packet size: 0200
    polling interval: 00
    endpoint[1].address: 81
    max packet size: 0200
    polling interval: 00
    Claiming interface...
    Setting up interface...

    Initialising protocol...
    ERROR: libusb error -7 whilst sending bulk transfer. Retrying...
    ERROR: libusb error -7 whilst sending bulk transfer. Retrying...
    ERROR: libusb error -7 whilst sending bulk transfer. Retrying...
    ERROR: libusb error -7 whilst sending bulk transfer. Retrying...
    ERROR: libusb error -7 whilst sending bulk transfer. Retrying...
    ERROR: libusb error -7 whilst sending bulk transfer.
    ERROR: Failed to send handshake!ERROR: Failed to receive handshake response. Result: -7
    ERROR: Protocol initialisation failed!

    Releasing device interface...

    ```

    I have read another similar issues and tried following things:

    1. Tried different cables (Type-C to Type-C, Type-C to USB)
    2. Tried different ports.
    3. Plug-Unplug cable before run command.
    4. Reboot the machine after Heimdall source code compilation.
    5. `sudo apt update && sudo apt upgrade`.
    6. Below is the `libusb` detail:
    ```
    dpkg -l libusb-1*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-==============-============-============-=================================
    ii libusb-1.0-0:a 2:1.0.21-2 amd64 userspace USB programming library
    ii libusb-1.0-0-d 2:1.0.21-2 amd64 userspace USB programming library
    ii libusb-1.0-doc 2:1.0.21-2 all documentation for userspace USB p

    ```

    Please suggest how can I resolve this issue.
    10-16-2019 06:57 AM
  2. B. Diddy's Avatar
    I moved this from the Galaxy S forum (for the ancient original Galaxy S phone) to the S10 forum for more appropriate traffic.
    Laura Knotek likes this.
    10-19-2019 12:30 AM
  3. Laura Knotek's Avatar
    What exactly is your intention regarding this app and this script? Please send me a PM with further details. I'll close this thread until I receive further information from you.
    mustang7757 likes this.
    10-19-2019 12:41 AM

Similar Threads

  1. Samsung Email Error
    By Hermes Hidayat in forum Samsung Galaxy Note 10 & Note 10+ (2019)
    Replies: 6
    Last Post: 10-16-2019, 08:33 PM
  2. Sending pics, emoji etc via text on LG Stylio5 impossible
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 10-16-2019, 03:14 PM
  3. I can not send my messages
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 10-16-2019, 12:59 AM
  4. Why cant i send a vid that is only 50 secs long to friends on messenger?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2019, 12:43 AM
  5. Nokia 3 w/Android 9 & ATT, lost ability to send SMS text!
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-15-2019, 11:29 AM
LINK TO POST COPIED TO CLIPBOARD