1. Android Central Question's Avatar
    I fly almost exclusively American Airlines. To access their "on-board entertainment", you connect to their WiFi network and open the American Airlines app. Typically, you can click on "entertainment" and watch movies from there.

    Ever since I got my Galaxy S10, the device will detect and connect to the AA Wifi network, but my "Connections" screen will tell me that "Internet may not be available." I'll go to the AA app and you can tell it's connected because it updates my flight information. However, when I click on "entertainment", the app tells me to "first connect to the Wifi" and has a link for me to click on that takes me to my phone's Settings, where my phone says it's already connected and that there's no internet coming through.

    I have tried for (literally) hours to reset my phone, forget the network, have fiddled with every setting I can change, cleared the app data cache and Forced Stop. It has to be something with the S10, as I don't have any issue with my (business) iPhone.

    I DON'T KNOW WHAT ELSE TO DO! PLEASE HELP! I love watching movies on planes and it is maddening to not be able to do so because of some stupid glitch.
    11-26-2019 05:50 PM
  2. mustang7757's Avatar
    Hi, welcome to Android Forums

    I'd like to recommend creating a account so me or other members can assist you, as guest have limitations in replying here and if we need further Information to communicate with you.

    I'll provide a link to register, please come back to your post so we can further assist

    https://forums.androidcentral.com/sh...d.php?t=409154
    11-26-2019 06:09 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! What happens if you connect to the wi-fi, open the browser, and then type any URL (like cnn.com)? Does that force the AA login page to show up?
    11-26-2019 10:39 PM
  4. Gayle Lynn's Avatar
    Funnily enough on macrumors forum folks having trouble with public wifi with iOS 13 and iPhones.

    S10 supports WiFi 6 AX as does iPhone 11.

    You've tried turning on Airplane mode leave that on then turn wifi back on?

    Apple appears to be blaming older router wifi for being out of date and not properly secured.

    I found some apps won't work with that same error 😡 and they are not actually testing wifi but quering the phone... not the actual internet connection.

    Are you on Android 9 or latest beta 10?
    11-27-2019 06:08 AM
  5. Rukbat's Avatar
    And have you tried calling AA and asking how to get their "tech support" department. (Funny that an airline now needs to supply tech support for their customers.) There may be something different about their network (maybe what B. Diddy said - a captive login page). Or ... they may want to get an S10, set up the way yours is, and find out why S10s don't connect. (That's the reason for betas too - the developers and engineers can't fix a problem unless someone tells them that they have one. QA and QC catch some of the problems, but - old computer saying - once you exceed 10 lines of code, there are errors. And they can't possibly find them all*. So sometimes, users have to let them know that there's a problem.)

    *The people who developed the system know that you don't do "that", so they'd never do it to see if doing it breaks anything. Except that 99.999% of the users don't know not to do "that", so they do ... and it breaks.

    (My "new" MSI motherboard - which I returned - wouldn't recognize 2 NVMe M.2 SSDs. Each one worked separately. In either slot. But put both of them in and there was only 1 recognized. MSI's response? "not many will usually want to have M.2 OS & M.2 storage setup, usually solution is standard SATA drive for this". You can not make this stuff up. I copied it from their response on their page, and pasted it here. I buy a board with 2 slots, but I can't have a C drive and a D drive? Is it 1919 or 2019? Some developers develop great stuff. Some developers leave their minds at home when they go to work. Then you call them and they think, "Oh! I never thought of that." So maybe AA's engineers "never thought of" something that's preventing these phones from connecting. No one would want to connect an S10 or an iPhone 11 to the entertainment network, so why bother, right? Oh ...)
    Gayle Lynn likes this.
    11-27-2019 03:45 PM
  6. 11B1P's Avatar
    Why not download some movies from your favorite streaming service (Netflix, Hulu, Disney+, etc.) to your SD card? Then you can forego all the hassel.
    11-27-2019 07:11 PM
  7. robber's Avatar
    Try navigating to AAinflight.com and access entertainment from there. Once you actually start watching something it will open in the app.
    11-29-2019 01:23 PM

Similar Threads

  1. Can't Mirror Share
    By Awabennett in forum Honor 7X
    Replies: 5
    Last Post: 12-05-2019, 03:46 AM
  2. A couple small things I'd like to change...
    By GracieAllen in forum Samsung Galaxy Tab S6
    Replies: 2
    Last Post: 11-27-2019, 05:46 PM
  3. Why can i no longer add photos in Messenger?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-26-2019, 10:48 PM
  4. Samsung galaxy not 2 network mode issue SHV-E250L
    By Android Central Question in forum Samsung Galaxy Note 2
    Replies: 3
    Last Post: 11-26-2019, 10:47 PM
  5. Notifications on Android 9 - Galaxy Note 10
    By MIBUK in forum Samsung Galaxy Note 10 & Note 10+ (2019)
    Replies: 1
    Last Post: 11-26-2019, 06:54 PM
LINK TO POST COPIED TO CLIPBOARD