1. Cipri C's Avatar
    Whenever I try to delete something from the internal storage of my Galaxy S2 it gives me an error message: Cannot delete: The storage is write protected. Please remove write protection and try again.(This does NOT happen on my external sd card! That works perfectly fine! This happens on the internal storage of the phone) But it doesnt end here, my apps dont work because of this. They crash and most of them tell me I dont have enough internal storage(Tumblr won't load images, Instagram crashes after a few seconds of use, Viber and Whatsapp won't let me send or receive images, videos, voice notes and the Gallery won't open saying that I don't have enough storage.) When I'm on my phone and try to delete something from My Files its says that the file has been deleted but it's still there. I'm guessing somehow I don't have permission to edit the files on my internal storage or something. And also my apps, it's like they're not allowed to download files anymore because there's no more storage(except Google Play, downloading apps is no problem)
    However when I restart the phone, a few seconds after it starts up, everything seems to work fine.(I can see the pics in my gallery without the error message showing up, I can record voice notes and send pictures just fine, and instagram or tumblr work fine) But after a few seconds everything goes back and nothing works again.
    I tried a resetting my internal storage. So I it was just like new now, but the issue still occured even though I had more than enough storage. Booting in safe mode also doesnt do anything. Please help!
    03-24-2015 01:55 AM
  2. MajdiHashoul's Avatar
    I am Handeling the Same problem without any solution,
    The Storage seems to be empty, but the files still there,
    So there is a protection error or a maping error in LG G3.
    If some one can Help ..
    04-10-2015 04:59 AM
  3. anil byanju's Avatar
    i have the exact same problem, just exact. but dont have a real solution to that. but rooting the phone then changing the kernel seems to work. i had used a kernel called speedmod in which this problem is sorted out but the phone lags with this kernel after using for a month or so.
    04-24-2015 12:47 PM
  4. lordofcyberpunk's Avatar
    also having to same problem but with ext sdcard. tryed sdfix app but doesn't workcan any one help me to sort this out. model is sm-g355h.
    08-15-2015 07:59 AM
  5. Sahib Meet's Avatar
    same problem ...... any solution ??
    09-19-2015 01:35 AM
  6. lordofcyberpunk's Avatar
    yup..! i solved it apply a factory reset after rooting... then simply install
    SDFix: KitKat Writable MicroSD from app store
    then restart ur phn but don't uninstall this app. enjoy.
    09-20-2015 02:02 AM

Similar Threads

  1. How do I transfer music from the SIM card to music player?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 03-24-2015, 05:29 PM
  2. Replies: 1
    Last Post: 03-24-2015, 05:04 PM
  3. How do I have a a 'one click' app for a web page?
    By earlybutternut in forum Ask a Question
    Replies: 6
    Last Post: 03-24-2015, 12:11 PM
  4. How can I get my texts from my phone to my pc?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-24-2015, 01:45 AM
  5. Is the Spotify App running on Android Auto yet?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-24-2015, 01:35 AM
LINK TO POST COPIED TO CLIPBOARD