1. AC Question's Avatar
    Model SGH-T989 Version 4.1.2
    03-29-2015 07:36 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Android Wear requires 4.3 or higher, so you're probably limited to Pebble (which is 4.0 or higher).
    03-29-2015 07:59 PM

Similar Threads

  1. Download files from S5 with a non-functional screen.
    By Sameer El-Khal in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 08-21-2015, 08:30 AM
  2. New circle widget design with Lollipop?
    By TechCaptain in forum Motorola Droid MAXX
    Replies: 4
    Last Post: 04-02-2015, 06:28 PM
  3. Will ATT ship phones before the 8th?
    By ballaonnabudget in forum Samsung Galaxy S6 edge
    Replies: 7
    Last Post: 03-30-2015, 07:10 PM
  4. Why does this app say my phone is incompatible with the app?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 03-29-2015, 08:24 PM