1. Farmer Ghetts's Avatar
    Hi all,

    I've just started using a Samsung S2 GT-I9100. I have a giffgaff sim in it. I would like to use snapchat with it, which requires android 4.0, but mine is currently 2.3.3 and when I check for software updates, nothing is available.

    Any suggestions?
    06-09-2015 05:23 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You could see if your exact model has a firmware of 4.0 or higher here: Firmwares - SamMobile. Then use Odin to flash it: http://forums.androidcentral.com/amb...interface.html
    06-10-2015 01:16 PM
  3. asmarkowitz's Avatar
    I am having the same problem, recently bought a secondhand Galaxy S2 with 2.3.3., unlocked and I use Virgin SIM on a monthly contract. I have been unable to upgrade Android. Kies recognizes the phone but does not show any firmware updates. According to SamMobile my model (GT-I9100) goes to 4.1.2. I took it to a mobile tech who tried to flash it with Odin in order to upgraded, but Odin would not recognize the phone. I did a root check and it is unrooted.

    The retailer I bought it from says the S2 cannot be upgraded, but I know that's bull. Any idea what might be causing my phone to be un-upgrade-able?
    09-14-2015 12:11 PM

Similar Threads

  1. How can I scale an image?
    By Joachim Larsen in forum Displays
    Replies: 3
    Last Post: 06-12-2015, 03:08 PM
  2. How can I install Facebook app Huawei P8?
    By Rodolfo Rangel in forum Huawei P8
    Replies: 1
    Last Post: 06-10-2015, 01:17 PM
  3. Replies: 3
    Last Post: 06-09-2015, 07:35 PM
  4. Why can't I find Blocking Mode anymore?
    By Alishibaz in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 06-09-2015, 07:25 PM
LINK TO POST COPIED TO CLIPBOARD