1. AC Question's Avatar

    My GPS was not working for a long time. It didnt get GPS fixes usually. Sometimes it got the fix but very seldomly. My phone is Samsung S2 (GT-I9100). Not rooted.

    After trying to find different solutions, I finally did a mistake (at least i think so) by installing the following GPS patch file: gps_patch_v2.zip . I installed the file from external SD card in recovery mode. After installing it, my GPS does not work at all. Now google maps or navigation or GPS TEST application they all dont find GPS at all. I mean no searching and so on (and no blinking gps sign on left upper corner after opening google maps or camsam. Was it a total mistake to install that file?

    I think that file was not good for my non-rooted phone. My phone is not rooted but on that web site they told that it is also for non-rooted phones. So because the zip.file didnt do any good for my phone, then i tried to do the restore with the other zip file mentioned in that web site for restoring: the restore file is called gps_ori.zip . I tried to do it in recovery mode from external sd card too. But it was not installed because of authentication errors. I tried several times, but always those errors came.

    This is the web site where this whole advice was given was xda-developer-com.

    So now I am totally without gps (no blinking gps sign when maps or navigation is on). I even did factory setting for my samsung s2 yesterday and it has again the same 4.1.2 android. But gps has still the same problem that appeared after installing that "gps_patch_v2.zip". I think the file may have been totally wrong for my phone and it was not changed in factory reset.

    What can i do? Do you have another better zip.file that i could install in recovery mode? That gps_ori.zip can not be installed because of those authentication problems. I think I need very orginal gps.zip.file that is accepted by my phone in recovery mode.

    I would be very grateful to find a solution how to repair this gps in my samsung s2 because my work require navigation when i use a car.

    If there is a solution, please give me very grassroot level advice because i am not good with mobile phones.

    Or if you can advice me about someone who knows more. So even going back to factory settings didnt help me. I tried it yesterday. I even tightened the screws of the mobile phone cover because somewhere in You Tube there was an advice video that loosened screws can somehow make gps part of the phone weakly connected. But I dont know the result of that advice because this wrong zip.file installation was done before tightening the screws.

    Thank you. I really appreciate the help.
    09-03-2015 10:18 AM
  2. nahoku's Avatar
    I was going to suggest you reflash your OS via ODIN, however, I think it might be a good idea to visit your carrier and have them assist in reflashing the OS for you. It sounds like your phone is working other than GPS, so be sure to backup all your data before you visit the carrier.
    09-03-2015 10:55 PM

Similar Threads

  1. Which Samsung should I get?
    By Turns31 in forum Samsung Galaxy S6
    Replies: 20
    Last Post: 09-05-2015, 01:16 PM
  2. Google now reminders are always silent
    By rpaloalto in forum Google Nexus 5
    Replies: 1
    Last Post: 09-03-2015, 01:13 PM
  3. Why doesn't Xfinity TV Go app not work with my Samsung S?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-03-2015, 01:03 PM
  4. Replaced Sim Card now battery draining fast and phone hot
    By Ruth Sullivan1 in forum Samsung Galaxy S6
    Replies: 4
    Last Post: 09-03-2015, 11:12 AM
  5. Replies: 0
    Last Post: 09-03-2015, 09:16 AM