1. Lundon44's Avatar
    Wow, more than 100 days since I pre-ordered with PDA Plaza. To clarify, this is the dual sim Snapdragon variant of the 512GB/16GB RAM S20 Ultra (aka SM-G9880).

    So far, everything mostly works as it should except for one thing. I live in Toronto, Canada and have my personal sim with Telus and my work sim with Bell. I noticed today while making calls on my Telus sim that the connection would drop down to H or H+ during calls. Some calls would not even connect and others I had horrible reception as if I'm talking to someone 10 stories underground. Calls on my Bell sim on the other hand were clear and data connection wouldn't drop. I did some reading and double checked VoLTE was on.

    No matter what I tried I couldn't get the Telus sim working properly. I swapped sim slots and same results. Also noticed my speed tests on the Telus sim were horrible around 7mb download and 38mb upload on most tests. I did a chat with Telus support, they said my phone was not provisioned for VoLte on their end. That fixed that problem. We spent about an hour or so troubleshooting my horrible data speeds. I found that when I disabled the "automatic network selection" option and manually selected Telus as the network that it boosted my data speeds up to around 25mb on the download and 40ish on upload which the said is about where it should be for LTE.

    Now the last thing I noticed is my phone NEVER displays LTE on the notification bar as my data connection. I'm literally right downtown Toronto and in the best possible area for signal. And the speedtest app itself says "LTE" in the results page when I perform my tests. Yet it will only display 4G as the connection. Same with the Bell sim. I'm not sure if this is a software "bug" because it's from Hong Kong but I have to assume that they have LTE there lol.

    If anyone has any advice or questions about the variant I'd be happy to answer them!
    05-29-2020 08:53 PM
  2. mustang7757's Avatar
    Make sure the APN are correct? Did it automatically populate them? Also that phone for different region so not sure what bands it works for .
    05-29-2020 10:18 PM
  3. Lundon44's Avatar
    Yes it did auto-populate them. I checked compatibility and I seem to be covered.

    The SM-G9880 supports the following bands:
    Network: LTE Band: 1(2100), 2(1900), 3(1800), 4(1700/2100), 5(850), 7(2600), 8(900), 12(700), 13(700), 14(700), 18(800), 19(800), 20(800), 25(1900), 26(850), 28(700), 29(700), 30(2300), 38(2600), 39(1900), 40(2300), 41(2500), 46(5200), 48, 66(1700/2100), 71(600), 3G Band: HSDPA 850 / 900 / 1900 / 2100

    Telus uses:
    4G : 850 MHz Cellular, Band 5 (LTE). 1900 MHz PCS, Band 2 (LTE/ LTE Advanced). 700 MHz A/B/C/E, Band 12/13/17/29 (LTE/ LTE Advanced). 1,700/2,100 MHz AWS, Band 4 (LTE/ LTE Advanced). 2,600 MHz IMT-E, Band 7 (LTE/ LTE Advanced).

    Bell uses:
    4G : 700 MHz A/B/C/C2/E, Band 12/17/13/29 (LTE / LTE Advanced). 850 MHz Cellular, Band 5 (LTE). 1900 MHz PCS, Band 2 (LTE / LTE Advanced). 1700/ 2100 MHz AWS, Band 4 (LTE / LTE Advanced). 2600 MHz IMT-E, Band 7 (LTE / LTE Advanced).

    Or am I not catching something here...
    05-29-2020 10:31 PM
  4. mustang7757's Avatar
    Yeah seems to be covered .

    You been in different areas to see if lte would come on at some point ?
    05-29-2020 10:54 PM
  5. Lundon44's Avatar
    I haven't been outside much today. However, living in the most central downtown of the city where I'm surrounded by towers you'd just assume that my speeds would be extremely high. But it appears I'm not hitting LTE-A connections or speeds somehow.. Could it be a throttling issue by the carriers? Maybe due to Covid? I'm just making wild guesses. My pal in Edmonton, Alberta that just got a Z Flip from Hong Kong got 150mb on his speed test with Koodo. I don't get it lol.
    05-29-2020 10:58 PM
  6. mustang7757's Avatar
    I haven't been outside much today. However, living in the most central downtown of the city where I'm surrounded by towers you'd just assume that my speeds would be extremely high. But it appears I'm not hitting LTE-A connections or speeds somehow.. Could it be a throttling issue by the carriers? Maybe due to Covid? I'm just making wild guesses. My pal in Edmonton, Alberta that just got a Z Flip from Hong Kong got 150mb on his speed test with Koodo. I don't get it lol.
    Possible because covid19 everyone using their devices , I would wait and see once you start moving around if anything to be concerned about
    05-29-2020 11:06 PM
  7. Ranny99's Avatar
    Hows it run as a single sim in either slot?
    mustang7757 likes this.
    05-30-2020 03:31 PM
  8. mustang7757's Avatar
    Hows it run as a single sim in either slot?
    Good point , forget it's dual SIM
    05-30-2020 03:33 PM
  9. Lundon44's Avatar
    You mean remove one sim?
    05-30-2020 04:49 PM
  10. mustang7757's Avatar
    You mean remove one sim?
    Try that or swap slots
    05-30-2020 05:30 PM
  11. Ranny99's Avatar
    You mean remove one sim?
    Yes just try the Telus sim in both slots.

    Also do you have access to another mobile to get a test download.
    05-30-2020 05:52 PM
  12. Lundon44's Avatar
    Update! Went for a walk around the city today. Did a random speed test on both sims. Telus scored a 251mb download speed. So clearly must be the towers near my home. Seems like the phone itself is fine.
    mustang7757 likes this.
    05-30-2020 10:58 PM
  13. mustang7757's Avatar
    Update! Went for a walk around the city today. Did a random speed test on both sims. Telus scored a 251mb download speed. So clearly must be the towers near my home. Seems like the phone itself is fine.
    Glad to hear that
    05-30-2020 11:04 PM

Similar Threads

  1. Why is my S7 shutting off
    By SimonsG in forum Ask a Question
    Replies: 6
    Last Post: 06-15-2020, 07:31 PM
  2. Will S20+ get QHD with 120hz?
    By BigMosely in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 8
    Last Post: 06-01-2020, 07:53 AM
  3. Realme 5pro Dual whatsapp account can't sync with my contacts
    By Marwa Youssef in forum Android Apps
    Replies: 9
    Last Post: 05-30-2020, 08:20 AM
  4. Replies: 2
    Last Post: 05-30-2020, 08:04 AM
  5. Why is my phone fails on abd
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 05-29-2020, 02:39 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD