1. DUTCH VanAtlanta's Avatar
    I've noticed that my US unlocked S20 Ultra 512 GB is extremely slow to send emails on ATT LTE when not on WiFi. In fact it frequently sends slow enough to time out on a simple text email, and place it in the Outbox until I am back on WiFi. I've noticed this especially when out and about, even when the ATT LTE signal is strong.

    I just did a comparative test at home where i have both good WiFi and a strong ATT LTE signal. I sent an email containing a 2 MB photo file, which is not all that large.

    On WiFi it took 11 seconds to send. On LTE it took 29 seconds to send.

    Are these numbers normal? Thoughts, suggestions? TIA!
    07-13-2020 03:38 PM
  2. mustang7757's Avatar
    You can try resetting network in settings >general management >reset>reset network
    07-13-2020 05:58 PM
  3. B. Diddy's Avatar
    Also, try giving AT&T support a call, in case there are any known network issues in your area.
    07-13-2020 06:08 PM
  4. DUTCH VanAtlanta's Avatar
    I don't think it's ATT. I think it's Comcast with POP3 access.

    I just tried the same tests using Gmail with IMAP access, and it was much faster compared to POP3 Comcast.
    07-14-2020 04:16 PM
  5. mustang7757's Avatar
    I don't think it's ATT. I think it's Comcast with POP3 access.

    I just tried the same tests using Gmail with IMAP access, and it was much faster compared to POP3 Comcast.
    Just your Gmail the issue?
    07-14-2020 06:10 PM
  6. DUTCH VanAtlanta's Avatar
    Just your Gmail the issue?
    Nope. Gmail is A-OK. The Comcast email is the one that's slow.
    07-14-2020 06:24 PM
  7. mustang7757's Avatar
    Nope. Gmail is A-OK. The Comcast email is the one that's slow.
    Have you figured it out ?


    Edit: comcast email you tried clearing its cache, force stop it ?
    07-14-2020 06:44 PM
  8. DUTCH VanAtlanta's Avatar
    Have you figured it out ?


    Edit: comcast email you tried clearing its cache, force stop it ?
    Not sure I know how to do that.
    07-15-2020 11:24 AM
  9. mustang7757's Avatar
    Not sure I know how to do that.
    Just long press the app tap info ,then scroll to storage clear data,cache then force stop it
    07-15-2020 11:28 AM
  10. DUTCH VanAtlanta's Avatar
    Just long press the app tap info ,then scroll to storage clear data,cache then force stop it
    Gotcha. Thanks.
    mustang7757 likes this.
    07-15-2020 11:31 AM
  11. DUTCH VanAtlanta's Avatar
    It's Comcast email. Even my Windows desktop email client is taking it's time connecting and sending on the Comcast domain, and that's on a hardwired system.
    07-19-2020 02:53 PM
  12. Laura Knotek's Avatar
    It's Comcast email. Even my Windows desktop email client is taking it's time connecting and sending on the Comcast domain, and that's on a hardwired system.
    How about using IMAP for Comcast email?
    07-19-2020 03:42 PM
  13. DUTCH VanAtlanta's Avatar
    How about using IMAP for Comcast email?
    https://forums.androidcentral.com/e?...token=zk9MjlW9
    Thanks, but for some reason your link goes nowhere for me.
    07-19-2020 03:59 PM
  14. Laura Knotek's Avatar
    Thanks, but for some reason your link goes nowhere for me.
    https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email
    mustang7757 likes this.
    07-19-2020 06:16 PM
  15. DUTCH VanAtlanta's Avatar
    https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email
    Thanks.
    Laura Knotek likes this.
    07-19-2020 06:51 PM
  16. Laura Knotek's Avatar
    Thanks.
    You're welcome. I hope that helps.
    mustang7757 likes this.
    07-19-2020 10:45 PM
  17. DUTCH VanAtlanta's Avatar
    You're welcome. I hope that helps.
    IMAP seems to connect faster than POP3 to Comcast email, BUT!! When I delete an email on my Galaxy IMAP connection, it also deletes it on the Comcast email server; and that's not acceptable to me. I want to be able to go back later and access those emails on my desktop. Not possible with IMAP on the Galaxy.

    I do appreciate your gesture. Thanks again.
    07-22-2020 03:02 PM
  18. B. Diddy's Avatar
    With IMAP, though, there's no need to delete the email on your phone if you want to keep it on the server -- the email itself is taking up negligible storage space on the phone with IMAP, since it's syncing, not downloading emails en masse to the phone. It's essentially the same as accessing your email on a webmail interface.
    Laura Knotek likes this.
    07-22-2020 03:11 PM
  19. DUTCH VanAtlanta's Avatar
    With IMAP, though, there's no need to delete the email on your phone if you want to keep it on the server -- the email itself is taking up negligible storage space on the phone with IMAP, since it's syncing, not downloading emails en masse to the phone. It's essentially the same as accessing your email on a webmail interface.
    Thanks, but I do not want to have to sort through a whole bunch of email headers left on the phone after I've read them. I'll just live with the slower but less cluttered POP3 on Comcast.

    PS - This never happened with POP3 on my HTC 10. Maybe Comcast is slowing down with the Covid rush.
    07-22-2020 03:22 PM
  20. B. Diddy's Avatar
    Oh I see. I get around that by filing away emails I want to keep in custom folders, so that my main inbox remains fairly uncluttered. Hopefully things get a little better with the POP3 server!
    Laura Knotek likes this.
    07-22-2020 07:24 PM
  21. DUTCH VanAtlanta's Avatar
    I just did a test on 4G LTE with WiFi turned off. To send a 1.3 MB image from my POP3 Comcast email took 23 seconds to complete. Switched over to send from my IMAP Comcast email the same image took 41 seconds to complete. Interesting. I think I'll stick with POP3.
    07-23-2020 01:54 PM
  22. B. Diddy's Avatar
    Wow, regardless of the server you use, that's pretty slow. What are your usual download/upload speeds if you go to speedtest.net or use the speed test feature in the Google app (i.e., search "speed test" in Google)?
    07-24-2020 12:05 AM
  23. DUTCH VanAtlanta's Avatar
    A lot of the time with Comcast email seems to be taken up with getting past the log-in, be it POP3 or IMAP.
    07-24-2020 06:59 AM

Similar Threads

  1. Can't transfer files from Redmi 7a to PC, freezes up, causes other errors.
    By RogellParadox in forum Xiaomi Android Phones
    Replies: 8
    Last Post: 07-21-2020, 05:50 PM
  2. AT&T still using "5G-E" icon or not?
    By joeldf in forum General Carrier Discussion
    Replies: 7
    Last Post: 07-15-2020, 11:48 PM
  3. I have LG Stylo 4, my USB tethering option on the phone is grayed out?
    By Android Central Question in forum LG Stylo 4
    Replies: 4
    Last Post: 07-13-2020, 09:20 PM
  4. Zedge Ringtones saving to Amazon Music?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-13-2020, 06:00 PM
  5. Replies: 2
    Last Post: 07-13-2020, 05:58 PM
LINK TO POST COPIED TO CLIPBOARD