1. RapidTurtle's Avatar
    I'm on AT&T, and just picked up the S20. At a gas station this morning, I downloaded waze, and it took about 5 minutes for it to download. It was super slow, even though I had full bars, and the signal said 5G. I also noticed at work that while watching some youtube tv , I encountered buffering with full bars and the 5G signal, several times. Never had these problems on my S9 with 4g LTE in these areas. I took some speed test, and they were all over the place. Sometimes I would hit in the 80's , and others in the single digits. Is it the phone, or maybe the network?
    08-18-2020 07:52 PM
  2. missy8787's Avatar
    Does it just do that on 5g or also when its 4g lte?
    08-18-2020 08:14 PM
  3. RapidTurtle's Avatar
    At work and that gas station, and here at home, I only had 5G. My son had his Iphone on 4G LTE, and was getting in the 50's on a speed test, and I was only getting around 10 with 5G here at home. Is there a way to turn off 5G, and only have it on 4G?
    I also just got off the phone with AT&T. They did a few things on their end, and I reset network settings, but my speeds actually got slower. They are escalating this up the ladder. I'm not sure how many of you have had to deal with AT&T help, but I have very little faith, and think I will probably be going back to my old phone, and trusty 4G.
    08-18-2020 08:52 PM
  4. missy8787's Avatar
    At work and that gas station, and here at home, I only had 5G. My son had his Iphone on 4G LTE, and was getting in the 50's on a speed test, and I was only getting around 10 with 5G here at home. Is there a way to turn off 5G, and only have it on 4G?
    I also just got off the phone with AT&T. They did a few things on their end, and I reset network settings, but my speeds actually got slower. They are escalating this up the ladder. I'm not sure how many of you have had to deal with AT&T help, but I have very little faith, and think I will probably be going back to my old phone, and trusty 4G.
    I believe it's in network settings that u can set it up for 4g lte only
    08-18-2020 08:56 PM
  5. RapidTurtle's Avatar
    From what I have looked up, I can't change it on an AT&T phone.
    08-18-2020 09:05 PM
  6. missy8787's Avatar
    Hmm thats weird I thought any phone you can. Maybe at&t blocks that feature idk why they would
    08-18-2020 09:07 PM
  7. Kizzy Catwoman's Avatar
    The S20 has sub6 5G built in which should give you speeds around the top end of 4G. But even so your speeds seem really slow. Check under connections and mobile to choose between they types of connection. You should be able to choose 4G.
    Laura Knotek likes this.
    08-18-2020 09:13 PM
  8. RapidTurtle's Avatar
    It must have something to do with it being at-t branded phone, not being able to switch connection type. I am supposed to hear from them today, but like I said, I have very little faith in AT&T.
    08-19-2020 04:27 AM
  9. daswooski's Avatar
    It must have something to do with it being at-t branded phone, not being able to switch connection type. I am supposed to hear from them today, but like I said, I have very little faith in AT&T.
    Correct, AT&T does not allow several features on unlocked phones and it is ridiculous as Verizon and TMo have no problem allowing VOLTE, WiFi Calling, etc...AT&T whitelist phones and refuses to allow all the features that they say are part of their service
    J Dubbs likes this.
    08-19-2020 10:47 PM
  10. RapidTurtle's Avatar
    My phone is AT&T branded though, bought online through them.
    08-20-2020 08:22 PM
  11. poit57's Avatar
    According to AT&T's support when I called them last month, Oklahoma City has one tower with 5G in the downtown area. I just got my S20 on Saturday and happened to be downtown when I noticed that I was getting a 5G icon next to the antenna indicator. I was on the bottom floor of a shop next to the canal (below ground level). I don't know how much that might have affected my signal, but I got about 62 Mbps download.

    My house is about 15 miles away and only has 4G LTE. I performed a speed test that night and got 186 Mbps download. Throughout the week, I've tested in various locations with 4G and ranged from about 9.5 to 84 Mbps. The high that I've seen other than my house was at my office where my speed tests with my LG V40 ranged between 20 and 40 Mbps.

    The LG V40 was certified for AT&T's "5G Evolution" that we do not have in OKC. The download speeds at my house topped out around 115 Mbps on 4G with that phone. I was in Tulsa about a month ago where my LG showed the "5G E" indicator, but I was only able to top out around 35 Mbps with 5G E.
    daswooski likes this.
    08-28-2020 10:25 AM
  12. joeldf's Avatar
    My phone is AT&T branded though, bought online through them.
    AT&T blocks any phone from changing network type once you are on their network. They've always done that.
    08-28-2020 11:39 AM
  13. daswooski's Avatar
    I have a Unlocked S20+ and have jumped back and forth from AT&T to Verizon to Tmo several times by just swapping the SIM out...no problems but no VOLTE or WiFi Calling when I have the AT&T SIM inserted
    08-28-2020 12:21 PM
  14. RapidTurtle's Avatar
    Yeah, at&t kinda sucks that way. I returned the pone and went back to my S9 plus. I'll wait until they get their network straightened out before upgrading.
    I did really like the s20 though. Very nice phone.
    08-28-2020 05:48 PM
  15. cnotes2019's Avatar
    Yeah, at&t kinda sucks that way. I returned the pone and went back to my S9 plus. I'll wait until they get their network straightened out before upgrading.
    I did really like the s20 though. Very nice phone.
    I had the s20+ 5g and am having the same issue I’m having on my note 20 ultra. I’m in LOS of 5g+ sites and the phones display it but they will never connect to them per speed tests displaying lte. Only reason I’m keeping this phone (besides the hope AT&T will get better 5g coverage in due time) is because of the great trade in deal. I’ve escalated the issue etc to the Office of the President and now to advanced tech support. The rep said she will call me tomorrow when I’ll be at one of those sites to see what’s going on but it’ll be really something if this happens also on the Fold 2 and iPhone 12 .... I have options with all three carriers just in case they’re better on there.
    08-31-2020 09:05 PM
  16. Bee1To's Avatar
    I also have the s20 5g SD, and connection speed is slow, very slow especially with 5g. I don't understand, s20 got the latest SnapDragon, 16gb of ram, More than my laptop, and 5g,,,this thing should fly... and I am in Los Angeles.
    08-31-2020 09:20 PM
  17. cnotes2019's Avatar
    I also have the s20 5g SD, and connection speed is slow, very slow especially with 5g. I don't understand, s20 got the latest SnapDragon, 16gb of ram, More than my laptop, and 5g,,,this thing should fly... and I am in Los Angeles.
    On AT&T and in areas with 5g+?
    08-31-2020 09:22 PM
  18. VidJunky's Avatar
    I see I'm late to the party but I'm wondering if RapidTurtle had 5G or 5GE? I'm not sure if they're doing this on the actual 5G phones but I was just reading an post about an S10 on AT&T showing 5G and it turned out that AT&T is rebranding their 4G LTE to this 5GE. To kind of verify this story I went online and found this article that talks about it... https://www.google.com/url?sa=t&rct=...qsFbPcM-zGCLp8

    I could very easily see where something like this could might get past someone, especially if they have a 5G device and didn't know about this little trick AT&T was using.
    J Dubbs likes this.
    09-01-2020 01:59 AM
  19. J Dubbs's Avatar
    Yeah, at&t kinda sucks that way. I returned the pone and went back to my S9 plus. I'll wait until they get their network straightened out before upgrading.
    I did really like the s20 though. Very nice phone.
    AT&T sucks in general anymore. They're the only carrier we've ever used in over 25 years of cell phone usage. In the beginning they were great.....great service, great reception, good phones at good prices. Then Cingular bought them out and it all started to unravel. So Cingular thought "let's change the name back to AT&T, everybody loved AT&T" but putting lipstick on a pig doesn't fix the problem. They have gradually gotten so bad that we barely have service at our house of 20 years that used to have great service.

    Plus they like to lie alot about their coverage and data speeds, and try and force you to buy their overpriced network locked phones by refusing to fully support unlocked phones.

    We'll be leaving them soon ;-)
    09-01-2020 07:42 AM
  20. J Dubbs's Avatar
    I see I'm late to the party but I'm wondering if RapidTurtle had 5G or 5GE? I'm not sure if they're doing this on the actual 5G phones but I was just reading an post about an S10 on AT&T showing 5G and it turned out that AT&T is rebranding their 4G LTE to this 5GE. To kind of verify this story I went online and found this article that talks about it... https://www.google.com/url?sa=t&rct=...qsFbPcM-zGCLp8

    I could very easily see where something like this could might get past someone, especially if they have a 5G device and didn't know about this little trick AT&T was using.
    That's not a little trick it's an outright anti- consumer lie.... and something that should be legally addressed.
    09-01-2020 07:49 AM
  21. joeldf's Avatar
    That's not a little trick it's an outright anti- consumer lie.... and something that should be legally addressed.
    Well... kinda...

    It was the National Advertising Review Board that has forced AT&T to stop advertising "5G-Evolution", or specifically marketing it.

    It hasn't stopped them from still showing the " 5G-E" network icon, however.

    While still technically LTE, it is a different variation using 4x4 MIMO and 256 QAM on those bands. It is supposed to be faster LTE, but in my town, when I see my S9 show 5G-E, a barely get faster speeds than I get when connected to a straight 4G-LTE tower, most of the time it's slower.

    I've had speeds up to 160 Mbps on 4G-LTE - but, only in certain parts of town (where my house was in particular, until I moved a year and a half ago). I've yet to see speeds more than 40 Mbps on 5G-E.
    09-01-2020 06:40 PM
  22. RapidTurtle's Avatar
    I see I'm late to the party but I'm wondering if RapidTurtle had 5G or 5GE? I'm not sure if they're doing this on the actual 5G phones but I was just reading an post about an S10 on AT&T showing 5G and it turned out that AT&T is rebranding their 4G LTE to this 5GE. To kind of verify this story I went online and found this article that talks about it... https://www.google.com/url?sa=t&rct=...qsFbPcM-zGCLp8

    I could very easily see where something like this could might get past someone, especially if they have a 5G device and didn't know about this little trick AT&T was using.
    I'm quite sure it was regular 5G, but can't be completely sure. It was also in areas that were 50 miles apart. The phone was pretty much always showing 5G. On my way to work, I use my phone on android auto for radio, and the S20 would cut out several times, where my S9+ never does. I loved the S20, but can't stand connection issues. It's one of the reasons that I pay a premium for AT&T. Verizon, Sprint, and Tmobile are all terrible at my work place, and AT&T has always been awesome there.

    Those of you who are having problems also, please keep this thread updated. I really liked the phone, but if I were to get another, I'd probably go with the plus model, but obviously not with the connection issues.
    09-04-2020 10:24 PM
  23. DrComputer's Avatar
    I live in Los Angeles and have had my AT&T S20+ since it was released back in March. It was working great until about a month ago when it got the July update and now it is horrible on the cell network. Los Angeles is a "5G" region and the phone always shows 5G but most of the time now it will show full bars and have no data service. If I turn on and off airplane mode it will sometimes work great for a few minutes and then revert back to very poor cell data service. Luckily during this pandemic, I've been working from home most often and when the phone is on wifi it works fine. I really hope AT&T fixes their problem as they did something on their network over the past two months to make a really good phone work horribly. I guess I'll call support and complain (expecting them to do nothing) but at least it will be another logged complaint about data service with the S20+ on their network.
    09-07-2020 08:41 PM
  24. RapidTurtle's Avatar
    Hopefully it's just them working on the network. I feel your pain with calling them. The phone I returned still shows I owe on it, so I have called and chatted a few times, being assured each time that within 24 hrs, it will be fixed. It's still not fixed.
    09-08-2020 06:07 PM
  25. RapidTurtle's Avatar
    09-09-2020 08:14 AM

Similar Threads

  1. Already having issues with 5G
    By HungryHOBO in forum Samsung Galaxy Note 20 & Note 20 Ultra
    Replies: 13
    Last Post: 08-21-2020, 09:49 AM
  2. 2 Questions about Sound
    By HnLA in forum Samsung Galaxy S10 & S10+
    Replies: 4
    Last Post: 08-20-2020, 03:46 PM
  3. Replies: 2
    Last Post: 08-18-2020, 08:22 PM
  4. Got the OtterBox Defender Pro, questions welcomed!
    By Bike Mi Vie in forum Samsung Galaxy Note 20 & Note 20 Ultra
    Replies: 8
    Last Post: 08-18-2020, 02:43 AM
  5. Icon question
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2020, 10:24 PM
LINK TO POST COPIED TO CLIPBOARD