Save big + get 3 months free! Sign up for ExpressVPN today

03-31-2020 07:50 PM
41 12
tools
  1. TimmE's Avatar
    Waze can't get a GPS position. Location services are on and other apps such as Google Maps are working normally. I did a search and saw others are having the same issue. Does anyone know of a fix for this?
    03-12-2020 08:15 PM
  2. mlblack16's Avatar
    Waze can't get a GPS position. Location services are on and other apps such as Google Maps are working normally. I did a search and saw others are having the same issue. Does anyone know of a fix for this?
    No, but glad you brought this up. It's something Waze is going to have to address. It's my go-to app for navigation, so hopefully they will look into it, but if it's only affecting Ultra users (or even S20 users) it may take awhile for them to notice.

    I left a review stating the issue. Also, when you look at reviews and select "this device only" you will see the same complaints.
    03-13-2020 04:43 AM
  3. daswooski's Avatar
    No, but glad you brought this up. It's something Waze is going to have to address. It's my go-to app for navigation, so hopefully they will look into it, but if it's only affecting Ultra users (or even S20 users) it may take awhile for them to notice.

    I left a review stating the issue. Also, when you look at reviews and select "this device only" you will see the same complaints.
    Ahhh, thought it was just me..glad to hear it was not, ill send a note into Waze too as I love that App
    03-13-2020 06:17 AM
  4. dgcorn's Avatar
    Me too. It eventually works, but not a quickly as it should.
    Monee_121 and big samm like this.
    03-13-2020 08:06 AM
  5. mlblack16's Avatar
    Me too. It eventually works, but not a quickly as it should.
    Or kicks in quicker after a reboot, which is very inconvenient. I also think when switching off WiFi it seems to struggle worse with getting a GPS lock.
    03-13-2020 08:19 AM
  6. Kee5892's Avatar
    I have the same problem on my Samsung A10.
    Waze seems broken.
    03-13-2020 08:22 AM
  7. wrich2005's Avatar


    check that out on regular Google maps. That was the second day I had the phone
    03-13-2020 08:25 AM
  8. dgcorn's Avatar
    Some one on google play mentioned it happened to them right after a software update, so maybe it's not isolated to the S20s.
    03-13-2020 08:34 AM
  9. TimmE's Avatar
    Apparently if you torn off 5g or voice over lte Waze works. Very annoying. I hope they fix it soon.
    03-14-2020 12:30 AM
  10. jlangner's Avatar
    Same, swapped to Maps for now.
    03-14-2020 01:57 PM
  11. lcs101's Avatar
    Waze often tells me it can't find the network on my Note 10. Problematic server?
    03-14-2020 07:27 PM
  12. DUTCH VanAtlanta's Avatar
    Looks like this problem is getting a little more notoriety. Hopefully, Sammy will notice.

    https://www.androidcentral.com/some-...-maps-and-waze

    I just cancelled a S20 Ultra 512GB version due to this and the all too well known camera issues. I'm not willing to pay $1700 for a phone with this many problems. Hopefully, with time, they'll be fixed; and then I will reconsider an order.
    03-18-2020 09:08 AM
  13. Mike Dee's Avatar
    No problems using Waze on my Ultra
    03-18-2020 09:43 AM
  14. Super Spartan's Avatar
    I read that the GPS issue is isolated to Snapdragon CPUs not the Exynos variants.
    03-18-2020 09:44 AM
  15. Mike Dee's Avatar
    I read that the GPS issue is isolated to Snapdragon CPUs not the Exynos variants.
    I'm on the Snapdragon so I wonder what actually causes it
    03-18-2020 09:49 AM
  16. mlblack16's Avatar
    I'm on the Snapdragon so I wonder what actually causes it
    Same, but the issue is with Waze, not Google Maps/Navigation. At least not that I've noticed.
    03-18-2020 11:10 AM
  17. nuangel2's Avatar
    no problem on my ultra with waze
    03-18-2020 12:39 PM
  18. bhatech's Avatar
    I don't have any issues with Waze and Google maps on us unlocked Ultra which is the Snapdragon version.
    03-18-2020 12:45 PM
  19. Mike Dee's Avatar
    Same, but the issue is with Waze, not Google Maps/Navigation. At least not that I've noticed.
    Right....and I said previously, no issues running Waze
    03-18-2020 02:05 PM
  20. mlblack16's Avatar
    Right....and I said previously, no issues running Waze
    Didn't mean to quote you. This sh!tty app only lets me respond in a thread if I reply to a post vs using the quick reply box at the bottom.
    03-18-2020 04:48 PM
  21. _YoKolorMeBadd's Avatar
    No, but glad you brought this up. It's something Waze is going to have to address. It's my go-to app for navigation, so hopefully they will look into it, but if it's only affecting Ultra users (or even S20 users) it may take awhile for them to notice.

    I left a review stating the issue. Also, when you look at reviews and select "this device only" you will see the same complaints.
    I was having the same issue with my S10+. GPS won't pick up at all.
    03-19-2020 05:58 PM
  22. Monee_121's Avatar
    Finally I'm not the only one. I've had this issue where it lags before showing my current location. I emailed tech support and they told me to try a GPS test app and make sure location permission was granted. All of my GPS services are fine with every app except Waze. I emailed them back and said there is an apparent bug and they might want to address it.
    03-20-2020 10:46 AM
  23. daswooski's Avatar
    So what is the path forward here?
    Are we waiting for Waze to update their software or Samsung?
    03-20-2020 10:59 AM
  24. Mike Dee's Avatar
    So what is the path forward here?
    Are we waiting for Waze to update their software or Samsung?
    [IMG=1080x2400]https://uploads.tapatalk-cdn.com/20200320/6377ce778489ac967dc73698b60541fc.jpg[/url]
    That would depend on what the problem is. I'm puzzled why only some are seeing it. I keep checking mine but I get a signal every time.
    03-20-2020 11:51 AM
  25. mlblack16's Avatar
    Finally I'm not the only one. I've had this issue where it lags before showing my current location. I emailed tech support and they told me to try a GPS test app and make sure location permission was granted. All of my GPS services are fine with every app except Waze. I emailed them back and said there is an apparent bug and they might want to address it.
    Just checked using a GPS tracking app. Keep in mind, this was measured indoors and is currently very cloudy/rainy weather.
    Attached Thumbnails WAZE and GPS issues.-3279.jpg  
    03-20-2020 12:18 PM
41 12

Similar Threads

  1. Replies: 35
    Last Post: 03-13-2020, 03:21 PM
  2. Replies: 4
    Last Post: 03-12-2020, 06:23 PM
  3. Replies: 1
    Last Post: 03-12-2020, 05:47 PM
  4. G2 and Assistant
    By lan4 in forum LG G2
    Replies: 3
    Last Post: 03-12-2020, 03:53 PM
  5. Compared 15, 25 and 45W chargers with the S20 Plus
    By Snareman in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 2
    Last Post: 03-12-2020, 03:39 AM
LINK TO POST COPIED TO CLIPBOARD