1. andrew4576's Avatar
    On July 1st my S22 received an update. 10-15 minutes after every restart the S22 works fine. After that I lose signal completely (circle with line instead of bars).

    I put my Tello SIM into a note 8, no issues for the hours I left it there. I can use LTE just fine.
    But returning the SIM to my S22, rebooting, and waiting 10 minutes; no signal again. I played with my Network Mode settings as the note 8 isn't 5G and was curious if that might be involved. Randomly my signal (and ability to text/call) returns if I set Network Mode to either 3G/2G (auto connect) OR 3G only OR 2G only.

    This is some advanced shenanigans. In all my years with Samsung and Android, I've never had an update prevent normal operation of a phone. Hope this can help someone else, if they have the same issue.
    07-02-2022 02:39 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did you already try the Reset Network Settings option?
    Laura Knotek likes this.
    07-02-2022 08:34 AM
  3. andrew4576's Avatar
    Thank you for trying to help!

    I just did. I reset Network settings, Network mode remained at 3G/2G so I manually switched it to5G/LTE/3G/2G, lastly I had to reconnect to my Wi-Fi as that was reset. However, 12 minutes later I lost signal and returning to 3G/2G (auto connect) restored my signal again.

    Everything was fine before that update. I bought a S22 directly from Samsung and tossed a Tello SIM in it. Earlier on July 1st I received an email stating that the T-Mobile 3G service was being taken down in the near future. Tello is a MVNO on T-Mobile's network. I don't know if that is related to the update and subsequent issue or not.
    07-02-2022 10:03 AM
  4. B. Diddy's Avatar
    Check your APN settings -- do they match this? https://bestmvno.com/apn-settings/tello-apn-settings/
    Laura Knotek likes this.
    07-02-2022 10:07 AM
  5. andrew4576's Avatar
    They are only slightly off. The defaults have an MNC of 240 instead of 260 and protocols are IPv4/6 instead of just 4.

    Unfortunately if I make a custom APN with any of the 4 settings from that link, it just deletes itself. I can make and save APNs with just random stuff in it. However, if I touch the MNC it vanishes on save. Resetting my APNs to default to see if it would help did not.
    07-02-2022 10:42 AM
  6. andrew4576's Avatar
    Randomly, data works fine. I can browse the internet on 5G. I can make outbound phone calls (it is silent for a while, then my 5G is replaced by a 3G and the circle with a line returns to bars). However, texting and inbound phone calls don't work unless I set my network mode to 3G.
    07-02-2022 10:55 AM
  7. B. Diddy's Avatar
    It doesn't allow you to edit and save the existing APNs?
    07-02-2022 11:08 AM
  8. mustang7757's Avatar
    In the upper right corner on APN page should be 3 dots tap it and choose reset to default S22 only works in 3G/2G mode.-screenshot_20220702-121638_settings.jpg
    Laura Knotek likes this.
    07-02-2022 11:17 AM
  9. Laura Knotek's Avatar
    Have you contacted your carrier? What time of day are these connectivity issues occurring? It is possible that regular T-Mobile customers are prioritised during times of heavy usage, resulting in issues for customers using MVNOs.
    mustang7757 likes this.
    07-02-2022 12:33 PM
  10. andrew4576's Avatar
    -B. Diddy: It doesn't allow me to edit my existing APN (I can open it and view the settings, but they are greyed out). If I create a new one and save it, I can open it and edit it at will. However, it disappears if I mess with MNC at all.

    -mustang7757: I reset to default after I was unable to edit my APN. That didn't solve my issue unfortunately.

    -Laura Knotek: I have yet to contact the carrier. It has been constant since the update yesterday, even until the early AMs. However, I have no such issue with the SIM if I put it in other phones. Not to mention, internet works. Just not texts or inbound calls. Since there are no issues with my other 2 phones, it has to be the S22 itself. I doubt it is an issue on the MVNOs end, but anything is possible.

    Thank you everyone!
    mustang7757 and Laura Knotek like this.
    07-02-2022 01:14 PM
  11. mustang7757's Avatar
    -B. Diddy: It doesn't allow me to edit my existing APN (I can open it and view the settings, but they are greyed out). If I create a new one and save it, I can open it and edit it at will. However, it disappears if I mess with MNC at all.

    -mustang7757: I reset to default after I was unable to edit my APN. That didn't solve my issue unfortunately.

    -Laura Knotek: I have yet to contact the carrier. It has been constant since the update yesterday, even until the early AMs. However, I have no such issue with the SIM if I put it in other phones. Not to mention, internet works. Just not texts or inbound calls. Since there are no issues with my other 2 phones, it has to be the S22 itself. I doubt it is an issue on the MVNOs end, but anything is possible.

    Thank you everyone!
    Double check your sim card is set in properly has to be flush with tray , this not dual sim correct?

    If you can show screenshot of your APN page like my screenshot and go to settings>connection>sim card manager and show us there but block your phone number
    07-02-2022 01:20 PM
  12. andrew4576's Avatar
    My phone is a single SIM phone and I reinstalled it again to be safe. Here are the screenshots.
    Attached Thumbnails S22 only works in 3G/2G mode.-screenshot_20220702-132534_settings.jpg   S22 only works in 3G/2G mode.-screenshot_20220702-132551_call-settings-2.jpg  
    07-02-2022 01:30 PM
  13. mustang7757's Avatar
    Thank you , so lte no problem just 5g?
    07-02-2022 01:46 PM
  14. andrew4576's Avatar
    Both LTE and 5G only allow me to use data. For calls/texting I have to set my Network Mode to 3G or 2G.
    Attached Thumbnails S22 only works in 3G/2G mode.-screenshot_20220702-135228_call-settings_2.jpg  
    07-02-2022 01:56 PM
  15. mustang7757's Avatar
    Both LTE and 5G only allow me to use data. For calls/texting I have to set my Network Mode to 3G or 2G.
    Does your carrier have a store to stop in ? Probably needs correct APN
    Laura Knotek likes this.
    07-02-2022 01:58 PM
  16. mustang7757's Avatar
    I know you say that it works on your previous phone but that used lte/3g/2g where as the newer one uses all them including 5g
    Laura Knotek likes this.
    07-02-2022 01:59 PM
  17. andrew4576's Avatar
    They are online only. However, I will place the SIM in another 5G phone tomorrow. If it works fine, I'll compare the APN settings. Considering that LTE doesn't work on the S22, but does on my Note 8 and Note 5, then the update could've just bugged the APN settings. If that is the case, I can always try a factory reset.
    07-02-2022 02:06 PM
  18. andrew4576's Avatar
    Yeah, no issues with LTE when I drop the SIM elsewhere. LTE is bugged on the S22 and fine on Note 8/5. The fact it was an issue right after booting back up from an update points to a software problem on the S22 itself.
    07-02-2022 02:09 PM
  19. mustang7757's Avatar
    They are online only. However, I will place the SIM in another 5G phone tomorrow. If it works fine, I'll compare the APN settings. Considering that LTE doesn't work on the S22, but does on my Note 8 and Note 5, then the update could've just bugged the APN settings. If that is the case, I can always try a factory reset.
    Definitely let us know
    07-02-2022 05:22 PM
  20. holz75's Avatar
    Just a shot in the dark here, but would a new SIM card change anything?
    Laura Knotek and nuangel2 like this.
    07-02-2022 08:43 PM
  21. andrew4576's Avatar
    Well, I put the SIM card in my friends 5G phone yesterday, it worked just fine. In the end I resorted to a factory reset. That fixed the issue. The APN settings looked exactly the same. The android update that installed on July 1st bugged something in the software. Not sure what, but at least it isn't a hardware issue.
    07-04-2022 10:47 AM
  22. mustang7757's Avatar
    Well, I put the SIM card in my friends 5G phone yesterday, it worked just fine. In the end I resorted to a factory reset. That fixed the issue. The APN settings looked exactly the same. The android update that installed on July 1st bugged something in the software. Not sure what, but at least it isn't a hardware issue.
    Glad to hear everything is good!
    Laura Knotek likes this.
    07-04-2022 11:36 AM

Similar Threads

  1. S22 does not check for software updates automatically
    By Simon6785789 in forum Samsung Galaxy S22 & S22+ & S22 Ultra
    Replies: 7
    Last Post: 07-03-2022, 07:22 AM
  2. Replies: 2
    Last Post: 07-02-2022, 11:26 AM
  3. S22 does not check for software updates automatically
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 07-01-2022, 02:16 PM
  4. Why is my speaker is not working and now also my buletooth is also not working
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-01-2022, 01:29 PM
  5. Vibration on phone stops working at random
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 07-01-2022, 05:10 AM
LINK TO POST COPIED TO CLIPBOARD