1. Matzel_27's Avatar
    I have a serious problem with my Samsung Galaxy S3. I can't update some of my existing apps or download new (some) new apps. Plenty of storage available as far as I can tell, but I get an 'Insufficient internal memory' message. I am not exactly a techie but I emptied (app) cache (1 tap cleaner) and uninstalled a few seldomly used apps to free up space. No luck. :-(

    This is a 2 month old work phone, so rooting is out of the question. That said, frustration is great.
    This seems to be a wide spread problem across multiple versions of Android OS. Any and all help would be appreciated.
    01-18-2013 08:09 PM
  2. mhinc's Avatar
    Not sure what to tell you at this point, it would appear you have plenty of internal room to update and install new apps. Since it's a work phone, what about warranty? Only 2 months old can you get a spare and have them ship to Samsung for RMA?
    01-19-2013 06:27 AM
  3. Matzel_27's Avatar
    That'll be my next step.
    I was really hoping to be able to get past this issue somehow, but there seems to be no easy fix for this.

    What worries me is the fact that this is not an isolated case by the looks of it. I love my SGS3 for many reasons, but I am not on for a repeat of this crap...
    01-23-2013 08:53 PM
  4. Matzel_27's Avatar
    After visiting my local Telus dealer, following the CSR's advice, I have just performed a hard reset. I backed up contacts and email account info. Everything else was installed from scratch... So far, so good. As long as you do not see another update, the solutions worked.

    Shannon Vary likes this.
    01-24-2013 11:34 PM
  5. mhinc's Avatar
    After visiting my local Telus dealer, following the CSR's advice, I have just performed a hard reset. I backed up contacts and email account info. Everything else was installed from scratch... So far, so good. As long as you do not see another update, the solutions worked.

    I just came on to suggest you do that. Ha ha glad it's working, let us know if it happens again.
    01-25-2013 06:41 AM
  6. Matzel_27's Avatar
    You betcha.

    01-26-2013 06:07 PM
  7. JoJoJo_Alan's Avatar
    this has happened to me a second time now and i'm getting increasingly frustrated seeing as this is my second handset, the first one died completely another S3 fault!, last time i did a factory reset but i don't want to do it yet again, any suggestions?!
    03-12-2013 05:26 PM
  8. Matzel_27's Avatar
    <Knocking on wood> ... my S3 is still working fine with no further problems.

    I know a hard reset is quite a bit of work, but I have to admit that the phone is set up better this time around because I took the opportunity to switch some things around.
    03-29-2013 06:37 PM
  9. JonsoNuts's Avatar
    I too received the Insufficient Memory. I looked at my device storage and it shows that the 'Miscellaneous Files' are the culprit. It takes up 8.19Gb. My available device space is 609MB. My SD Card Memory shows 10.01GB of Available Space. 14.62GB Total Space. How do I make my device memory "not so full"? I've had my s3 since December if that even helps out a little.
    04-27-2013 02:32 AM
  10. likearvie's Avatar
    my samsung galaxy s3 mini have 16GB , but when i transfer files to my phone, and plug in to the computer, in only shows 17.8MB
    i thought its 16GB , i cant use my internal memory, thats why i buyed an sd card. 8Gb.
    now im using SDcard 8GB , but i want to use my 16 GB internal memory.

    can someone help me? Thanks ..
    stephen takyi likes this.
    07-04-2013 11:00 PM
  11. Maria Sussette del Campo's Avatar
    i have the same problem. so sad.. i cant fix it. guys please help. i cant attach photos and cant open my music player. i've checked the downloaded files, ive deleted everything but its still the same.
    07-05-2013 01:41 AM
  12. Maria Sussette del Campo's Avatar
    Fixed already.. yeay..
    07-15-2013 02:05 AM
  13. wamilo's Avatar
    how did you fix that problem? please share. I have the same problem
    07-20-2013 02:44 AM
  14. scynz1's Avatar
    My SGS3 was plagued with this problem for months but I have finally found the answer on another forum. Basically it's a huge log file which keeps building up. The fix is incredibly simple after all that frustrating searching

    "You don't have to root your phones to fix this problem. Just dial *#9900# on the phone and then select from menu - delete dumpstate/logcat. I tested this solution on my SGS2 and it works. "
    Credit to damianoz here
    01-03-2014 05:03 PM
  15. Aliboywp's Avatar
    Your post just made my life easier. I have 570MB with almost nothing on my phone, I deleted almost everything. After dialing that code I now have just under 4GB
    11-05-2014 06:07 PM
  16. Marc van der Linden's Avatar
    This solution did not work for me on my S3 mini I even rebooted my S3 mini. But still, after complete download, it wants to begin the install, and than stops with "Error: out of space"
    04-23-2015 02:02 PM
  17. Kamena's Avatar
    It has worked on my S3 Mini. Thanks a million times.
    08-14-2015 09:08 AM
  18. P Droiddily's Avatar
    i am having this problem also

    i wanted to download whatsapp plus app for my sgs3 mini - so i downloaded the apk from off market site and lowwed the intsructions given which were:

    back up conversation and uninstall whatsapp - which i did - then when i go to install the whatsapp plus apk from my downloads it says:

    out of space ?? i have a 32gb sd card with 25gb free - and internal storage is absolutely fine too - with over 2gb free

    ive downloaded the "one click cache cleaner app as suggested above (strangely this installed with no problems?) i used this to clear all my cache and tried to install whatsapp plus again - same message - out of space

    i then tried to download and install the original whatsapp - again same message - out of space

    ive also tried to delete the "dumpstate/logcat" usuing the method above - again no joy - out of space

    ive rebooted several yimes also - nothing is working?

    please help
    09-13-2015 01:02 PM

Similar Threads

  1. Galaxy 4G - Internal memory full
    By vishal1857 in forum T-Mobile Galaxy S 4G
    Replies: 4
    Last Post: 12-29-2012, 03:03 AM
  2. Galaxy s3 internal memory please help
    By Jukka in forum Samsung Galaxy S3
    Replies: 7
    Last Post: 11-22-2012, 09:38 AM
  3. Ota update error on international galaxy s3
    By surender_jhakra9999 in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 08-19-2012, 02:55 PM
  4. Galaxy s3 all internal storage prices
    By assasinezio4 in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 05-06-2012, 06:56 PM
  5. Insufficient memory error - when there's plenty of memory!
    By Rudiepoo1 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 09-14-2011, 04:51 AM