1. promart611's Avatar
    Someone in the Verizon forum posted this "solution" to many people's similar problem:

    Make sure the Samsung drivers are installed. Power off your phone. Power on the phone in Download mode. (Volume Down + Home + Power) Press Volume Up to continue. Once it's in Download mode, plug it into your computer. Windows should now discover it and load the driver. Once this is complete, unplug the phone from the computer, and pull the battery out of the phone to get out of Download mode. Replace the battery, and power on the phone like normal. It should connect to the computer properly.
    Thanks for the tip, but mine is stuck now in Downloading Android screen.... I'm connecting my S3 to a MacbookPro running OS 10.6.8 and the USB/Kies Wifi connection used to just fine (well, almost) until the latest Samsung firmware update, whatever version that was. Also Kies is updated to the latest version, but obviously it doesn't help either....

    Is it only me or other people find that having to use pseudo hacks into what should work by itself are normal for an OS that's supposed to beat Apple's iOS?
    I switched to GS3 from the iPhone for ease of use and what do I get? Updates and firmwares that screw up the phone? Looks like Apple all over again.

    Shame on you Samsung and Google!
    eaBatzer likes this.
    07-13-2013 04:26 PM
  2. mrbowlman's Avatar
    I can only say that what was quoted above worked for me with a Verizon S3 on Windows 7 with a USB connection. I don't know the root cause of the issue, nor where the issue itself actually lies, so I don't know if this "fix" is even applicable to a different carrier S3 or OSX. I've never installed/used Kies for anything. On my laptop with Linux Mint, I've never installed any driver, and have never had an issue with it recognizing my phone, even when my desktop wouldn't.

    From what I understand, the only way out of Download Mode is to pull the battery unless you're using Odin to flash something, which can issue a reboot command. While in Download mode, the phone won't show up on the computer like it normally would. (you won't see the internal storage or SD card, I don't know if that's what you were expecting) In Windows 7 it shows the "Installing Driver" pop up, and after it says "Successful," you unplug the phone and pull the battery. After restarting the phone, it shows up properly for me. But like I said, I don't know if any of this is applicable to OSX.
    07-16-2013 03:09 PM
  3. eaBatzer's Avatar
    I'm having the same problem (Windows 7 laptop won't recognize phone). I thought was because I tried to install the latest driver so I could run App Inventor but after reading these threads, I realize that I ran the Samsung update since last attempting to connect via USB.

    So after attempting mrbowlman's solution, which sounded so promising, my S3 is in download mode for the past 10 minutes. How long should I leave it? Will it brick it if I pull out the battery? There is nothing popping up on the laptop so I don't think this is the fix.

    BTW I'm not complaining about the proposed solution, just nervous about getting the phone back to it's (almost) working state.
    07-18-2013 08:08 PM

Similar Threads

  1. Replies: 10
    Last Post: 07-18-2013, 09:32 PM
  2. Can't text after upgrade.
    By 420benz in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 07-14-2013, 12:14 AM
  3. How to update my xperia p to jellybean??
    By Red_Berry_21 in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 07-13-2013, 04:29 PM
  4. No Sound from Phone Call using Ibolt for Note 2
    By dave_w_h in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 07-13-2013, 04:11 PM
  5. delete pix after ota update
    By joemontana57 in forum Verizon Samsung Galaxy S4
    Replies: 1
    Last Post: 07-13-2013, 03:53 PM