1. GUay JEal's Avatar
    HEllo sir../ma'am
    I have a problem with my galaxy s3 mini. it does not launch.If I turns it on,it jst produce light and continues too.how can i fix it sir? pls. i need this phone its something memorAble.
    06-12-2014 01:48 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! How long have you had it? Did you get it brand new, or was it used? Is it rooted? Has there been any recent trauma--did you drop it or anything? Any water damage?

    Try booting into the Recovery Mode and see if you can Wipe Cache Partition: http://forums.androidcentral.com/sam...2-s3-tab2.html
    Golfdriver97 likes this.
    06-12-2014 02:14 AM
  3. GUay JEal's Avatar
    Sir,it is brand new this was the first time because whenever I turn it on it just light up but I don't have the tools for professional rebooting .is it for home?
    06-12-2014 02:26 AM
  4. GUay JEal's Avatar
    I just tried to install an application but it kept still untill I turned it of but when i power it on,there it just lighted up.hoping for your answer sir.please
    06-12-2014 02:29 AM
  5. B. Diddy's Avatar
    If it's brand new, then I suggest you return it for an exchange or refund. Don't waste too much time trying to fix it, because if you wait too long, you may lose the opportunity to return it.

    You don't need tools for professional rebooting. Just follow the steps in the link if you want to try booting into Recovery.
    Golfdriver97 and dpham00 like this.
    06-12-2014 02:29 AM
  6. dpham00's Avatar
    If clearing cache doesn't work, try a factory data reset as well before returning.

    dpham00, Android Central Moderator
    Sent from my Verizon Samsung Galaxy Note 3
    Golfdriver97 likes this.
    06-12-2014 07:47 AM
  7. GSDer's Avatar
    it does not launch.If I turns it on,it jst produce light
    Can you post a screenshot or a picture of what it is doing? I'm having a tough time figuring out exactly what the problem is.

    Perhaps if you took the battery out for a couple of minutes and then reinserted it and tried to turn it on?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    06-12-2014 02:15 PM

Similar Threads

  1. Galaxy S4 incoming call issue + international error
    By joleesays in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 05-16-2016, 07:02 AM
  2. Rumor: Samsung Galaxy Note 4 with Sony 16MP OIS Camera
    By Omer San Gabriel in forum Rumored Devices Lounge
    Replies: 4
    Last Post: 06-20-2014, 02:39 PM
  3. Galaxy S5 Active Caught On Ebay
    By JSG59 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-11-2014, 11:43 PM
  4. samsung galaxy s4 active front camera failing
    By androiduser1910 in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 06-11-2014, 09:21 PM
  5. Replies: 1
    Last Post: 06-11-2014, 05:01 PM
LINK TO POST COPIED TO CLIPBOARD