1. takarob's Avatar
    Hello and thanks in advance. This is my first post. I am hoping this is the right thread

    I have a samsung gt-s5570 (galaxy mini I guess...) stuck in a bootloop (or so I believe). I have looked everywhere on the web for a soft or hard factory reset (and I did find the info) but nothing works.

    Soft reset:
    Press and hold Volume Up and Power Button for 5 secs....etc

    Hard reset:
    Turn on your Galaxy Mini on recovery mode: Power + Home ... etc.

    What should I do?

    Tm baxsadegh likes this.
    07-22-2014 03:02 AM
  2. GSDer's Avatar
    Hello and welcome to the forums!

    Can we first establish the correct key sequences for Recovery mode and Download mode (which you may need to try)?

    - you use Recovery mode to clear the system cache and to Factory Reset
    - you use Download (aka Odin) mode (showing the Android guy) to load/reload firmware
    - the key sequences to enter both modes are very similar, and they are timing dependent so it may take a few tries to get it working
    -- Recovery = Volume Up + Home + Power
    -- Download = Volume Down + Home + Power
    - for either, you start with the phone completely off
    - press and hold the required keys simultaneously, and release them all when you see the desired screen

    Try Recovery mode first (use the Volume rockers to navigate; use the Power button to select) and if it boots into this mode just clear the cache and then restart. If the phone won't boot into Recovery mode (which happens sometimes) then try Download mode. Let us know what happens.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-23-2014 12:05 AM
  3. takarob's Avatar
    Thanks !!!

    I have decided to go use the Download (aka Odin) mode (showing the Android guy) to load/reload firmware. I am getting the phone to show the Android guy (says "downloading") it;s been about 20 minutes but nothign happens.

    No SIM card is in. What should I do?

    Thanks again for your time. Much appreciated it
    07-23-2014 01:35 AM
  4. GSDer's Avatar
    When the phone is in Download mode it's just sitting there waiting for you to download something to it - it'll sit there until the battery dies; until you pull the battery; or until you press-and-hold the Power button for about ten seconds.

    I suggested that you try booting into Recovery mode and clearing the system cache - did you do that?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-23-2014 01:02 PM
  5. takarob's Avatar
    Thanks for your message. Well, I have tried both revery systems now and none of them worked.

    -- Download = Volume Down + Home + Power
    Just stays in download mode until the battery dies

    -- Recovery = Volume Up + Home + Power
    Nothing happens - still stuck in bootloop.

    What to do???
    07-24-2014 05:35 AM
  6. GSDer's Avatar
    I was going to suggest using Odin to reload the stock firmware, but all of the firmware that I've found is really old (2.3.6 or something like that). Do you remember what firmware version you had installed?

    You could try using the Kies software to reload the firmware. Here's an overview:

    - if you don't already have the Kies software installed on your PC, download it (just search Google) and install it. The first time it runs it'll update itself to the latest version so make sure you run it once before proceeding.
    - put your phone in Download mode: with the phone completely off, press and hold the Volume Down and Home and Power buttons simultaneously, and release them all when you see the Samsung splash screen
    - connect the phone to your PC with the USB cable that came with the phone
    -- if you've never had the phone connected to your Windows-based computer before, you'll see messages about installing drivers, etc - just wait until this is done (may take 5 or 10 minutes) [I don't know what happens if you have a Mac - it probably just works]
    - in the Kies software, select the second item in the Tools menu and just follow the prompts to enter the model number (in CAPS) and IMEI/Serial Number (both found under the battery - it's ok to remove the battery at this point)
    - the Kies software should start downloading the correct firmware for your phone from the Internet; once that's done (depending on your Internet connection speed) it'll begin downloading that to the phone (this probably takes 10 minutes or so)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-24-2014 01:08 PM
  7. Andrew D246's Avatar
    this solution worked perfectly.
    08-07-2016 04:22 PM
  8. Naman Gupta4's Avatar
    cannot be initialised
    11-14-2017 06:53 AM

Similar Threads

  1. Replies: 1
    Last Post: 03-03-2015, 11:24 PM
  2. Replies: 5
    Last Post: 09-18-2014, 01:10 AM
  3. Replies: 5
    Last Post: 08-13-2014, 06:29 PM
  4. Samsung Galaxy S5
    By Atown Her in forum Ask a Question
    Replies: 1
    Last Post: 07-22-2014, 02:45 AM
  5. Replies: 1
    Last Post: 07-22-2014, 02:27 AM