1. Luminio's Avatar
    Hello everyone.

    My phone has been doing this thing for the past 3-4 months. I changed the battery. I even tried another ROM.
    The problem is, my phone is charging properly, there is no battery drain etc. But the battery status icon won't show it.
    When i charge it fully, it stays on 100% and i can't see it going down unless i restart the phone. Then when it's at around 6% battery i start charging it again. Battery status icon doesn't show it (sometimes it shows but i don't know how) but it charges. I know it charges because -It's ridiculous- but you can go for hours with that '6%' battery.

    I've searched everywhere for a solution but no one seems to have the same problem as me.
    Thanks in advance.
    10-03-2014 04:25 AM
  2. GSDer's Avatar
    Welcome to the forums!

    Want to be sure I understand the problem - the battery icon won't show discharging activity; won't show charging activity; or both?

    Are you running the stock firmware?
    Rooted?
    Do you have any battery apps installed?
    Have you tried booting into Safe mode? http://support.verizonwireless.com/s...ase.html/59242

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    10-03-2014 02:53 PM
  3. Luminio's Avatar
    Welcome to the forums!

    Want to be sure I understand the problem - the battery icon won't show discharging activity; won't show charging activity; or both?

    Are you running the stock firmware?
    Rooted?
    Do you have any battery apps installed?
    Have you tried booting into Safe mode?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk

    Hello.
    Won't show both discharging and charging activity. Sometimes it shows discharging activity when i reboot it.
    Yes. I'm currently using CM10.2. But I had the same problem when I was running the original firmware.
    It's rooted.
    I have BatteryCalibration.
    No I haven't tried booting into safe mode.
    10-03-2014 03:34 PM
  4. GSDer's Avatar
    Sorry, I only have minimal exposure to CM (used it on my Nook for awhile before reverting back to the stock firmware), but assuming that it offers a battery percentage THAT would be your only indication of discharge.

    You should see the lightning bolt when the device is charging, and the red LED should go off at some point (once the battery gets above 15%?).

    If you turn the phone completely off and connect the charger do you see the battery graphic showing the current battery level and charging activity?

    Have you tried different chargers/cables?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    10-03-2014 10:21 PM
  5. Luminio's Avatar
    Sorry, I only have minimal exposure to CM (used it on my Nook for awhile before reverting back to the stock firmware), but assuming that it offers a battery percentage THAT would be your only indication of discharge.

    You should see the lightning bolt when the device is charging, and the red LED should go off at some point (once the battery gets above 15%?).

    If you turn the phone completely off and connect the charger do you see the battery graphic showing the current battery level and charging activity?

    Have you tried different chargers/cables?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    I have tried different cables. Yes.
    and I can see the charging activitiy when i turn it off completely
    Red LED goes off at 14% I think. I honestly don't know what's wrong with my phone. It's not about charging port. It's not about the ROM.
    10-04-2014 03:47 AM
  6. predator519's Avatar
    I have tried different cables. Yes.
    and I can see the charging activitiy when i turn it off completely
    Red LED goes off at 14% I think. I honestly don't know what's wrong with my phone. It's not about charging port. It's not about the ROM.
    Try safe mode
    11-05-2014 02:59 PM
  7. GSDer's Avatar
    I can see the charging activitiy when i turn it off completely
    I'll have to disagree with your assessment - if the phone is showing the correct charging activity when the phone is off then it sounds like the current firmware is at fault. I'd suggest reloading the stock firmware and clearing the system cache and performing a Factory Reset and see what happens.
    11-06-2014 10:44 PM
  8. Arif Khusnul's Avatar
    Same problem with me.. Its carged but indicator not showed charging. Iv try change my rom but its not fix my problem. Hope master can fix this problem. Regrads.
    05-01-2016 01:09 AM
  9. RYM87's Avatar
    Hi I am Rolly and I'm using samsung vivalto known as in our country as galaxy v.
    I've got two questions about my device. I'm looking for a solution of it and I saw this
    forum and so I joined here expecting for some answers.

    1.First of all my phone was not charging in an off mode. The battery icon i used to when I charged it
    never displayed anymore. The power too won't work if a charger is connected to it. I unplug the
    charger then the power button works. And the charging activity just work on when it's turned on.
    Could it a problem was a program, software or else or might be it's electronic parts?
    My phone don't connect to a computer too. I tried any lightning cable on it that fits but
    it doent work at all even though I enable the USB Debbugin mode.

    2. I was done to undergo to a rooting my device using an application kingroot.
    I'ver deleted some unwanted system apps but accidentally some of it's apps that should be kept
    was deleted. The phone dialer, sim tool kit #1 & #2 coz its a dual sim unit. How could
    I put or retrieve it back? Now my phone is futile... I doesn't connect to a network.
    "Com.Android.phone.has stopped" message keep appearing whenever I went to tap the sim manager
    and i know it was the sim tool kit loss and dialer.

    Sorry for my english, i wast fluent to use it but im trying. I hope somebody could help
    me through it.
    #RYM
    07-07-2016 05:12 AM
  10. B. Diddy's Avatar
    Hi I am Rolly and I'm using samsung vivalto known as in our country as galaxy v.
    I've got two questions about my device. I'm looking for a solution of it and I saw this
    forum and so I joined here expecting for some answers.
    See response in your other thread: http://forums.androidcentral.com/mor...-gs-313hz.html
    07-08-2016 02:04 PM
  11. Daisy Hemrom's Avatar
    Hello everyone.

    My phone has been doing this thing for the past 3-4 months. I changed the battery. I even tried another ROM.
    The problem is, my phone is charging properly, there is no battery drain etc. But the battery status icon won't show it.
    When i charge it fully, it stays on 100% and i can't see it going down unless i restart the phone. Then when it's at around 6% battery i start charging it again. Battery status icon doesn't show it (sometimes it shows but i don't know how) but it charges. I know it charges because -It's ridiculous- but you can go for hours with that '6%' battery.

    I've searched everywhere for a solution but no one seems to have the same problem as me.
    Thanks in advance.
    11-08-2017 10:20 AM
  12. chow master's Avatar
    almost same problem with me... my sony ericsson xperia ray ST18i... the led icon is turn on but the battery icon was not indicating a charging mode but it keeps on discharging and fast... i tried every piece of advice but nothing happens.. battery is 100% working.. i charge the battery on a universal charger as for now..
    05-22-2018 06:26 AM

Similar Threads

  1. Replies: 5
    Last Post: 10-04-2014, 07:29 AM
  2. Replies: 2
    Last Post: 10-03-2014, 01:29 PM
  3. Replies: 1
    Last Post: 10-03-2014, 12:23 PM
  4. Could my G2 battery perform better?
    By Enigma07 in forum Sprint LG G2
    Replies: 1
    Last Post: 10-03-2014, 03:41 AM
  5. Why does my phone lock after making a call?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-03-2014, 03:38 AM
LINK TO POST COPIED TO CLIPBOARD