1. AC Question's Avatar
    Samsung S3 mini phone.
    Samsung Tab2 10"
    Samsung Tab3 7"
    All my devices have auto update on apps etc.

    When accessing Google Play Store up I no longer get sent to the usual search menu offering apps etc, I now get sent to a page where I can see my image/profile and options to choose from -
    1- redeem
    2- settings
    3- help and feedback
    4- about google
    I choose my profile and then the search magnifying glass icon to search for whatever, I choose an app and two seconds later whilst loading I get the same message -Unfortunately Google Play Store App stopped working.

    I just tried downloading an app on my mobile from playstore and it seems to be fine, yet still no luck on my tablets.

    Please help me find a solution.
    04-01-2015 02:03 PM
  2. VW Maverick's Avatar
    Welcome.
    What an odd occurance.
    On each device, go into the Play Music App and clear the cache and data, restart and see if that helps.

    Mav.
    04-01-2015 03:14 PM

Similar Threads

  1. Replies: 2
    Last Post: 04-01-2015, 07:58 PM
  2. Replies: 1
    Last Post: 04-01-2015, 05:29 PM
  3. How do I root my Moto G?
    By AC Question in forum Moto G (2014)
    Replies: 1
    Last Post: 04-01-2015, 03:18 PM
  4. Replies: 1
    Last Post: 04-01-2015, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD