1. coredump's Avatar
    Is it me or the S3's Automatic Brightness is a bit dark? I noticed it's a bit darker than my old Droid X's Automatic Brightness.

    The S3's Automatic Brightness seems a bit finicky. In constant indoor lighting, it's usually a bit darker than what I am expecting; sometimes it's brightens up for a little bit.

    I just want to make sure my light sensor isn't busted. If it's a software feature for power saving, then I won't be too worried about it (even though it's annoying). I should probably goto a Verizon store and compare the brightness with their demo S3.

    Thanks!
    07-12-2012 03:14 AM
  2. Kench33's Avatar
    My droidx does the same thing, but it brightens up more. I just keep the brightness around half on the sg3

    Sent from my SCH-I535 using Android Central Forums
    07-12-2012 07:54 AM
  3. coredump's Avatar
    My droidx does the same thing, but it brightens up more. I just keep the brightness around half on the sg3

    Sent from my SCH-I535 using Android Central Forums
    Did you mean your GS3 does the same thing? Not your Droid X?
    07-12-2012 01:22 PM
  4. Kench33's Avatar
    I meant they both do the same thing. It seems like the screen is almost at 0 when I have it on automatic. I just keep it at 50%-75%

    Sent from my SCH-I535 using Android Central Forums
    07-13-2012 02:24 AM
  5. li2327's Avatar
    I have a sgs2 but have the same brightness problem. I take it off auto brightness and it still gets dim.
    07-13-2012 03:19 AM
  6. qdtphotog's Avatar
    I also came from the droid x and agree that the S3 auto brightness is much dimmer compared to the droid x. I guess we'll just have to get used to the way the new device works.
    07-13-2012 06:39 AM
  7. WilburNJ's Avatar
    I have a sgs2 but have the same brightness problem. I take it off auto brightness and it still gets dim.
    Some apps seem to have the auto brightness feature built into that app itself. For example, the browser has one, which I disabled. Now the websites I go to don't appear too dim. Check in the settings section....
    07-13-2012 07:53 AM
LINK TO POST COPIED TO CLIPBOARD