1. tsims10s's Avatar
    The Sandisk 64gb Mobile Ultra sdxc class 6 card initially would not work in my USCellular Galaxy S3. The phone would say something like "Preparing SD card" and then it would say "Safe to Remove Card", but it wouldn't give me an option to format it or use it at all. It was recognized by my PC in a card reader so I knew the card should be ok. I spent about thirty minutes on the phone with USCellular with a support person who seemed to be totally in the dark about my problem. Finally, on a "gut feeling" and in desperation, I inserted it into my old Sprint Epic 4G Touch where it was recognized and I was able to format it. I took it out of the old phone and reinserted it into my S3 and it was recognized immediately. I just thought I'd try to help out anyone else who might have had this problem, because I don't think I would ever have gotten an answer from USCellular's tech support.
    07-13-2012 11:43 PM
  2. barregb's Avatar
    I'm having the exact same problem on my US Cellular S3. I don't have another phone to try to format it with, so any ideas?

    My PC (Windows 7) recognizes the card and I was able to format it to both NTFS and exFAT, but with exFAT, I'm having the same problem/message you were. When formatted on my PC with NTFS, the phone doesn't even recognize the card, says that there is a blank SD card and doesn't have an option to format it on the phone.
    07-19-2012 09:41 AM
  3. barregb's Avatar
    I wound up resolving this similarly to the OP. I asked a co-worker who has a Verizon Droid if he could try to format on his phone. He was able to, and then it worked on my S3 afterwards. Maybe this is an issue specific to US Cellular S3's?
    07-19-2012 04:11 PM
  4. nelonez's Avatar
    I just popped mine in and it worked just fine.... i did format it on my phone before I started adding music, pics, and vids.....
    07-19-2012 11:06 PM
  5. 1marklor's Avatar
    I was having the same exact problem on my US Cellular S3. I ran across a review on Amazon of someone having the same problem. They downloaded a free program EaseUS Partition Master that I used to format the card on my computer to FAT32. Popped the card into my phone and works great. (hint - I made the mistake of trying to format the card with my phone after that - that just recreates the original problem and I had to reformat with
    EaseUS Partition Master again.) Hope this saves someone the hours of frustration I had trying to get this card to work
    07-30-2012 11:44 AM