07-11-2019 10:43 AM
92 1234
tools
  1. preemarose's Avatar
    My memory card was working fine then suddenly i read that the card should not be removed before it is dismounted. I have switched off my s3 taken out the 64Gb sdcard removed the battery put the card back and my s3 still keeps asking me to insert my card. I have even pressed on it in case of contact issues but it still does not recognise it is in the mobile. I have only had the card for a few days so it should not have a problem. Any other suggestions would be helpful
    chtvp and oragland like this.
    04-06-2013 06:47 AM
  2. BiRONIC's Avatar
    UPDATE:
    If you have experienced this 'SD card unexpectedly removed' problem,
    please go to the following defect issue, and click the star to register yourself as another user with the problem...
    Issue 9736 - android - SD card unexpectedly removed error LG Ally - Android - An Open Handset Alliance Project - Google Project Hosting

    Also, please add this note and link to the OP to hopefully catch people when they first see this thread, and encourage them to go there and register before getting lost in this rabbit hole (i.e. a real solution might not exist outside of fixing some code somewhere within the OS itself).
    Vignesh Ragav likes this.
    04-15-2013 07:23 AM
  3. Chris Suzuki's Avatar
    Im having the same problem..sd card unexpectedly removed..it was working just fine before the jb update..i went to play store to download an app ...sd card moniter..and found it was unmounting and re mounting quit a bit..so i removed the sd card all together..as it chews through my battery..Please make samsung update ther jb to fix rhis problem..my card is a 32 gb sandisk card ...i have heard the buying a samsung sd card solves this problem..but stuff that i paid $100 dollars for this one..and i should still be able to use it!!! Im not spending more money..samsung needs to adress the problem.
    05-01-2013 11:23 PM
  4. officechris's Avatar
    I've had the same problem over the last few months with my S3 as well. To me, it seems like it's a mechanical issue.

    Turn on the phone, open the back, insert the SD card, but HOLD it in place. It's like a push button, if you hold it as tight as it goes in, it detects and installs just fine. Release tension on the SD card slowly, (locking it in place), and it goes to "removed".

    For whatever reason, the pins are fully touching the contacts when you release tension on the SD card. It may be touching initially, but it may start to slip as the phone gets used, causing more frequent issues.

    No way I could tape it place, too much force pushing back on the SD card.
    05-07-2013 10:14 PM
  5. Rob Hamilton 1's Avatar
    The fix i found... put it in you PC card reader. Browse it, quickly check that everything is there and it's the right card; put it back in the phone; power up and it's back. This has worked every single time for me. Restarting the phone, or re-seating the card never done a thing for me. The 8 gig card I had before this new one worked fine and never had an issue. The new card that is randomly unmounting is an ADATA brand class 10 32 gig. Nice large and fast. I too think it's a hardware issue... the sd card reader in the phone might become unstable with the larger cards or the faster class cards.

    f you have experienced this 'SD card unexpectedly removed' problem,
    please go to the following defect issue, and click the star to register yourself as another user with the problem...
    Issue 9736 - android - SD card unexpectedly removed error LG Ally - Android - An Open Handset Alliance Project - Google Project Hosting
    05-08-2013 12:10 PM
  6. jonickthornton's Avatar
    I was having the same issue with my GS3 so I went to Samsung's website and did a live chat. After chatting with them the problem seems fixed (knock on wood). They told me to do 2 things: First: Remove the Battery for 30 seconds and then put it back in and start the phone. Second: Follow theses steps:
    1 Power the device off (remove and re-insert the battery).
    2 Press and hold the Volume Up key and the Home key, then press and hold the Power key.
    3 When the first boot screen displays; release only the Power key.
    4 When the Android system recovery menu displays; release the Volume Up and the Home key.
    5 Navigate with the Volume keys to the wipe cache partition and press the Power key to select

    I'm not sure which part was the one that worked however so try both.

    EDIT: Right after I posted this it came back... Chatting with them again we'll see if it helps any.
    05-28-2013 10:37 PM
  7. urban_smurf's Avatar
    Hi all,
    Similar problem here. I've got the Galaxy Media player 4.2. Worked fine for a month or two, then started seeing SD card problems. I get 'SD card unexpectedly removed' 'preparing SD card' 'unable to read SD card' 'damaged SD card' all at various times....restarting my player, after quick-swipe starting my player, even during playing music on the default player sometimes I'll get "media file is not supported" and the music stops. Doesn't matter if its switching songs or in the middle of the song. I know they are correct formats cause I can restart and get the songs to play no problem. I've restarted the player, reformated the player (both in my computer and in the player), taken the card out and back in. The only thing I haven't yet tried is to try the SD card in another device, only because I have no other device. I'm hesitant to believe its the SD card since so many others are having problems, and cause I spent some cash and bought a nice SanDisk ultra micro SDHC 32gb.
    To boot, I've never dropped the player, and have always kept it in a protective case (Ringke SLIM). The push-click holder for the card seems to be fine.

    I'm was converted from ipod hardware for the convenience of drag-and-drop, and accessability to other programs like adobe, word, etc. etc. However, this problem nearly makes the whole player useless since 4gb internal storage is a joke.

    Has anyone found any reliable solution to this problem??
    06-04-2013 01:34 AM
  8. lazy_hoor's Avatar
    Bump!

    I've got a new S4 with a new SanDisk 64gb card. Constant 'SD card removed' messages. Has anyone found Samsung SD cards to work better?
    DAFTEK likes this.
    06-04-2013 07:01 AM
  9. amiller012803's Avatar
    First scandisk card died after 2 day's. I did some research and scandisk stated they had a batch of bad cards. I replaced my cats and no issues so far. 64 gb

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 4 Beta
    06-04-2013 07:09 AM
  10. chtvp's Avatar
    I have smae Problem with my S3 and it makes me angry because non stope my phone restarting even sometimes middle of typing in fb or skype or any other application
    please if anyone who have knowladge about fixing of this problem kindly share your information
    thank you
    06-16-2013 01:35 AM
  11. tommykat's Avatar
    Same issue, but fixed it. All I did was remove the battery, sd card, and sim for about 15min. Then reinserted everything and booted back up. All works again. Picture and videos on SD card reappeared.
    06-25-2013 03:50 PM
  12. ardhill's Avatar
    I have a HTC Desire HD

    The other day I got an unexpected error message on my phone that the SD card wasn't recognised or wrong file system. I tried it in my computer and it didn't recogise it either. Interestingly, this was after I moved a bunch of images from the phone to Dropbox.

    I then bought a new card - a Class 10 32GB Micro SD. I started installing apps, but had the "SD Card Unexpectedly Removed" error message again and again. So, I did a factor re-set and erased the SD card. The phone was bare and card formatted by the phone, I started to add apps and my details. As soon as tried installing a large app (on the phone) I got the "SD Card Unexpectedly Removed" error??? This happened a couple of times before I gave up.

    Other apps installed just fine, but this was a pretty big Sat Nav app. Then I tried moving apps to my card. Tiny apps moved just fine, bigger (normal sized) apps give me this error again.

    It looks like a problem moving big lumps of data on my phone.

    I have had this phone for ages without any problems really, until now.
    06-26-2013 06:03 AM
  13. ardhill's Avatar
    I just bought a new SD Card - a Samsung Ultra. Put it in my phone and everything appears to be working just fine now. I did this after reading more people having problems online, and the common denominator appeared to be one particular make of SD Card, 32GB, class 10. So, I bought a Samsung card, which I thought may be good quality, and wasn't the make that kept being mentioned.
    06-27-2013 02:21 PM
  14. Mauricio Franco's Avatar
    Me too... exactly the same
    07-04-2013 02:13 AM
  15. MichaelCherry's Avatar
    my phone did the same thing, i had to replace the sd card, working ok so far, beside all the dropped calls signal issue but they are fixing it now,,, we shall see,
    07-04-2013 07:22 AM
  16. 1kulsol's Avatar
    I've got a new S4 with a new SanDisk 64gb card. Constant 'SD card removed' messages .. Samsung definitely needs to resolve this issue!!
    07-06-2013 08:45 AM
  17. CCSupport's Avatar
    +1 for the issue! I am having this issue with two different MicroSD cards on a brand new S4 & Tab 2 10.1 !!! Here's the shocker...I have two MicroSD Cards, a 32GB SanDisk Ultra & a 16GB Class 10 Samsung....when using either of the cards in the S4 or Tab I constantly get the 'SD Card Removed Unexpectedly'....HOWEVER I also have an old S2 and BOTH cards work perfectly!! That sums up this issue!

    I have formatted both cards using the Format SD Card on the phones/Tab and also formatted using a Win7 PC with FAT & exFAT....PLUS I have formatted on a Linux box just in case....guess what...no difference at all. All works well with the bloody old S2 but not on my newly purchased Samsung goods

    Ludicrous!

    **EDIT**
    I have just noticed that most posters on this thread have only one or two posts to their name, like me....that says a lot that this issue is effecting MANY new users!!
    07-12-2013 06:30 AM
  18. Alexmxperia's Avatar
    I had this same problem when I had my s3 the reason is because it's a used card for some reason it doesn't like them I never tried to format it though which would probably have helped.

    Posted via Android Central App
    07-12-2013 06:34 AM
  19. CCSupport's Avatar
    Sadly the not being a new card doesn't stack up as one of my cards came straight out of the packaging into the phone I have since bench-tested both cards using a number of difference devices and software and both have come out normal...smells more like a hardware or OS fault to me.
    07-12-2013 07:22 AM
  20. CSIgirl30's Avatar
    Hi I have a straight talk phone and had the same problem the phone would unmount, remount, say the SD card is damaged. It would reboot at random times so this might help you. I did my research and found that other people were having the same problems and it is because the some phones are not equip to handle the newer high speed cards. What's crazy is that the card that came with the phone was the same way it is not able to handle a lot of apps so when you load a certain amount on your phone it overloads it and the phone starts dropping the apps. So the solution is to get an SD card that is either a class 2 or 4 and install it, they have them at walmart for less than ten dollars. I did this and it fixed my problem hope it helps you also. I think its crazy that they do not tell you this with your phone.
    uncbutterfly likes this.
    07-25-2013 11:11 AM
  21. Svein Berg's Avatar
    I had the same issue with S4 and a 64 GB Sandisk card. I also have a 32 GB Sandisk card that works fine, so I figured it was an issue with the 64 GB card. I returned it to Sandisk and received a new 64 GB replacement today, but after putting it in the phone I immediately got the "SD Card unexpectedly removed" error. So maybe this is an issue with 64 GB cards in general? My old S2 would read the card, but then the file system would corrupt after some use.
    08-08-2013 09:32 AM
  22. Phrayzur's Avatar
    I've got an AT&T SIII. I had it rooted within 10 mins of leaving the strore. I've run all sorts of different SD cards, roms, apps, tweaked the cpu, etc. I've never had this problem until about 2 weeks ago. My 32GB class 10 Lexan (lexar, lexor, something) card failed. Couldn't get it to work on the phone, PC, nuthin. So I grabbed another one. It worked fine for a bit but then started giving me the "SD card removed" error but it would read on the computer and sometimes in the phone. After I formatted an class 10 Patriot 64GB SD card with the utility you get from (whatever the professional body for SD cards is) as SDXC I put it in and it wouldn't recognize it. It did work in the computer I changed it to fat32 and it would recognize it but it wouldn't let me write to it. I put my good(ish) newer 32GB card back in and it's still working the same, reads and writes, but I keep getting the same error.

    I don't know if it might be connected in any way, but I'll mention it because I've seen people sometimes mentioning both but not as connected... I'm also have a hell of a time with my WiFi. It might be Cyanogenmod 10.1.2, but I figured I'd throw it out there...
    08-23-2013 08:44 AM
  23. Ahmed Al Samraie's Avatar
    I have the same problem too on my htc desire hd. I changed the SD slot 2 times in the htc company in Lebanon and its work for 2 days and 1 day only and then get the same error Unexpected sd card unmount I did many things but no solv plz. anyone know how?
    09-13-2013 02:53 PM
  24. secretunicorn561's Avatar
    mine i try like 500 time still cannot my phone is samsung galaxy ace 1
    any tips or solution?
    is it the phone or the SD card?????
    11-11-2013 02:02 AM
  25. secretunicorn561's Avatar
    My Sd card is a old one. I bought a new one and try it again still cannot but whenI try on my old phone it worked
    11-11-2013 02:09 AM
92 1234
LINK TO POST COPIED TO CLIPBOARD