07-11-2019 10:43 AM
91 123 ...
  1. Bsk8r999's Avatar
    My phone keeps saying "sd card unexpectedly removed.. Preparing sd card". I think I've limited this problem most of the time to when my phone is on a hard surface such as a table and I press anywhere on the phone with even a slight tap such as typing etc. I haven't encountered it with really any other scenarios , i've even tried smacking it in my hand and that doesn't even bring up the error ,but it is perplexing. It's a brand new flagship phone how can this be? Is it because the back cover is so flimsy and any pressure bumps the SD card, or is the SD card too sensitive.. Any thoughts or fixes?
    Thanks AC community
    07-17-2012 02:48 PM
  2. funkylogik's Avatar
    are u using an external sd card? sounds more like a fault with the card if u are but probably worth gettin it checked especialy if its internal memory thats the problem. ive never heard of this happening
    07-17-2012 03:29 PM
  3. durango992007's Avatar
    Saw this on the front page and figured i could put in my 2 cents even though i don't have this phone. My old lg ally used to do this all the time. Finally, after so many times of it doing what it did, my sd card became corrupted. Never found a solution to it, and Verizon always told me to factory reset to solve the problem. I always figured it was more hardware problem with the sd card reader than software. I would see if you couldn't get the phone swapped for a new one.

    Sent from my DROID RAZR using Android Central Forums
    07-17-2012 03:33 PM
  4. Bsk8r999's Avatar
    are u using an external sd card? sounds more like a fault with the card if u are but probably worth gettin it checked especialy if its internal memory thats the problem. ive never heard of this happening
    Yes external 16 gb sandisk micro sd. Never had a problem with my droid x, took it straight out of that phone and into the s3 it went.
    07-17-2012 05:39 PM
  5. funkylogik's Avatar
    does the sd work normaly when you arent gettin that error message? did u format it in the s3 when u put it in? i noticed my s3 wouldnt read any data from the sd taken from my old phone. had to format it for it to work.. was really annoying coz lost my own keyboard dictionary ive got it learning the words+slang i use from scratch again
    07-17-2012 06:35 PM
  6. Bsk8r999's Avatar
    No I didn't format because it has my music on it. And I din't have access to the original anymore, if I were to back the sd up on my comp the format sd in my phone do you think that would help?
    07-17-2012 06:40 PM
  7. funkylogik's Avatar
    youve nothing to lose if u back it up m8
    07-17-2012 06:47 PM
  8. 20blks's Avatar
    Happened to me once.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-17-2012 07:26 PM
  9. RazorOrange's Avatar
    I encountered this problem right after I first installed my sd card. I had used the card for a year in my HTC, removed all the files and folders except for my music and pictures before installing it in my S3. When the problem happened, I shut the phone down, physically removed the sd card and then reinserted it, making sure the card was in tight by not just inserting it, but clicking it once or twice to make sure the spring loaded tensioner was in the right position. I restarted the phone and haven't had a problem since. Give that a try, your card may be at odds with the spring in the slot (the one that ejects the card)
    funkylogik and tomvb2000 like this.
    07-17-2012 08:05 PM
  10. tomvb2000's Avatar
    +1 for RazorOrange. Just started getting the error today after the laptop bag the phone was in rolled off the chair. Figured the SD card may have come loose and made sure it was in tight. So far so good - hasn't happened again so far.
    07-17-2012 09:18 PM
  11. bway's Avatar
    I was having same problem on my galaxy s3 but it is now fixed. I got in contact with samsung customer support and they told me it is best to insert the card while the phone is off. I did that with no success only for them to tell me to take the battery out then insert the sd card, put the battery back in and power up...it worked for me! i also formatted the sd card to "exFAT" first so you can try my way and hopefully it works for you too!
    BobbyC#AC likes this.
    08-01-2012 09:39 PM
  12. BobbyC#AC's Avatar
    I was having a similar problem but different :-).

    I bought a 32gb Class 10 MicroSD and formatted in the phone. I unmounted and plugged it into my computer to copy some music and movies and reinstalled it into my S3. The files were there and everything read fine but I couldn't write photos I took to the SD card.

    I just unmounted the card, turned the phone off and removed the battery. I pulled the card and reinserted it and lightly pressed down where the contacts of the card is (with the card inserted). Booted up and now my camera photos are writing to the SD card.

    Thanks bway!
    10-06-2012 02:22 PM
  13. GSDer's Avatar
    I also formatted the sd card to "exFAT" first so you can try my way and hopefully it works for you too!
    bway, please note that there have been mixed results reported when the SDCard is formatted as ext3 - you may want to do a search and review that information before relying on that configuration.
    I didn't have any problems, but I also wasn't storing lots of music. I finally reformatted my SDCard as FAT32 in the hopes that it would work with ROM Manager, but it doesn't (due to some issue with that app, but that's a different story).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    funkylogik likes this.
    10-06-2012 04:19 PM
  14. MagsGTA's Avatar
    Mine started doing this after the last load of updates. It is doing it MANY times every day now which is incredibly annoying.
    I am using a card that I already had for my Samsung phone and when I went to buy a new card, the local phone supplier told me to remove the card and let the new phone format the card. He suggested that I try this before I lay out $50 for a new card.
    Just off to try this now, will come back in a few days to advise if this fixed the issue.
    11-06-2012 08:00 AM
  15. Livia.'s Avatar
    I was having this problem too. It started when I was copying some files to the sd card and got a call in the middle of the process.
    Suddenly it stoped doing that. Everything seems fine since yesterday. I don't know what happened.

    Sent from my GT-I9300 using Android Central Forums
    funkylogik likes this.
    11-06-2012 09:08 AM
  16. Wael Allam's Avatar
    Hi I had the same issue "SD card unexpectedly removed" and it happened when I turned on bluetooth and used my earphone. Eversince I keep receiving the same message. I bought a new SD 16G and turned off bluetooth before using the new one and it never happened again and kept my photos and music since then.
    11-12-2012 03:37 AM
  17. msankadi's Avatar
    I received this message a few times 2 3 days ago followed by an error which said blank sd card unsupported format.. but after I took out he battery from the phone and started it again everything was fine again
    .. hope this helps

    Sent from my GT-N7000 using Tapatalk 2
    funkylogik likes this.
    11-12-2012 04:09 AM
  18. funkylogik's Avatar
    s3 just isnt happy with SD cards eh
    any1 had any issues with Sammy sd cards in the s3?
    that would be great

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    11-12-2012 04:21 AM
  19. robsawalker's Avatar
    Hi there

    I have an international S3 on O2 in Uk, running jellybean and it does it. It is very tedious and annoying. I changed to an android phone from an iPhone due to the 'drag and drop' advantages... only to find I cannot connect to my macbook by cable in any way and my windows laptop keeps doing this or crashing the USB drivers! Sort it out Samsung!
    11-15-2012 03:55 AM
  20. lovinglf's Avatar
    This just happened to me with a brand new Sandisk microSD card on my brand new Samsung Galaxy Reverb. On my old LG phone I was able to copy files to the SD card using the SD Card Reader and then just mount the SD card. Samsung seems to be a different beast though because after I copied music and picture files to the new SD card using the SD Card Reader I constantly received the SD card unexpectedly removed error. I unmounted the card, removed the battery, reinstalled the card and restarted the phone but it made no difference. Since I have all the files on my PC I just reformatted the card and erased my data. I had to format twice before the phone recognized the SD card and successfully mounted it. After that I just connected the phone directly to the PC and now the phone is using something called the MTP application to transfer picture and music files. No more error messages though but the MTP application seems to be very buggy and quits very often. Ugh! I finally got around this problem by copying smaller chunks of data at a time.
    11-25-2012 02:42 AM
  21. jennysmate's Avatar
    I've had this too, since mooving to jb. Now cant drag and drop onto card and have to put it into my D2 mp3 player to drag files from pc. I always use "unmount sd card" in settings before removing card from S3 and so far have had no problems
    11-25-2012 05:35 AM
  22. giorgitd's Avatar
    Same here, Verizon GS3. Had a 32Gb Adata mSD that was failing to be recognized occasionally. Formatted and loaded with music outside the GS3 as FAT32. Substituted a new SanDisk 32Gb mSD, set up the same way, now failing in the same way, including occasional 'unexpectedly removed' messages. Tried all of the mechanical 'fixes'. In both cases, the problem was evident for some time (a month or more) then started and persisted. Very frustrating. Verizon - you listening?
    11-28-2012 08:58 AM
  23. Surjith k's Avatar
    I do have the same problem.. it happened a number of times, i used to format the memory card to resolve this issue

    Suddenly the phone shows SD card removed unexpectedly , then i wont be able to use the SD card. but if i put the same sd card in anyother memory card reader, i am able to use it. only the mobile is failed to detect.. but it works fine after the format..

    So what u think ? its the memory card issue or the phone ?
    11-29-2012 12:00 PM
  24. Vishnu Prasad's Avatar
    I had the same problem. I have dropped my phone many times due to carelessness. First time my memory card has to be replaced because it was permanently damaged, and none of my devices was able to recognise the memory card. I bought a new card and few days back I dropped it again. Since then it began showing the message - memory card removed unexpectedly, preparing memory card.....

    This(my problem) is due to some kind of corruption in the memory card. I dont know, this is the second time the card is damaged when the phone is dropped. My phone have no other problem, not even a scratch, and the fall was from a height of about 0.5 feet only.

    To solve the issue, just connect the memory card through a card reader in computer and format it. Do not use quick format. In windows, connect the memory card through a card reader, when the card is detected and drive icon is shown in my computer, right click the icon and select format. Remove the tick mark on quick format and use a regular formatting with fat32. It takes lot of time. It took more than an hour for my 16gb card. After that the error message wont appear again.! It could solve the problem if the problem is due to some kind of corruption, which may be due to any interruption during data reading/writing. Anyways, give it a try. It worked for me. .
    11-30-2012 04:15 AM
  25. malqasim's Avatar
    my dear ,
    you have to update the firmware , you will solve your problem . if not broken your mobile


    [Facebook URL redacted by Mod]
    12-07-2012 11:03 PM
91 123 ...