1. iron330's Avatar
    New member here saying hello. I have a Galaxy S3 (AT&T) that will not connect to my Airport Extreme at home. S3 connects with no issues to all other (public) WIFI spots. I'm on an iMac i7 OS X 10.7.4. Our Powerbooks, my wife's iphone, and my old iphone 3GS connect to our network always, no issues. Of course, they're all Apple products! I log in the S3 with password, it says saved, secure. Unfortunately, the Galaxy S3 just sees the network, but never actually connects. Have reset Airport, Galaxy, etc., but nothing allows the S3 to connect. It says "connecting", but never completes the connection. Any ideas from those with Android phones on the Mac? I love the phone, it does everything VERY well, except this is quite a bugger for me.

    Regards,
    07-19-2012 09:42 AM
  2. EvilMonkey's Avatar
    I don't know if this will help since I don't use Apple products, but I was having some wifi issues that I think (too early to tell, but it's looking good) fixed it.

    Go into wifi on your phone and your network settings and click on the advanced button. Check to see if it's set for DHCP (which seems to be the default). Try switching it to Static and see if it helps. You'll need to re-enter the password as well.
    07-19-2012 09:48 AM
  3. ibcop's Avatar
    My father in law has an Airport as well and I have no issues with connecting. As soon as I'm in range, badda bing. I'm with Verizon.
    07-19-2012 10:00 AM
  4. gbb0131's Avatar
    I have the Time Capsule at home and have no issues connecting.
    07-19-2012 10:40 AM
  5. jimbo1mcm's Avatar
    Do a battery pull. Turn off the Router..Do you have a security code to enter? Is Wifi ON??
    07-19-2012 01:46 PM
  6. LadiJae's Avatar
    I have the Apple airport as well, neither myself or husband have had any connectivity issues....

    ~Jae, GS3 on Tapatalk~
    07-19-2012 01:58 PM
  7. iron330's Avatar
    Do a battery pull. Turn off the Router..Do you have a security code to enter? Is Wifi ON??
    Did all that, no workie. Yes wifi is on
    07-19-2012 02:23 PM
  8. jimbo1mcm's Avatar
    You can connect other devices, correct? ie. the router is putting out a good wifi signal.
    07-19-2012 02:40 PM
  9. iron330's Avatar
    Yes, and yes.
    07-19-2012 04:50 PM
  10. ibcop's Avatar
    Any chance you know anyone that has an S3 that can try to connect? Maybe to a swap and see if maybe the device is kaput?
    07-19-2012 08:02 PM
  11. iron330's Avatar
    Thanks all for the feedback Got it going using the link provided by this fella on android forums.

    I do not remember if the Airport broadcasts an adhoc network or not. Not sure if that is an issue. You can try some of the info in this link:

    Connect an Android phone to Mac OS X's Internet Sharing | Macworld

    Hope that helps.

    PS this is an Android to Airport issue NOT an S3 to Airport issue. If that helps any.
    http://www.macworld.com/article/1158...e_station.html
    07-19-2012 08:05 PM
  12. JayredB's Avatar
    What happens to me is that i connect and re connect constantly
    06-01-2013 07:59 PM
LINK TO POST COPIED TO CLIPBOARD