1. JRola's Avatar
    Hi all,

    New to the forum folks. My wife just got a new Samsung SIII. Very impressive. However I found a problem with it and your tips to solve it will decide whether or not to exchange it by an iPhone.

    I noticed that when accessing the Internet (Globe icon) the web page dims down to an unacceptable level. So I set the automatic brightness to off and slided the brighteness level to maximum. As expected everything brights up beautifully. But when I go to the Internet, the screen brightness dims down as before. Is like going from a level 10 to a level 4.

    While on the web page I also noticed that if I press the favorites bottom the page lights up bright for a fraction of a second but dims down immediately. Is this an hardware issue? A browser issue? Any Clues? I own a Samsung Focus (Windows) and do not see any similar problems with it.

    Thanks,

    Joaquim Rola
    07-22-2012 11:53 PM
  2. GK3K's Avatar
    One of the latest updates from Samsung removes the brightness control that segregates the browser brightness from the system brightness.

    For now, launch your browser and press the menu button. You will see an option called "Brightness and colors." Note that yours may only say brightness.

    Tap it and you will see that the browser has its own brightness setting. From there, you can disable it by unchecking the "Automatic brightness" option.

    From now on, your browser will match the phones brightness.
    07-23-2012 12:46 AM
  3. GK3K's Avatar
    I found a website that has pictures that may make it easier to follow: Fix Browser Dimming – Samsung Galaxy SIII
    07-23-2012 12:47 AM
  4. funkylogik's Avatar
    yeah it was annoying when i got the phone at 1st but as GK3K says, get the update. just download Samsung Kies on your computer and plug the phone in. DONT get an iphone lol!
    07-23-2012 01:15 AM
  5. bigslam123's Avatar
    Just turn off power saving. This is what tones down the brightness in the browser.
    Megan Hunt likes this.
    07-23-2012 10:45 AM
  6. GK3K's Avatar
    Just turn off power saving. This is what tones down the brightness in the browser.
    Power Saving Mode does a lot more than just adjust brightness.

    The OP was having issues in the browser, not system-wide.
    funkylogik and breegirl23 like this.
    07-23-2012 11:11 AM
  7. Roboticz's Avatar
    The browser has it's own individual brightness setting. While in the browser open up it's settings and you can change the brightness there.
    Vagrant_1 likes this.
    07-23-2012 02:13 PM
  8. yah00eu's Avatar
    Try Dolpbin HD browser. And you will Never go back to stock browser.
    07-23-2012 02:32 PM
  9. funkylogik's Avatar
    Try Dolpbin HD browser. And you will Never go back to stock browser.
    i always found dolphin a bit clunky but havent tried it on s3 yet
    07-23-2012 03:48 PM
  10. coolcontour71's Avatar
    why i didn't rhimk of that awesome
    10-02-2012 12:40 AM
  11. funkylogik's Avatar
    hope OP has updated the phone by now lol and not swapped for an iphone....

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    10-02-2012 01:14 AM
  12. breegirl23's Avatar
    I'm having the same problem... but I have t-mobile and they dont have the "Brightness and colors" option on the internet settings list. Does anyone know why? I'd like to fix this brightness issue.
    11-06-2012 01:21 PM
  13. breegirl23's Avatar
    What would you download from Samsung Kies so you can get that option on my internet settings?
    11-06-2012 02:54 PM
  14. funkylogik's Avatar
    What would you download from Samsung Kies so you can get that option on my internet settings?
    have you went to settings, about device, check for updates?

    if there are none. you can just run Kies, plug phone in and itl tell you if its up to date or install latest software. charge phone 1st

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    11-06-2012 08:56 PM
  15. scootone's Avatar
    I also was having problems with screen dimming when going into browser, once I had taken tick out of power saving in phone settings the brightness returned when browsing?
    12-12-2012 06:09 AM
  16. jeffreydh's Avatar
    Yes! Finally someone that knows--thank you! All of the other replies revolve around "settings" once in the internet app, none of which work/matter if you have Power Save on in the main phone settings. I thought it had something to do with the incognito function once in the internet app. If you know, please share--I don't even know how incognito got turned on or how to turn it off? Also, do you turn Power Save on and off depending on what your are doing? Just curious--thanks
    04-04-2013 01:49 PM
  17. duff24's Avatar
    None of this has helped me. When I change the brightness in the browser, it also changes the brightness for the whole phone! I haven't seen a good solution yet!
    10-10-2013 05:34 PM
LINK TO POST COPIED TO CLIPBOARD