1. spasypaddy's Avatar
    I have an orange (UK) S3.

    At home and at work I have wifi access.

    At home the phone works perfectly well on wifi, sends and received data no problem.

    At work it connects to the wifi network but does not send or receive data. I know the wifi is working as I currently have a client using it in the boardroom connected wirelessly.

    Anyone got any ideas?
    07-23-2012 09:22 AM
  2. chappo2000's Avatar
    It's not one of those wifi points where you have to launch the browser after you're connected so you can log in/accept the terms of use is it?
    07-23-2012 09:58 AM
  3. nelonez's Avatar
    You probably need a password to login... I know at my job we a guest account but u still need a password to connect....

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-23-2012 10:08 AM
  4. spasypaddy's Avatar
    nope, its a completely open unmetered wifi. complete separate internet connection to our wired work one.

    i have the SSID and the wifi code, my phone connects. loses the 3g symbol and then no data is transferred. Browser doesnt work. Whatsapp doesn't work. the moment i go back to mobile data it works fine.
    07-23-2012 10:53 AM
  5. Rev2010's Avatar
    I had this very same thing happen on my home wifi (but static IP). I'm an IT Tech for a living and everything was setup perfectly. matter of fact, it worked the first day I set it up but then every time after that day it would connect but not send or receive. Eventually I just deleted the profile for my home network then re-set it up from scratch with the IP, subnet mask, WPA2 key, DNS, etc etc and then it worked and has been working perfectly ever since and it's been weeks now.

    I would try deleting the profile, rebooting the phone for the heck of it, and then try connecting again. It's DHCP yes?


    Rev.
    07-23-2012 11:20 AM
  6. spasypaddy's Avatar
    tried that.

    i then open browser and go to the ip address of the router and it works but no actual data when i try to browse
    07-23-2012 11:54 AM
  7. goin_nil's Avatar
    My work has a limited # of IP addresses assigned and sometimes they run out. The IP addresses are leased for an amount of time so even though they might not all be used at the same time, they are held for certain # of hours after they get assigned and then expire with inactivity. This could be happening.
    07-23-2012 12:01 PM
  8. spasypaddy's Avatar
    goin_nil thanks for the suggestion but at the moment nothing is connected to the wifi its purely there for my mobile (noone else in the office has asked for the wifi code) and for when clients come in and need internet access.

    ive just connected again and the two arrows are lit up orange and green but the 4 semi circles above dont fill in like they do when im at home
    07-24-2012 03:42 AM
  9. funkylogik's Avatar
    its not a bt router is it m8?
    07-24-2012 04:30 AM
  10. spasypaddy's Avatar
    nope a netgear one
    07-24-2012 06:25 AM
  11. funkylogik's Avatar
    sound man. ive heard bad things about bt + ICS. duno then m8 lol
    07-24-2012 06:47 AM
  12. kaushal101's Avatar
    My office wifi requires our domain account authentication. I've maintained that. Internet works. But things like whatsapp and hangout doesn't work. I'm guessing push notifications etc. aren't working by default on my office wifi.
    06-12-2013 04:23 AM
LINK TO POST COPIED TO CLIPBOARD