1. Forgetful's Avatar
    Is there any way to load email in the stock app past the 1 month limit. In AOSP I remember you just scrolled to the bottom and could hit "load more messagss"

    Sent from my SCH-I535 using Tapatalk 2
    08-03-2012 01:37 PM
  2. Ricky Babalu's Avatar
    1 month Limit? Can you reference where it indicates that? I only get 1 week!
    08-03-2012 02:08 PM
  3. Forgetful's Avatar
    1 month Limit? Can you reference where it indicates that? I only get 1 week!

    open email app
    menu/ settings/ whatever email account you want / in here somewhere
    08-03-2012 05:37 PM
  4. meenas9's Avatar
    somewhere? where??
    since this morning i cant seem to view any emails past 2 days ago. not sure what happened all of a sudden. would like to have the option to view older emails also.
    Help!
    08-09-2012 03:15 PM
  5. Sailindawg's Avatar
    If you downloaded the missing emails to your pc email client, the emails are removed immediately from the stock email app. I don't get it. I ended up running my pop3 accounts through my Gmail account and use only gmail for sending/receiving pop3 account email. Much better solution.
    08-09-2012 06:30 PM
  6. Rev2010's Avatar
    If you're referring to the Gmail app, I don't see any other stock mail app, I just checked and you go into settings then select your email account and scroll down to mail days to sync and you can change it there. I use K-9 so if there's another stock mail client I'm not seeing please excuse me.


    Rev.
    08-09-2012 07:27 PM
  7. Rev2010's Avatar
    Found it, I had the stock app disabled. I took a look and there's a setting called recent messages or recent emails or something like that. In there is an option for "total". See if that fixes it?


    Rev.
    08-09-2012 07:34 PM
  8. AdamH5000's Avatar
    Assuming you are using the stock Email app for Android, use these steps:

    First, open the app > see the 3 dots in the top right corner? tap that > tap Settings > tap Manage Accounts > tap your email address > tap Sync settings > tap Period to sync Email > select desired range (example: "All" to see every email)

    Now you've changed your settings, arrow back until you reach your inbox. If you still don't see your emails, tap the circular refresh arrow.
    05-31-2016 03:50 PM
  9. derloopkat's Avatar
    Assuming you are using the stock Email app for Android, use these steps:

    First, open the app > see the 3 dots in the top right corner? tap that > tap Settings > tap Manage Accounts > tap your email address > tap Sync settings > tap Period to sync Email > select desired range (example: "All" to see every email)

    Now you've changed your settings, arrow back until you reach your inbox. If you still don't see your emails, tap the circular refresh arrow.
    This doesn't work. Still shows emails for the last month. I have checked out on line using my laptop and can see older emails are there but my phone cannot access them.
    06-14-2017 12:35 PM
LINK TO POST COPIED TO CLIPBOARD