02-04-2013 01:21 AM
66 123
tools
  1. mechanicboy's Avatar
    I have the same problem. My galaxy nexus operated much smoother and faster. I wish I could run bare bones ics on my s3 but my phone won't root for some reason.
    09-21-2012 02:57 PM
  2. prembng's Avatar
    This seems to be working fine.
    11-21-2012 09:31 PM
  3. badelhas's Avatar
    My Galaxy S3 i9300 is more fluid, faster and smoother since the Jelly Bean update. I am with Nova Laucher, though, but I had it before the update. You should try it. Try to uninstall stuff you dont need and that might be slowing you down.
    11-22-2012 05:59 AM
  4. plumto66's Avatar
    WHOA!!

    I was "this far" from taking my brand new (3 days) S3 back until I tried this.
    .5 did the trick instantly. I'M KEEPING MY S3!!!
    12-02-2012 11:00 AM
  5. sfrrr's Avatar
    WHOA!!

    I was "this far" from taking my brand new (3 days) S3 back until I tried this.
    .5 did the trick instantly. I'M KEEPING MY S3!!!
    What does this mean? What is the trick? And what is.5?

    Sent from my GT-I9300
    12-02-2012 11:35 AM
  6. badelhas's Avatar
    WHOA!!

    I was "this far" from taking my brand new (3 days) S3 back until I tried this.
    .5 did the trick instantly. I'M KEEPING MY S3!!!
    What did you try?
    12-02-2012 04:15 PM
  7. EndlessDissent's Avatar
    What does this mean? What is the trick? And what is.5?

    Sent from my GT-I9300
    What did you try?
    You guys should read threads before you reply to them. From page 2:

    try this

    settings>Developer options> window animation scale (set it to 0.5x) and Transition Animation scale(set to 0.5x).

    that should speed things up a bit without any ill effects.

    let me know if that helps
    12-02-2012 06:55 PM
  8. badelhas's Avatar
    You guys should read threads before you reply to them. From page 2:
    Ahh, thanks. And you should try to answer in a less arrogant way to people. ;-)
    12-02-2012 07:12 PM
  9. David Strong's Avatar
    Agreed, my phone is so slow is ridiculous. I've closed every app that's unnecessary, it's not on power saver, there's no special apps open. Even opening sms, or the contacts takes 2 seconds. 2 seconds, I've timed it. What is going on???

    - - - Updated - - -

    I tried the developer options thing and it makes no difference. Cheers though.
    01-11-2013 11:07 PM
  10. David Strong's Avatar
    Hmm, the latest update has made my phone crash on at least 6 occassions. It restarts by itself, it's even slower than before. Has anyone else got this problem?
    01-11-2013 11:09 PM
  11. badelhas's Avatar
    I am experiencing this also
    01-12-2013 03:55 AM
  12. jdub1981's Avatar
    Sorry wrong forum
    01-12-2013 06:48 AM
  13. meyerweb#CB's Avatar
    This is NOT a slow phone. If it's gotten very slow, it's almost certainly because of the app(s) you've installed. First, do a reboot. If it's still slow, look at what apps are running in the background, and what apps are using cpu. The app System Panel is very good for this. If all else fails, factory reset.
    Steven Holman likes this.
    01-13-2013 09:38 AM
  14. Steven Holman's Avatar
    what i always do its tap settings > applications manager > (swype) to running applications tab >and you can touch on the offending apps to stop them. for things like google maps you will have to swype right to the next tab to directly force close apps. this way you wont clog your memory up on task killers and its the safest way to kill apps, *** annoying it is. all these apps are decoys. hope this helps

    p.s you can kill cached processes too as its like the turbo boost part of the phone basically
    01-18-2013 09:30 AM
  15. Steven Holman's Avatar
    Agreed, my phone is so slow is ridiculous. I've closed every app that's unnecessary, it's not on power saver, there's no special apps open. Even opening sms, or the contacts takes 2 seconds. 2 seconds, I've timed it. What is going on???

    - - - Updated - - -

    I tried the developer options thing and it makes no difference. Cheers though.

    try settings > applications manager > swype to running services and tap and stop. things like google maps are stubborn possibly because you have location services on. to kill apps like this keep swyping and find the apps, tap and force close
    01-18-2013 09:35 AM
  16. dazza27's Avatar
    I had the same problem since I upgraded to jelly bean. I tried factory resetting and removing apps.. Nothing worked.
    The developer options mentioned previously helped a little, but was still really sluggish.

    What eventually REALLY helped me - turning off all locations services!! It is now substantially better!! I can't believe it took this long. Hope this helps someone else.
    02-04-2013 01:21 AM
66 123
LINK TO POST COPIED TO CLIPBOARD